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PERCOBAAN 1 

Penggunaan ZEN Support Software 

 

A. Tujuan Percobaan 

- Mahasiswa dapat membuat program ladder menggunakan ZEN support software 

- Mahasiswa dapat mensimulasikan program ladder  

 

B. Teori Singkat 

Memulai dan mengakhiri 

Pada bagian ini akan dijelaskan cara memulai dan mengakhiri program zen support software: 

1. Pada Windows XP, pilih Start → Program → Omron → Zen Support Software → 

Zen Support Software; 

2. Gambar berikut akan ditampilkan. Pilih Create a New Program kemudian klik OK; 

 

Catatan: Pilih Load Program From Files, jika diinginkan membuka program ladder 

yang sudah pernah dibuat.  

3. Kemudian jendela dialog Property Settings akan ditampilkan. Pilih model Zen yang 

akan digunakan beserta konfigurasinya (yaitu apakah unit ekspansi I/O dihubungkan 

atau tidak), kemudian isikan nama projek (Project name) serta komentar (Comment) 

jika diperlukan dan klik OK; 

 

4. Maka Zen Support Software akan dimulai; 



 

 

 

 

5. Pilih menu File → Exit dari menu Zen support software untuk mengakhiri aplikasi. 

 

KONFIGURASI LAYAR 

 

    

 

Catatan: Bit-bit tampilan dalam memori Zen merupakan ”relai”, bit-bit masukan program 

merupakan ”kontak”, dari bit-bit keluaran program merupakan ”koil”; 
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BAR STATUS 

 

1. Model Zen yang terhubungkan  - menampilkan model Zen 

  yang dipilih sejak awal 

2. Status koneksi    - Status terhubungkan    

       (Online) atau tidak (Offline)   

3. Status Operasi (Kerja)   - apakah Zen dalam kondisi  

        RUN atau STOP (tampil saat Online) 

4. Komentar     - menampilkan penjelasan  

        operasi dan error-error yang terjadi. 
 

Diagram Rangkaian dan Program  Ladder 

Ladder Diagram menggambarkan program dalam bentuk grafik. Diagram ini dikembangkan 

dari kontak-kontak  yang terstruktur yang menggambarkan aliran arus listrik. Dalam Ladder 

Diagram terdapat dua buah garis vertikal dimana garis  sebelah kiri dihubungkan dengan 

sumber tegangan positip catu daya dan garis sebelah kanan dihubungkan dengan sumber 

tegangan negatip catu daya di internal PLC. Program Ladder Diagram ditulis menggunakan 

bentuk  simbol yang secara umum mirip dengan rangkaian kontrol relay (diagram listrik). 

Program ditampilkan pada layar dengan elemen-elemen seperti normally open contact, 

normally closed contact, timer, counter, sequencer dan lain-lain. Dibawah kondisi yang benar, 

listrik dapat mengalir dari rel sebelah kiri ke rel sebelah kanan, jalur rel seperti ini disebut 

sebagai ladder line (garis tangga).  Peraturan secara umum di dalam menggambarkan program 

ladder diagram adalah : 

➢ Daya mengalir dari rel kiri ke rel kanan 

➢ Output koil tidak boleh dihubungkan secara langsung di rel sebelah kiri. 

➢ Tidak ada kontak  yang diletakkan disebelah kanan output coil 

➢ Hanya diperbolehkan satu output koil pada ladder line. 

 

Di antara dua garis ini dipasang kontak-kontak yang menggambarkan kontrol dari switch, 

sensor atau output. Satu baris dari diagram disebut dengan satu rung. Input menggunakan 

symbol  [ ]  (kontak normally open/NO) dan [/] (kontak normally close/NC). Output mempunyai 

symbol  (  ) yang terletak paling kanan. 

 



 

 

 

 

 Konsep Ladder Diagram  

Sebagai persiapan membuat program ladder, pada bagian ini diterangkan hubungan antara 

rangkaian relai dengan program ladder. 

1. Program Ladder 

Zen menggunakan program ladder yang mirip dengan diagram rangkaian relai. 

  

Relay Circuit     Ladder Program 

Ry

SW1 SW2

  
  

2. Konfigurasi Dasar Program Ladder 

Zen mampu mengerjakan hingga 96 baris program, dengan setiap barisnya terdiri dari 3 

masukan dan 1 keluaran. Keluaran hanya dapat ditentukan/digambarkan di bagian kanan baris 

saja. Masukan tidak bisa digambarkan setelah keluaran. Perhatikan gambar berikut: 

 

 

 

 

Program ladder untuk masukan dan keluaran tersebut ditunjukkan pada program Zen Support 

Software seperti berikut: 

 

Masukan  
Pertama 

Masukan  
Kedua 

Masukan  
Ketiga 

Bit 
Keluaran 

3 Masukan 
1 Keluaran 



 

 

 

 

 

Bit-bit I/O dalam tabel berikut dapat digunakan dalam program ladder Zen: 

Simbol Nama 
Nomor bit 

(lihat cat. 1) 

Dapat digunakan 
untuk kondisi 

masukan 
(lihat catatan 2) 

Dapat 
digunakan 

sbg 
keluaran 

Fungsi 

I Bit-bit masukan Unit 
CPU 

0 – 5 Ya Tidak Berkaitan dengan 
terminal-terminal 
masukan unit CPU dan 
Ekspansi I/O 
 

X Bit-bit masukan unit 
Ekspansi I/O  

0 – 6 
(lihat cat.3) 

Ya Tidak 

B Saklar-saklar 
tombol 

0 – 3 Ya Tidak ON/OFF saat tombol 
ditekan pada unit CPU 
selama ZEN beroperasi 

A Bit-bit pembanding 
Analog 

0 – 3  Ya Tidak Membandingkan (, ) 
I4 dan I5, I4 dan suatu 
nilai serta I5 dan suatu 
nilai. Nilai tersebut: 0,0 
hingga 10,5 (3 angka 
desimal) 

P Bit-bit pembanding 
pewaktu/pencacah 

0 – f Ya Tidak Membandingkan nilia 
pewaktu/pencacah saat 
itu dengan setingnya 

@ pewaktu mingguan 
(lihat cat.5) 

0 – 7 Ya Tidak Pengaturan: ON/OFF 
antara hari-hari dan 
waktu-waktu yang 
ditentukan 

* pewaktu kalender 0 – 7 Ya Tidak Pengaturan: ON/OFF 
antara tanggal-tanggal 
yang ditentukan 

Q Bit-bit keluaran unit 
CPU 

0 – 3  Ya Ya Q dan Y berkaitan 
dengan terminal-
terminal keluaran 
Fungsi: dapat 
ditentukan keluaran 
normal (I), set (S), reset 
(R) atau alternatif (A) 

Y Bit-bit keluaran 
ekspansi I/O 

0 – b 
(lihat cat.3) 

Ya Ya 

M Bit-bit kerja 0 – f Ya Ya 

H Bit-bit Tahan 
(holding, lihat cat.6) 

0 – f  Ya Ya 

T Pewaktu 0 – 7 Ya Ya 

Masukan 

Pertama 
Masukan 

Kedua 

Masukan 

Ketiga 
Masukan 

Keempat 

3 Masukan 1 Keluaran 



 

 

 

# Pewaktu tahan 
(holding timers, 

lihat cat.6) 

0 – 3  Ya Ya Fungsi: dapat 
menentukan tundaan 
ON (x), OFF (▪), pulsa 
oneshot (o) atau pulsa 
berkedip (F) 
Pengaturan: 
00 det 010 mdetik – 99 
det 990 mdetik 
00 menit 01 detik – 99 
menit 59 detik  
00 jam 01 menit – 00 
jam 59 menit 

 
C Pencacah 0 – 7  Ya  Ya Fungsi: pencacah 

naik atau turun 

D Bit-bit penampil 0 – 7  Tidak Ya Fungsi:menampilk

an string, tanggal, 

jam, nilai 

pewaktu, nilai 

pencacah atau 
nilai konversi 

analog pada 

tampilan LCD unit 

CPU. 

D Bit-bit penampil 0 – 7 Tidak Ya Fungsi: 

menampilkan 
string, tanggal, 

jam, nilai 

pewaktu, nilai 

pencacah atau 
nilai konversi 

analog pada 

tampilan 
 

Catatan: 

1. Nomor-nomor bit disajikan dalam format heksadesimal  (0, 1, 2, ... , 9, a, b, ...f). 

2. Bit-bit yang digunakan sebagai kondisi masukan dapat digunakan sebagai kondisi 
normally open atau normally closed. 

3. Jumlah  bit yang dapat digunakan tergantung pada konfigurasi koneksi Unit Ekspansi 

I/O. 

4. Bit-bit pembanding analog dapat digunakan pada unit CPU dengan catu daya DC (ZEN-

10C1DR-D dan ZEN-10C2DR-D). 

5. Pewaktu mingguan (weekly) dan kalender dapat digunakan pada unit CPU yang 

memiliki fungsi kalender dan jam (ZEN-10C1AR dan ZEN-10C1DR-D). 

6. Jika catu daya dimatikan, pewaktu tahan (holding timer) akan menyimpan status 

ON/OFF dan nilai sebelum catu daya mati. 

 

 

 

 

 

 

 

 



 

 

 

 

3. Menulis/Menggambar Program Ladder 

➢ Aktifkan Zen Support Software, kemudian pilih Create a New Program dan klik OK; 

 

Jika Zen support software sudak aktif sebelumnya, klik tombol New pada Toolbar atau 

pilih menu File → New. 

➢  Layar Property Setting akan ditampilkan. Tentukan model Zen, konfigurasinya (yaitu 

unit-unit Ekspansi I/O yang dipakai), nama proyek dan komentar, kemudian klik OK. 

 

➢  Sebuah layar dalam format tampilan-ladder ditampilkan, kilk ganda pada posisi untuk 

kondisi masukan pertama. 

 

Catatan:  

posisi untuk bit-bit masukan dan keluaran dapat diset dengan menggeser geser atau 

menggunakan mouse untuk menempatkan pada suatu posisi kemudian 1) tekan ENTER, 2) klik 

ganda mouse, 3) mengklik tombol Insert Input atau Insert Output pada Toolbar, 4) Pilih 



 

 

 

Insert → Contanct/Coil pada Menu Bar, 5) pilih Edit → Edit pada Menu bar atau 6)   klik 

kanan mouse kemudian pilih Edit. 

➢  Kotak dialog Edit Input kemudian akan ditampilkan. Tentukan tipe bit, tipe masukan 

dan nomor bit (relay no.) serta masukan/tuliskan komentar jika diperlukan. 

 

Catatan: Pengaturan parameter juga harus ditentukan untuk pewaktu dan pencacah  

➢  Klik ganda pada posisi masukan berikutnya. 

 

Nama bit : I 

Input: Normally open 

Nomor bit: 0 

Komentar: 

CPUUnit input0 



 

 

 

➢  Kotak dialog Edit Input akan ditampilkan lagi. Tentukan tipe bit, tipe masukan, nomor 

bit dan komentar jika diperlukan, sebagaimana yang telah dilakukan pada langkah 4. 

 

➢  Pindah ke posisi bit keluaran dan klik ganda. 

 

 

Nama bit : I 

Input: Normally closed 

Nomor bit: 1 

Komentar: 

CPUUnit input1 



 

 

 

➢  Kotak dialog Edit Output akan ditampilkan. Tentukan tipe bit, tipe masukan, nomor bit 

dan komentar jika diperlukan, sebagaimana yang telah dilakukan pada langkah 4. 

 

➢  Pindah ke posisi masukan pada baris berikutnya dan klik ganda. 

 

 

➢  Kotak dialog Edit Input akan ditampilkan lagi. Tentukan tipe bit, tipe masukan, nomor 

bit dan komentar jika diperlukan, sebagaimana yang telah dilakukan pada langkah 4. 

 

➢  Klik dan geser (drag) mouse secara vertikal untuk membuat garis koneksi vertikal. 

 

Nama bit : Q 

Input type: Normally open 

Nomor bit: 0 

Komentar: 

CPUUnit Output0 



 

 

 

 

 

 

 

Dan klik-geser mouse ke kanan, hingga bit keluaran untuk membuat koneksi horisontal 

Kedua cara ini bisa dilakukan dengan tombol Insert Vertical dan untuk Insert 

Horizontal atau dengan menu Insert → Vertical atau Insert → Horisontal. 

Diagram ladder sekarang sudah lengkap/selesai. 



 

 

 

 

➢  Kemudian pilih menu ZEN → Program Check untuk memeriksa program. Gambar 

beriku akan ditampilkan jika tidak dijumpai adanya kesalahan. 

 

 

4. Menyimpan Program Ladder 

a. Menyimpan Ke berkas 

➢ Pilih menu File → Save As 

➢ Kotak dialog Save As akan ditampilkan. Tuliskan tujuan (folder) penyimpanan dan/atau 

mana berkas kemudian ENTER (atau klik Save). 

 

 Catatan: 



 

 

 

1. Saat menyimpan program ladder yang pernah tersimpan sebelumnya, bisa anda 

gunakan tombol Save atau pilih menu File → Save As untuk menumpuk berkas 

yang pernah tersimpan. 

2. Pengaturan sistem dan password juga ikut tersimpan. 

b. Membuka Berkas 

➢ Klik tombol Open atau pilih menu File → Open dari Menu Bar untuk membuka berkas 

yang pernah disimpan. 

➢ Kotak dialog Open File akan ditampilkan. Tentukan lokasi dan nama berkas kemudian 

klik tombol Open atau tekan Enter. 

 

 

 

 

 

5. Mengedit Program Ladder 

a. Mencari Masukan dan Keluaran 

➢ Klik tombol Find pada ToolBar atau pilih menu Edit → Find 

 

 

Mencari berdasar nomor baris Mencari berdasar tipe atau nomor bit 

  

b. Mengubah masukan, keluaran dan pengaturan 

➢ Untuk contoh ini, klik ganda pada keluaran Q0. 



 

 

 

 

➢ kotak dialog Edit Output akan ditampilkan. 

 

➢ Ubah tipe bit pada kotak dialog tersebut dari Q menjadi M (bit penyimpan, holding bit), 

tentukan fungsi dan nomor bit serta ketik/isikan komentar jika diperlukan. 

 



 

 

 

 

 

c. Menyisipkan Masukan 

➢ Klik ganda pada jalur koneksi program ladder seperti gambar berikut: 



 

 

 

 

➢ Gunakan atau lengkapi kotak dialog untuk menyisipkan sebuah masukan pada jalur 

tersebut. 

 

d. Menghapus masukan dan keluaran. 

 Gunakan mouse atau kursor untuk memilih bit masukan atau keluaran yang akan 

dihapus dan klik tombol Delete pada toolbar. Alternatif lain, pilih menu Edit → Delete atau 

tombol Del pada keyboard. 

➢ Geser kursor pada masukan ”CPUUnit Input 2” 

➢ Gunakan tombol Del pada keyboard, hasilnya: 



 

 

 

 

Catatan:  

Semua masukan dan keluaran di dalam area akan ikut terhapus dengan cara seperti ini (lihat 

pasal VI.6). 

 

e. Mengedit jalur-jalur koneksi. 

Gunakan salah satu cara berikut ini untuk menghapus jalur-jalur koneksi: 

➢ Klik-geser (drag) mouse sepanjang garis yang ingin dihapus; atau 

➢ Gunakan mouse akan keyboard untuk memilih jalur yang akan dihapus, kemudian: 

➢ klik tombol delete; atau 

➢ Pilih menu Edit → Delete; atau 

➢ Tekan tombol Del pada keyboard. 

Gunakan salah satu cara berikut ini untuk membuat jalur-jalur koneksi: 

a. Klik-geser (drag) mouse dari posisi yang diinginkan untuk membuat sebuah jalur baru; 

atau 

b. Gunakan mouse atau keyboard untuk menempatkan jalur baru yang dikehendaki, 

kemudian: 

➢ Klik tombol Insert Horisontal atau Insert Vertical; atau 

➢ Pilih menu Insert → Horisontal atau Insert → Vertical; atau 

➢ Tekan tombol ‘-‘ atau ‘|’ pada keyboard 

f. Memotong, menyalin dan Mem-paste 

Masukan dan keluaran dalam suatu area dapat dengan mudah disalin dan dipindah jika fungsi-

fungsi potong (Cut), salin (Copy) dan Paste digunakan. 

➢ Klik tombol Select Object pada toolbar atau pilih menu Edit → Select Object. 



 

 

 

 

Catatan: 

Pengeditan program secara normal, seperti memasukkan atau menyisipkan masukan 

dan keluaran, tidak dapat dilakukan setelah tombol select objects, ditekan. Untuk 

kembali ke mode edit program yang normal, klik tombol select Objects lagi atau tombol 

ESC. 

➢ Klik-geser mouse dari awal daerah ke akhir daerah yang dipilih, perhatikan contoh 

gambar berikut: 

 

 



 

 

 

 

➢ Untuk menyalin, klik tombol copy pada toolbar atau pilih menu Exit → Copy. 

Untuk memindahkan, klik tombol Cut pada toolbar atau pilih menu Edit → Cut. 

 Saat menyalin    Saat memindah 

  

 

➢ Pindahkan mouse pada posisi letak penyalinan atau pemindahan dan klik tombol Paste 

atau pilih menu Edit → Paste. 

 Setelah disalin    Setelah dipindah 

  



 

 

 

 

6. Mengedit Komentar 

Fungsi edit komentar digunakan untuk menampilkan atau mengedit semua komentar I/O 

berdasar tipe bit. 

➢ Pilih menu Edit → Edit Comments 

➢ Edit komentarnya di layar Edit Comment 

 

Catatan: 

1. Program akan lebih mudah dipahami dan disusun jika nama-nama piranti I/O yang 

sesungguhnya atau nama-nama yang berhubungan dengan suatu fungsi dituliskan 

dalam komentar I/O. 

2. Klik tombol Show Comments atau pilih menu View → Show Symbol Comments 

untuk menampilkan atau menyembunyikan komentar-komentar I/O pada layar 

program ladder. 

 

7. Mencetak Program Ladder 

a. Pengaturan Pencetakan 

Pada bagian ini akan diterangkan bagaimana mengatur layout dan heading yang harus dibuat 

sebelum mencetak program ladder. 

➢ Pilih menu File → Print_setup. 

➢ Kotak dialog Print_Setting akan ditampilkan. Lakukan pengaturan pada masing-

masing item. 



 

 

 

 

Pengaturan Penjelasan 

- Program frame display di- boks ini jika ingin mencetak frame 

- Parameter Setting information di- boks ini jika ingin mencetak 

pewaktu, pencacah dan parameter lain. 

- Print title di- boks ini untuk mencetak judul 

- Drawing name nama gambar 

- Figure no nomor gambar 

- Revision mark tanda revisi 

- Prepared by Nama yang membuat program 

- Date Tanggal pembuatan program 

3. Klik tombol OK untuk menyimpan pengaturan sebagai pengaturan pencetakan Zen 

Support Sofware. Atau klik cancel untuk membatalkan. 

b. Print Preview 

Klik tombol Print Perview atau pilih menu File → Print Perview untuk memeriksa Layout 

pencetakan. 

 



 

 

 

c. Mencetak 

1. Klik tombol Print atau pilih menu File → Print 

2. Kotak dialog Print akan ditampilkan, lakukan pengaturan jika diperlukan dan klik OK. 

 

 

   

Catatan : Tidak membuat laporan, buatlah folder dengan nama file  PLC dan simpan 

proyek anda 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

PERCOBAAN 2 

Operasi Logika (menggunakan ZEN Support Software) 

 

A. Tujuan Percobaan  

Mahasiswa dapat membuat program operasi logika menggunakan ZEN Support Software 

 

B. Alat dan Bahan Percobaan : PC terinstal ZEN support sofware 

 

C. Langkah Percobaan 

 

1. Operasi logika AND 

I0 I1 I2 Q1

 
➢ Buatlah program ladder diagram seperti gambar di atas (perhatikan teori percobaan 1). 

➢ Setelah selesai aktifkan simulator ubah jenis kontak input dengan cara arahkan cursor 

di push button -> clik kanan pilih alternate open contact. 

➢ Aktifkan saklar input seperti pada table data percobaan kemudian jalankan simulator 

dan run. 

➢ Amati nyala lampu (output) catat pada lembar pengamatan. 

➢ Simpan program anda! 

 

2. Operasi logika OR 

I0

I1

Q1

I2

 

 Ulangi langkah kerja seperti percobaan sebelumnya. 

 

 



 

 

 

3. Operasi Logika NAND 

I0 I1 I2 Q1

 

Ulangi langkah kerja seperti percobaan sebelumnya. 

4. Operasi Logika NOR 

I0

I1

Q1

I2

 

Ulangi langkah kerja seperti percobaan sebelumnya. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

DATA PERCOBAAN 2 

   

    Operasi Logika 

 

  

 Nama  : _________________________ 

 NPM  : _________________________ 

 Kelas  : _________________________ 

 Kelompok : _________ 

 Hari/Tanggal : _________________________ 

 

 Paraf  : _________ 

 

 

 

No Input  Output   

  I0 I1 I2 AND  OR NAND  NOR 

1 OFF OFF OFF         

2 OFF OFF ON         

3 OFF ON OFF         

4 OFF ON ON         

5 ON OFF OFF         

6 ON OFF ON         

7 ON ON OFF         

8 ON ON ON         

 

 

 

         Mengetahui. 

         Dosen/Asisten 

 

 

 

          

         ___________________ 

 

 

 

 

 



 

 

 

 

PERCOBAAN 3 

INSTALASI PLC 

 

 

A. Tujuan Praktikum 

- Mahasiswa dapat menghubungkan power supply PLC. 

- Mahasiswa dapat menghubungkan komponen-komponen eksternal ke input PLC. 

- Mahasiswa dapat menghubungkan komponen-komponen eksternal ke output PLC. 

 

B. Teori Singkat 

Umumnya PLC dioperasikan pada tegangan DC, tetapi beberapa PLC dioperasikan dengan 

tegangan AC.  

 

 

 

 

 

 

 

 

 

 

 

 

 

Gambar 1.1 AC power wiring 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

Gambar 1.2 DC power wiring 

Input PLC menerapkan opto-isolator berupa LED dan photo transistor, hal ini bertujuan untuk  

mengisolasi (tidak terhubung langsung) dengan perlalatan eksternal.   

 

 

 

 

 

 

 

 

 

 

 

Gambar 1.3 Typical Input Circuit 

 

Input-input PLC dapat dikonfigurasikan dengan dua cara yaitu common conection dan isolated 

inputs. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Gambar 1.4 PLC dengan Common Inputs 

 



 

 

 

 

 

 Gambar 1.5 PLC Isolated Inputs 

 

Ada dua jenis output PLC yaitu output relay dan output transistor. Untuk mengkonfigurasikan 

output dapat menerapkan common output atau isolated output. 

 

 

 

Gambar 1.6 Common Relay Output 



 

 

 

 

 

 

 

Gambar 1.7 Isolated Relay Output 

 

C. Alat dan Bahan Percobaan 

- Papan percobaan (trainer) instalasi PLC 

- Kabel penghubung (jumper)  

- Catu daya DC 24 Volt 

D. Langkah Percobaan 

1. Menghubungkan power supply 

- Identifikasi pisik PLC dan gambarkan pada lembar kerja berikut pengkabelannya 

menurut teori dan konsultasikan gambar tersebut  kepada asisten atau dosen. 

- Pasanglah kabel penghubung pada terminal catu daya  PLC (belum dihubungkan ke 

catu daya). 

- Hidupkan catu daya atur tegangan sampai 24 V, jangan melebihi nilai ini. 

- Periksa kembali dan laporkan kepada asisten atau dosen apakah pengkabelan benar. 

- Hubungkan kabel penghubung ke catu daya, amati keadaan PLC. 

2. Menghubungkan komponen-komponen eksternal pada input PLC. 



 

 

 

- Berdasarkan identifikasi percobaan sebelumnya lengkapi gambar untuk 

menghubungkan empat buah push button pada input PLC konsultasikan gambar 

tersebut kepada asisten atau dosen. 

- Pasanglah kabel penghubung pada terminal input dan push button PLC (catu daya 

belum dihidupkan). 

- Periksa kembali dan laporkan kepada asisten atau dosen apakah pengkabelan benar. 

- Hidupkan catu daya, minta kepada asisten untuk membuat program sederhana, pilih 

operasi PLC pada mode run kemudian monitor. 

- Amati keadaan display PLC apakah keempat push button telah berfungsi. 

3. Menghubungkan komponen-komponen eksternal pada output PLC. 

- Berdasarkan identifikasi percobaan sebelumnya lengkapi gambar untuk 

menghubungkan empat buah lampu 220 V pada output PLC konsultasikan gambar 

tersebut kepada asisten atau dosen. 

- Pasanglah kabel penghubung pada terminal output dan lampu 220 V PLC (catu daya 

belum dihidupkan). 

- Periksa kembali dan laporkan kepada asisten atau dosen apakah pengkabelan benar. 

- Hidupkan catu daya, pilih operasi PLC pada mode run kemudian monitor, amati 

keadaan display PLC dan keempat lampu telah berfungsi. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

DATA PERCOBAAN 3 

   

    Instalasi PLC 

 

  

 Nama  : _________________________ 

 NPM  : _________________________ 

 Kelas  : _________________________ 

 Kelompok : _________ 

 Hari/Tanggal : _________________________ 

 

 Paraf  : _________ 

 

 

Gambar Pelaksanaan Instalasi PLC 

 

 

 

          

 

 

 

 

 

 

 

 

 

Mengetahui. 

         Dosen/Asisten 

 

 

 

          

         ___________________ 

 

 



 

 

 

PERCOBAAN 4 

Penggunaan Output /Input 

 

A. Tujuan Percobaan  

Mahasiswa dapat membuat program macam-macam input dan output menggunakan ZEN 

Support Software. 

  

B. Teori Dasar 

ZEN Programmable Relay merupakan produk PLC buatan Omron, merupakan kontroler kecil 

yang menyediakan 10 saluran I/O (6 masukan dan 4 keluaran) yang dapat diprogram yang juga 

dapat diekspansi jumlahnya dengan perangkat keras tambahan. PLC ZEN jauh lebih murah dan 

kompak atau kecil dibandingkan dengan seri CPM,   maupun seri terbaru CP1. Saat ini  PLC 

ZEN telah ada   yang menyediakan 20 saluran I/O (12 masukan dan 8 keluaran). 

 

 

 

 

 

 

 

 

 Gambar 5.1 ZEN Programmable Relay 

 

ZEN Programmable Relay terdiri dua jenis yaitu type LCD yang dilengkapi dengan LCD 

dilengkapi dengan tombol-tombol operasi dan type LED yang tidak dilengkapi dengan LCD 

dan tombol-tombol operasi hanya indicator LED saja. Type LCD memudahkan dalam 

pemrograman diagram tangga, karena pemrograman dapat diakukan secara langsung dengan 

bantuan LCD tersebut atau dapat juga dengan computer melalui port serial. 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

Gambar 5.2 Type LCD dan LED ZEN Programmable Relay 

 

Pemrograman type LCD dilakukan dengan menekan fungsi-fungsi tombol mengikuti aturan 

yang ditunjukkan di bawah ini. Tombol operasional (seperti DEL, ALT, dst) dapat digunakan 

untuk operasional ZEN, tidak peduli apakah tombol-tombol yang bersangkutan digunakan 

sebagai tombol tekan (B) atau tidak, dengan kata lain, saat suatu tombol operasional misalnya 

DEL ditekan (untuk penghapusan) maka tombol tekan B6 juga ON. Pastikan anda  memilih 

atau menggunakan tombol tekan yang tidak terganggu karena sifat ini. 

 

 

 

Gambar 5.3 Fungsi tombol tekan 

 

 

 

 

C. Alat dan Bahan Percobaan 

- Papan percobaan (trainer) PLC 

- Kabel penghubung (jumper) 

- Catu daya DC 24 volt. 

 

 

 

 

 

 

 

 

 



 

 

 

D. Langkah Percobaan. 

 

 

 

 

 

 

 

 

 

 

 

1. Pastikan sumber tegangan belum dihidupkan. 

2. Hidupkan power supply atur tegangan keluaran 24 volt, jangan melebihi nilai ini 

kemudian matikan kembali. 

3. Hubungkan   sumber tegangan modul PLC dengan output power supply, kabel merah 

plus dan hitam minus kemudian laporkan kepada asisten apakah sumber tegangan telah 

benar. 

4. Apabila telah benar hidupkan power supply dan buatlah program ladder diagram 

berdasarkan diagram listrik di atas. 

5. Jika telah selesai jalankan program, pilih mode operasi monitor, tekan tombol sesuai 

table pengamatan dan catat kondisi output. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

S1

S2

lampu 1

lampu 2

S3

S4

lampu 3

lampu 4



 

 

 

DATA PERCOBAAN 4 

 

Penggunaan Input/Output 

 

  

 Nama  : _________________________ 

 NPM  : _________________________ 

 Kelas  : _________________________ 

 Kelompok : _________ 

 Hari/Tanggal : _________________________ 

 

 Paraf  : _________ 

 

 Gambar Ladder Diagram (digambar setelah program dapat dijalankan) 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Input Output Q0, Q1, Q2, Q4 

S1 (I0) S2 (I1) S3 (I2) S4 (I3) 

ON         

  ON       

    ON     

      ON   

 

 

 

Mengetahui. 

Dosen/Asisten 

 

 

            

         __________________ 

 



 

 

 

PERCOBAAN 5 

Latching Circuit 

 

A. Tujuan Percobaan  

  Mahasiswa dapat membuat program dan menjalankan Latching Circuit 

B. Teori Dasar 

Rangkaian yang bersifat mengingat kondisi sebelumnya seringkali dibutuhkan dalam kontrol 

logic. Pada rangkaian ini hasil keluaran dikunci (latching) dengan menggunakan kontak hasil 

keluaran itu sendiri, sehingga walaupun input sudah berubah kondisi output tetap. Latcing 

circuit banyak diterapkan pada kendali individual. 

C. Alat dan Bahan Percobaan 

- Papan percobaan (trainer) PLC 

- Kabel penghubung (jumper) 

- Catu daya DC 24 volt. 

D. Langkah Percobaan  

 

 

 

 

 

        Gambar 5.1 Ladder Diagram 

                 Latching Circuit 

 

1. Pastikan sumber tegangan belum dihidupkan. 

2. Hidupkan power supply atur tegangan keluaran 24 volt, jangan melebihi nilai ini 

kemudian matikan kembali. 

3. Hubungkan   sumber tegangan modul PLC dengan output power supply, kabel merah 

plus dan hitam minus kemudian laporkan kepada asisten apakah telah sumber tegangan 

telah benar. 

4. Apabila telah benar hidupkan power supply dan buatlah program ladder diagram 

berdasarkan diagram listrik di atas. 

5. Jika telah selesai jalankan program, pilih mode operasi monitor, tekan tombol sesuai 

table pengamatan dan catat kondisi output. 

start stop
MC 1

MC 1

start stop
MC 2

MC 2



 

 

 

DATA PERCOBAAN 5 

   

  Latcing Circuit 

 

  

 Nama  : _________________________ 

 NPM  : _________________________ 

 Kelas  : _________________________ 

 Kelompok : _________ 

 Hari/Tanggal : _________________________ 

 

 Paraf  : _________ 

 

 Gambar Ladder Diagram (digambar setelah program dapat dijalankan) 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

         

   

 

 

Mengetahui. 

Dosen/Asisten 

 

 

 

          

Start 
MC1 

Stop 
MC1 

Start 
MC2 

Stop 
MC2 

Output Q0, Q1 

ON     

     

 ON    

  ON   

   ON  



 

 

 

         ___________________  

 

PERCOBAAN 6 

Kendali Sekuensial (Inter Lock) 

 

Tujuan Percobaan: Mahasiswa dapat membuat program dan menjalankan Inter Lock 

Teori dasar 

Kendali sekuensial banyak digunakan pada proses batch atau beberapa batch. Kendali ini dapat 

dioperasikan dalam mode otomatis dengan timer atau secara manual. Otomatis berarti operasi 

berjalan berurutan hanya dengan menekan dengan tombol ON dan OFF untuk seluruh operasi, 

sedangkan manual dengan menekan tombol keseluruhan operasi tanpa terjadi kesalahan urutan 

karena adanya fungsi inter lock. Kesalahan prosedur pengoperasian (sekuensial) dapat 

mengakibatkan penumpukan material (bahan-bahan). 

 

Alat dan Bahan Percobaan 

- Papan percobaan (trainer) PLC 

- Kabel penghubung (jumper) 

- Catu daya DC 24 volt. 

 

Langkah Percobaan 

Diagram listrik: 

 

 

       

 

 

         

        Gambar 6.1 Diagram Ladder 

          Interlock 

            

            

            

 

start stop
MC1

MC1

start
MC2MC1

start stop
MC3

MC3

MC4

MC2

stop

MC2



 

 

 

 

 

  Keterangan: 

MC (magnetic contactor) 2 akan ON apabila MC 1 ON,  

MC 3 ON apabila MC 2 ON. 

 

 

1. Pastikan sumber tegangan belum dihidupkan. 

2. Hidupkan power supply atur tegangan keluaran 24 volt, jangan melebihi nilai ini 

kemudian matikan kembali. 

3. Hubungkan   sumber tegangan modul PLC dengan output power supply, kabel 

merah plus dan hitam minus kemudian laporkan kepada asisten apakah telah sumber 

tegangan telah benar. 

4. Apabila telah benar hidupkan power supply dan buatlah program ladder diagram 

berdasarkan diagram listrik di atas. 

5. Jika telah selesai jalankan program, pilih mode operasi monitor, tekan tombol sesuai 

table pengamatan dan catat kondisi output. 

6. Setelah mengisi tabel pengamatan anda coba untuk membuat interlock seperti pada 

slide teori dengan men-delete MC1 pada rung 2 dan MC2 pada rung 3, kemudian 

hubungkan ke antar start-stop di atasnya. Kemudian delete stop pada rung 2 dan 3 

dan hubungkan. Jalankan program. 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

 

DATA PERCOBAAN 6 

   

  Kendali Sekuensial 

 

 

   Nama  : _________________________ 

 NPM  : _________________________ 

 Kelas  : _________________________ 

 Kelompok : _________ 

 Hari/Tanggal : _________________________ 

 

 Paraf  : _________ 

 

 

 Gambar Ladder Diagram (digambar setelah program dapat dijalankan) 

  

 

 

 

 

 

 

 

 

 

 

 

 

          

    

 

 

 

 

 

 
 

 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

Mengetahui. 

Dosen/Asisten 

 

 

 

          

         ___________________  

 

 

 

 

 

 

 

 

 

 

 

Start 
1 

Stop 1 Start 2 Stop 2 Start 3 Stop 3 Output Q0, Q1, Q2 

ON       

  ON     

    ON   

     ON  

   ON    

 ON      

ON       

  ON     

    ON   

 ON      

ON       

  ON     

    ON   

   ON    



 

 

 

 

 

 

 

PERCOBAAN 7 

TIMER dan COUNTER 

 

 

TIMER 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

COUNTER  
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