
DocType Shortcut Function

PCB +
Increase Routing Width; Switch to the next signal
layer

PCB * Cycle switch to the next signal layer

PCB Delete
Delete selected object; Undo the track when
routing

PCB ALT-- Decrease Snap Size

PCB ALT++ Increase Snap Size

PCB CTRL+R
Depend on reference point for copy object
repeatly

PCB CTRL+L Open layer manager

PCB CTRL+Q Hide/show network text

PCB SHIFT+M Remove All Copper Area fill data

PCB SHIFT+B Rebuild All Copper Area

PCB SHIFT+D Move Object(s) by reference point

PCB SHIFT+G Display track length while routing

PCB SHIFT+W Show favorite track width while routing

PCB SHIFT+R Change routing conflict

PCB SHIFT+S Toggle layers which is not active

PCB SHIFT+Double Click Delete selected track segment

PCB CTRL+SHIFT+V
Paste object(s) and keep the prefix, and hide the
ratline layer

PCB CTRL+SHIFT+SPACE Change routing angle, same as hotkey L

PCB CTRL+ALT+L Enable all layers

Footprint CTRL+SHIFT+ALT+D Open custom data dialog

Basic Skills

To use EasyEDA you need to be familiar with a few basic terms and concepts. The best way to
learn them is to open up EasyEDA, and create a new schematic:

File > New > Schematic , and play!

Saving Your Work Locally



Although EasyEDA saves all your files on our Server, sometimes you may want to save your
work locally and EasyEDA does provides a way to do this.

You can right-click your project folder, and click "Download Project", or export your design as
EasyEDA source file via "File > EasyEDA Source".

For more detail you look here: Export EasyEDA Source section.

To download your project:

History Record

It is easy to use this function, right click on the document for which you need the history as in
the image below:
After clicking on the history link, you will get a list of the History as in the image below.

Click the History number to open the saved file in the editor, if this is what you need, you can
save it to your project and delete your bad file.



Note:

Document Recovery

No operating system, software or network is perfect, so sometimes things go wrong. Having
your Desktop or web browser freeze or your broadband connection drop, two hours into
laying out a PCB, could spoil your day.

However, with EasyEDA, your day will be just fine.

This is because EasyEDA auto saves and makes backups of all your open files to your
computer, crash recovery is built into EasyEDA.

On the top menu, clickMenu - Advanced - Document Recovery as below:

Expand the folder to the latest version, Select the file which you would like to recover, then
click the Recover button; your file will be opened in a new tab, then save this opened file.

Please note:



Resizing the canvas area

Hovering the mouse cursor over the areas indicated by the three green ellipses will bring up
the blue sidebar toggle lines. Clicking on them will toggle the visibility of their associated right
and left areas to expand the canvas area. The vertical lines can be dragged horizontally to
resize the panels.

Cursor Style

Some users do not like the cross cursor, so you can change it to an arrow cursor like in the
image below.

Via: Top Menu - View - Cross Cursor

The difference between these options is shown below:



Clear and delete

If you think your schematic or PCB looks terrible, and you want to redraw everything, you can
do this:

Top Menu > Edit > Global Delete.

Delete this schematic and create a new one.
Click one object or CTRL+A, press delete key to remove all objects.

Left clicking

Similar to other EDA software:

Click on an item to select it;
If over a selected item, click and hold to drag a selected item;
If not over a selected item, clicking and holding while dragging creates a selection box;
The selection box, using click and drag to the right, selects everything inside the box;
The selection box, using click and drag to the left, selects everything inside and
intersected by the box;
Double click on a text area to edit the text;
The exact left click functionality depends on what item is being selected and in what
Canvas the item exists (Schematic or PCB).



Right clicking

In EasyEDA, right-clicking opens a context sensitive menu:

When you are placing a symbol, right-clicking will stop placing and return to select mode.
This is the same as the ESC key.
When you are drawing a shape such as a polyline, after a right click, the polyline will be
stopped at the place where you right click but the mouse will remain as a cross, so you
can draw another shape.
To get out of the current active context sensitive command such as placement or drawing
mode and go back to select mode, just double right click or press ESC (sometimes twice).

Right-Click and drag Right-clicking and holding the button anywhere in the Schematic,
Waveform or PCB Canvas while dragging the mouse will move the canvas around within the
EasyEDA window. Holding the middle button and dragging performs the same operation.

ESC key

Pressing the ESC key ends the current drawing action but does not exit the current active

context sensitive command mode (i.e. it does not return the cursor to select mode). Pressing
ESC again returns to select mode.

Select more shapes

CTRL+Left Clicking on items adds those items to your selection;
Clicking and holding creates a selection box;
Creating a selection box, using click and drag to the right, selects everything inside the
box;
Creating a selection box, using click and drag to the left, selects everything inside and
intersected by the box;

Zoom in and Zoom out

Using the middle mouse button:
Roll forward to zoom in;
Roll back to zoom out;
Using hotkeys, the default hotkey A for zoom in, Z for zoom out.

Please note:

Double clicks

Double clicking any text area opens a resizable text box that allows you to edit the text.



Right clicking

In EasyEDA, right-clicking opens a context sensitive menu:

When you are placing a symbol, right-clicking will stop placing and return to select mode.
This is the same as the ESC key.
When you are drawing a shape such as a polyline, after a right click, the polyline will be
stopped at the place where you right click but the mouse will remain as a cross, so you
can draw another shape.
To get out of the current active context sensitive command such as placement or drawing
mode and go back to select mode, just double right click or press ESC (sometimes twice).

Right-Click and drag Right-clicking and holding the button anywhere in the Schematic,
Waveform or PCB Canvas while dragging the mouse will move the canvas around within the
EasyEDA window. Holding the middle button and dragging performs the same operation.

ESC key

Pressing the ESC key ends the current drawing action but does not exit the current active

context sensitive command mode (i.e. it does not return the cursor to select mode). Pressing
ESC again returns to select mode.

Select more shapes

CTRL+Left Clicking on items adds those items to your selection;
Clicking and holding creates a selection box;
Creating a selection box, using click and drag to the right, selects everything inside the
box;
Creating a selection box, using click and drag to the left, selects everything inside and
intersected by the box;

Zoom in and Zoom out

Using the middle mouse button:
Roll forward to zoom in;
Roll back to zoom out;
Using hotkeys, the default hotkey A for zoom in, Z for zoom out.

Please note:

Double clicks

Double clicking any text area opens a resizable text box that allows you to edit the text.



Press the enter key to save your changes. Click outside the box or press ESC to discard your
changes.

Pan/Move Canvas

Right click anywhere in the Schematic, WaveForm or PCB Canvas and Hold down right
button to drags the canvas around within the EasyEDA window.
If your canvas is bigger than the EasyEDA window and is showing scroll bars, you can use
either the scroll bars or the Arrow keys to scroll the canvas to pan.
When drawing a wire, a graphic line or shape that you wish to extend beyond the edge of
the EasyEDA window holding down the left mouse button after starting the line will pan
the canvas to keep the drawn item inside the window.

Tip:

Rotate

After selecting one or more items, you can rotate the selected items using:

Top Menu > Format > Rotate or by pressing the default rotate hotkey: ‘Space’.



When in PCB view mode you can click the footprint and change its rotation in the right
property panel.

Please note:

Flip

To place a Q2 as shown in the schematic below you need to Flip the item. Via: Top menu -
Format - Flip.

You can Flip one or more selected items using:

Rotate and Flip > Flip Horizontal or Flip Vertical from the toolbar,

or by pressing the default flip hotkeys: X to Flip Horizontal, Y to Flip Vertical.

Notice: Footprint does not support the flip command.

Align



EasyEDA provides many align option features, you can align your symbols or footprints very
easily using: Top menu - Format - Align. There are also icons on the toolbar for this.

Bring to Front and Send to Back

In the image below, both the rectangle and the ellipse are filled. Use: Top menu - Format -
Bring/Send to Front/Back.

If you draw an ellipse before drawing a rectangle, the rectangle will overlap and therefore hide
the ellipse. To reveal the ellipse, select the rectangle and then use the Bring and Send
function, as shown:



Multiple Windows

Since v6.4.0, EasyEDA supports multiple windows design.

How do it works?

1. Open schematic and PCB
2. Right-click the schematic or PCB tab, click "Open in New Window"

3. This will open the document in a new window, then you can do the cross probe: Click the
component, pads, click the Design Manager list, the "Cross Probe and Place" also works.

Documents Tab Switch

It is easy to modify the tab positions of your documents.

Simply drag the tab location, or use the hotkeys SHIFT+1 and SHIFT+2



Schematic Capture

Canvas Setting

During this tutorial we will create a simple Schematic design to guide you in using EasyEDA
Schematic capture.

You can find the canvas Properties setting by clicking on any the blank space in the canvas.

As described earlier, background and grid colours and the style, size, visibility and snap
attributes of the grid can all be configured.

The canvas area can be set directly by the Width and Height or by using the available preset
frame sizes.

Grid:

Visible Grid : Yes or No
Grid Color: Any valid colour
Grid Style: Line or Dot
Grid Size: To ensure proper alignment of all EasyEDA parts, it is advisable to set in 10, 20,
100. the unit is pixel.
Grid (and background) colour can be set directly by entering the hexadecimal value of
the colour you want or by clicking on a colour in the palette that opens when you click on
the colour value box:



Snap:

Snap: Yes or No. Pressing this key toggles switching snap to grid on and off.
Snap Size: To ensure proper alignment of all EasyEDA parts, it is advisable to set in 10,
20, 100 but any valid number can work, such as 1, 5, 10.

It is strongly recommended that you keep Snap = Yes all the time. Once items are placed off-
grid it can be very difficult to reset them back onto the grid. Off-grid placement can result in
wires looking as though they are joined when in fact they are not and so causing netlisting
errors that can be hard to track down.

If you need to draw detailed parts of new symbols or footprints that need to go between grid
points, try to reduce the grid spacing to draw these elements and then reset the grid back to
your chosen default value as soon as you have completed that part of the drawing. Setting
Snap=No should only really be used as a last resort.

ALT Sanp: Snap size when pressing the ALT key.

Wiring Tools

If you have hidden your tools , you can open them from here:
Top toolbar Top Meun > View > Wiring Tools...



Note:

Wire

There are three ways to enter the wire mode in EasyEDA.

1. Click theWire button from theWiring Tools palette.
2. Press the W hotkey.

3. Click on the end of a component pin (where the grey pin dot appears if you select the
component):



EasyEDA automatically entersWire mode.

Here is a screenshot of the Astable Multivibrator LED project schematic after wiring:

Moving Components and Wires:

If you place a component, such as a resistor, on top of a wire then the wire breaks and
reconnects to the ends of the component.

When moving selected components using the mouse, they will drag attached wires with them
(“rubber band”) to some extent but please be aware that the rubber banding feature has
some limitations. When moving selected components most wire will move vertically and
horizontally. Using the arrow keys will not rubber band. Selected wires do not rubber band.



A selected wire can be moved directly by clicking on it using the mouse or by the arrow keys.
If a wire is selected by clicking on it using the mouse then green grab handles will appear at
the ends and vertices.

Auto adjust connection

If you put a resistor or capacitor on a wire, the wire will auto connect the pins as below:

When you want to wiring a series of resistors which are in a row, you can just wire through
them, and then you will find they all be connected.

Wire Node

When you click on the wire, you can see the nodes on the wire, where the white is the virtual
node, the red is the real node, drag the virtual node to generate the real node, and right-
delete the line segment is to delete the line segment between the real nodes.



Bus

When you design a professional schematic, perhaps it will use a lot of wires. If you wiring one
by one, much time would be wasted, and then you need to use Bus .


