
Export BOM supports to export LCSC part price, it is the same as LCSC website.

Notice:

Before v6.4.17, If your project has schematic and PCB, the BOM data will come from
schematic; if the project only has PCB, the BOM data will come from PCB.
Since v6.4.17, the schematic BOM and PCB BOM are separated. If you assign the LCSC
part at the PCB, it will not modify the schematic.
In order to support multiple languages, BOM and coordinate files (CSV file) are UNICODE
encoded and tab-based. If the CSV file cannot be read by your components vendor or
PCB manufacturer, please convert the encoding and change the delimiter.
Recommended solution: Save as a new CSV file in Excel or WPS. For example, open a CSV
file in Excel, click or select: Save As - Other Formats - CSV (Comma Separated) (*. csv).
You can also open the CSV file with any text editor (such as Windows Notepad) and save
as ANSI or UTF-8 encoding. If necessary, replace all tabs with commas.

Export NetList

EasyEDA can export the netlist for the whole active project:

File > Export NetList > Spice...



EasyEDA can export a netlist in a variety of formats:

LTSpice for this Sheet: this is a Spice compatible netlist generated by the simulation
engine of EasyEDA, It is not normally used as the basis for as a PCB layout.
Protel/Altium for PCB: a PCB netlist in a format that can be imported straight into
Altium Designer and it's predecessor, Protel.
PADS for PCB: a PCB netlist in a format that can be imported straight into Pads PCB
layout tools.
FreePCB for PCB: a PCB netlist in a format that can be imported straight into FreePCB, a
free, open source PCB editor for Windows.

Report Error

For EasyEDA official libraries, we have staffs to draw and maintain(LCSC & JLCPCB Assembled
part) and we will try to keep them correctly as we can, but EasyEDA(System part) included a
lot of open source of the libraries and the official drawing of the libraries, that can not avoid
the wrong situation 100%, so when you meet a incorrect library, Please inform us in time, we
will fix it as soon as possible.

There are 3 ways to report error:



1.Right-click the offical library and use the "Report Error" function on the "Libraries".

2.Select the offical library on the canvas of the schematic/schematic module, click the "Report
Error" button at the right-hand panel.



or right-click the component:

3.Send Email to us or post a topic at Bug report

Create the Schematic Symbol

Create the Schematic Symbol

Using Schematic Symbol Wizard and Group/Ungroup... is a quick way to create schematic
symbols but they are placed directly into the schematic that they are built in.

It is possible to reuse them by copying them ( CTRL+C hotkeys) from the schematic they were

created in and then cross-document-pasting them ( CTRL+SHIFT+V hotkeys) into a different

schematic but this quickly gets messy if you need to copy symbols that were created in several
different schematics.

OK, you could keep copying new symbols into a dedicated “symbol library” schematic sheet
to save searching for them but EasyEDA offers you an easier way to create and manage your
symbols in a library.

Start a new Schematic Lib as shown below or by doing:



1. File > New > Symbol

This opens the New SchematicLib symbol editor.

2. Create the symbol

Get the Datasheet
For example, using the NE555DR, the datasheet you can refer LCSC: NE555DR.
And then create the symbol and place the pins for the library base on the datasheet.
This component have 8 pins and names.

Create via Schematic Symbol Wizard

The more information of Schematic Symbol Wizard please refer next section.

Create by Manually



Draw the shape via the Drawing Tools

Place the Pins

The Pin dot must keep out side as the image indicated, it is connecting with the
wires. The more information please refer SchematicLib Attributes - Pins Section.



3. Edit the pin map
Via Edit > Pin Map..., change Pin names and Pin numbers. For some complicated IC, will use
the alphabet for the pin number.

Note: if the pin is hidden, a network will be generated according to the pin name for
connection. If it is not necessary, it is recommended not to hide.

4. Modify the Detail
such as change Pin length, place text, change Pin color, Pin attributes etc.

5. Set Costom Attributes
You can set the supplier, footprint(Suggested, you must assign the footprint via "Footprint
Manager"), Name(Required), Prefix(Required) for it, the more detail of attributes please refer
below section: Custom Attributes



If the schematiclib need to assign the packahe, the Pin number should match the footprint's
Pad number. The detail of the footprint assign please refer the Footprint Manager section at
previous.

6. Set the Origin
You can via: "Top Menu - Place - Set Canvas Origin - By Center Grid of Symbols" to set the
origin.

7. Save your SchameticLib
You can set this library's owner, datasheet link and tags etc.



Then a Schematic Symbol is created finish. And the you can find it at "Libraries - SchematicLib
- Personl" on the left-hand.

Notice:

Note the Origin Point. To simplify rotating your symbols when they are placed into the
canvas, make sure all of your symbols are created as near as possible centered around
that point. Suggesting the first Pin/Pad or its center to be the origin point.

Pin Attributes

Symbols pins are the most important part of any Schematic Lib symbol. They are the things
that allow wires to be attached to symbols to connect up your circuit.

You can use the P hotkey to add a Pin or from the Draw Tools pallete:

Before placing it on the canvas, you can use the rotation hotkey or rotate and flip from the
menu to rotate it to the right orientation. Make sure the Pin Dot(black dot) is in the right
position. The Pin Dot will be used to connect your wires or netlabels. Whenever a PIN is either
placed as directly onto the canvas or as part of a symbol, the mouse has to point to the Pin
Dot position to automatically start the Wire mode or to join a wire to it.



Whenever a Pin is placed as part of a symbol, the Pin dot should be outside of — and
pointing away from — the symbol like in example 1(correct position), inside or pointing
towards the symbol as shown in example 2(wrong position).

When you select a single Pin, the Pin attributes will be shown in the right hand Properties
panel:



Orientation: 0°,90°, 180° and 270°。If you want to create a 45° pin, you need to set it length
as 0, and draw a line with 45°。

Start-X and Start-Y: The pindot position. Sometimes it may be difficult to move the pin to the
desired position using the mouse, so you can move the pin via Start-X and Start-Y.

Length: Pin length.

Name: In this example, is the name of the Pin.

Number: In this example, is the number of the Pin. This number is the pin number of the
device in a physical footprint.

Note that you can use alphanumeric identifiers such as; A1, B1, C1, A2, B2 and so on as the
Number.

Spice Number: These are the pin numbers used to connect your symbol to the corresponding
pins defined by the .model or .subckt used to simulate your device. The pin numbers of the
simulation model may be different from the physical footprint pin numbers and - unless the
model is specifically created to model multiple devices in a single footprint - do not change
for different instances of a device in a multi-device footprint. The Spice Pin order must
be numerals only.

Name Display: If you don't want to show , switch it to NO.

Number Display: If you don't want to show , switch it to NO.



You can adjust the Name or Number position using your mouse but note that rotate and flip
applies to the whole pin including the name and pin number; these items cannot be rotated
and flipped independently of the pin itself.

Note also that rotate and flip actions do not result in upside down or mirrored pin number or
names.

Color: You can set the Pin to different colours, such as as orange and as
blue. In this example, the PIN1 is set as color #880000 , but it shows as red, because it is

selected. After deselecting it, the pin will appear color #880000 .

Dot: adds a circle to the inside end of the pin to indicate logical (or analogue) inversion.

Clk: adds a > to the inside end of the pin to indicate that the pin is logical clock input.

Show: YES/NO. Allows you to hide the pin. When set it to NO, this Pin will be hidden when the
symbol is placed on the schematic editor canvas, and then create a net which name same as
this pin name.

Note that the pin is not hidden here in the Schematic Lib symbol editor canvas because if it
was, it would disappear from view and so how would you find it to make it visible again? For
the same reason this option has no effect in symbols made using Group/Ungroup…

Electric: [Undefined, Input, Output, I/O, Power]

EasyEDA provides Electrical Rules Checking (ERC) right now, But you still need to set electric of
your Schematic libs.



If you set the PIN as Power and set the pin to be hidden, then the Pin will be connected by
Name which is the NetLabel. If the Name is VCC, it will be connected to the net in your circuit
with the NetLabel or NetFlag VCC. This is helps to keep the schematic clear and uncluttered
when using Multi-part Components.

After created the Lib, use CTRL+S will open the save dialog:

After clicking Save, you will see it appears in Libraries > Symbols > Personal of the left hand
Navigation panel.



If you want to modify the tag for your new symbol: Libraries > Symbols > Personal > Select
New Lib > More > Modify, or right-click new Lib > Modify, if your Lib doesn't have the tags
it will appears on All.

Custom Attributes

In the Schematic Lib editor's canvas Properties panel, you will find a Custom
Attributes section:

footprint

How to change Schematic Symbol's footprint? If you would like to built a PCB, you need to
assign a footprint for your Schematic symbol. Although there are other ways to do this in
EasyEDA, here is the right place to do it. When you set a footprint , the footprint's pad
numbers must match the schematic Lib's pin number, otherwise, when you convert the
schematic to PCB , there will miss several nets.

Click in the footprint input box, and the Footprint Manager dialog will open as used to do
this task in the Schematic Editor.

The more information please refer to Schematic - Footprint Manager section.

Notie:

Prefix

The default Schematic symbol Prefix is U? If you create a resistor, you can set the Prefix to R?.
It is filled required.



Name

You can change the schematic lib's name here, it is can be different from the part's file name.

Contributor

This is your registered user name. When Other EasyEDA's users use your libraries, they will
remember your contributions!

Symbol Subparts

We have already touched on how EasyEDA can supportMulti-part/Subpart Components ,
but how do you create multi-part components?

EasyEDA provides a sub parts facility to do this.

After creating a part, you can right-click the part in the Library > Symbols > Work Space >
Created section to pop up the content menu.

Suppose you have created your own symbol for a 74HCT04 hex inverter.

Right Click Add sub part and that will add 74HCT04. ,

Click again to add 74HCT04. , up to 74HCT04. .

Then double click on each sub part in turn to modify the Pin Name and Number attributes.

Easy or what?

Schematic Symbol Wizard

How many times have you hit a schematic capture roadblock because you couldn't find
a component symbol?

Well, in EasyEDA that would be never because the Schematic Symbol Wizard provides a
quick and easy way to create a general Schematic Symbol symbol.

Via: Top Menu - Tools - Symbol Wizard



Basic Function

Input the Pins' name Only

1. Using the NE555 timer as an example: this device is available in a DIP8 package so select
DIP. Then enter the NE555 pin names into the Pin Names text box separated by new line
or space, Then press OK. Abracadabra! As if by magic, you will find a perfectly formed
dual in line 8 pin symbol for the NE555 attached to your mouse cursor, ready to be
placed! You just need a few seconds to build a NE555 symbol, quickly and easily.

2. The EasyEDA Schematic Symbol Wizard allows you to create DIP, QPF or SIP styles
symbols. If you are designing Arduino Shields then you will need lots of SIP symbol, so
you can create a SIP symbol like the one shown below in a few seconds.

3. If you are not too worried that the symbols may not look quite the way people might
expect and that they may not look anything like the Type you select, then of course you



can use the wizard to create symbols for any component:

Input the Pins' number and name

Schematic Symbol wizard support you input the pins' number and name.
As below example, setting every pin's number is easily.

Professional Function

Schematic Symbol Wizard support the professional function, it is easier to create the large and
complex and more convenient Schematic Symbol.

1.Download Schematic Symbol Wizard Template.xlsx

2.Open it via Excel or WPS, and edit each Pins attributes and position, and then copy the
content and paste in wizard dialog without content title.
Tip: If you want to create the gap between Pin and Pin, you can use the * as below image.



3.The Wizard will create the symbol follow your content. The types you chosen will be ignored.

Notice:

Schematic Symbol Attributes

Pin Attributes

Symbols pins are the most important part of any Schematic Lib symbol. They are the things
that allow wires to be attached to symbols to connect up your circuit.

You can use the P hotkey to add a Pin or from the Draw Tools pallete:



3.The Wizard will create the symbol follow your content. The types you chosen will be ignored.

Notice:

Schematic Symbol Attributes

Pin Attributes

Symbols pins are the most important part of any Schematic Lib symbol. They are the things
that allow wires to be attached to symbols to connect up your circuit.

You can use the P hotkey to add a Pin or from the Draw Tools pallete:



Pin Orientation

Before placing it on the canvas, you can use the rotation hotkey or rotate and flip from the
menu to rotate it to the right orientation. Make sure the Pin Dot(black dot) is in the right
position. The Pin Dot will be used to connect your wires or netlabels. Whenever a PIN is either
placed as directly onto the canvas or as part of a symbol, the mouse has to point to the Pin
Dot position to automatically start the Wire mode or to join a wire to it.

Whenever a Pin is placed as part of a symbol, the Pin dot should be outside of — and
pointing away from — the symbol like in example 1(correct position), inside or pointing
towards the symbol as shown in example 2(wrong position).

Pin Attributes

When you select a single Pin, the Pin attributes will be shown in the right hand Properties
panel:



Orientation: 0°,90°, 180° and 270°。If you want to create a 45° pin, you need to set it length
as 0, and draw a line with 45°。

Start-X and Start-Y: The pindot position. Sometimes it may be difficult to move the pin to the
desired position using the mouse, so you can move the pin via Start-X and Start-Y.

Length: Pin length.

Name: In this example, is the name of the Pin.

Number: In this example, is the number of the Pin. This number is the pin number of the
device in a physical footprint

Note that you can use alphanumeric identifiers such as; A1, B1, C1, A2, B2 and so on as the
Number.

Spice Number: These are the pin numbers used to connect your symbol to the corresponding
pins defined by the .model or .subckt used to simulate your device. The pin numbers of the
simulation model may be different from the physical footprint pin numbers and - unless the
model is specifically created to model multiple devices in a single footprint - do not change
for different instances of a device in a multi-device footprint. The Spice Pin order must
be numerals only.

Display Name: If you don't want to show , switch it to NO.

Display Number: If you don't want to show , switch it to NO.



You can adjust the Name or Number position using your mouse but note that rotate and flip
applies to the whole pin including the name and pin number; these items cannot be rotated
and flipped independently of the pin itself.

Note also that rotate and flip actions do not result in upside down or mirrored pin number or
names.

Color: You can set the Pin to different colours, such as as orange and as
blue. In this example, the PIN1 is set as color #880000 , but it shows as red, because it is

selected. After deselecting it, the pin will appear color #880000 .

Dot: adds a circle to the inside end of the pin to indicate logical (or analogue) inversion.

Clock: adds a > to the inside end of the pin to indicate that the pin is logical clock input.

Show: YES/NO. Allows you to hide the pin. When set it to NO, this Pin will be hidden when the
symbol is placed on the schematic editor canvas.

Note that the pin is not hidden here in the Schematic Lib symbol editor canvas because if it
was, it would disappear from view and so how would you find it to make it visible again? For
the same reason this option has no effect in symbols made using Group/Ungroup…

Electric: [Undefined, Input, Output, I/O, Power]

EasyEDA provides Electrical Rules Checking (ERC) right now, But you still need to set electric of
your Schematic libs.

If you set the PIN as Power and set the pin to be hidden, then the Pin will be connected by
Name which is the NetLabel. If the Name is VCC, it will be connected to the net in your circuit
with the NetLabel or NetFlag VCC. This is helps to keep the schematic clear and uncluttered
when using Multi-part Components.

After created the Lib, use CTRL+S will open the save dialog:



After clicking Save, you will see it appears in Libraries > Symbols > Personal of the left hand
Navigation panel.

If you want to modify the tag for your new symbol: Libraries > Symbols > Personal > Select
New Lib > More > Modify, or right-click new Lib > Modify, if your Lib doesn't have the tags
it will appears on All.



Symbol Custom Attributes

In the Schematic Lib editor's canvas Properties panel, you will find a Custom
Attributes section:

Add into BOM
This part display at BOM or not.
Convert to PCB
If you set it as No, this part will not display at Footprint Manager and can't not convert to
PCB.
footprint
To assign a footprint for this part. Only assign one footprint.
The more information please refer to Schematic - Footprint Manager section.
Notie:

Pre
The default Schematic symbol Prefix is U? If you create a resistor, you can set the Prefix to
R?. It is filled required.
Name
You can change the schematic lib's name here, it is can be different from the part's file
name.
Contributor
This is your registered user name. When Other EasyEDA's users use your libraries, they
will remember your contributions!

Show symbol value as component name when place
component at schematic

For example, a resistor symbol vaule is 2KΩ, name is ABC, but when place it at schematic, it
will not show 2KΩ as component name, the name is ABC. You can change name to 2KΩ, but it
not very well.



EasyEDA doesn't support common function to support this feature yet.

But, we can edit the symbol file soure to implement this feature.

How do it works:

1. Finish symbol and parameter edit.
2. Open file source. via: Top Menu - File - EasyEDA File Source.

3. Add or modify the parameter: nameAlias.

This symbol will show 1k as component name after placing at schematic.

4. Apply after modified, and save.

You can double click the EElib resistor symbol to get an example.

EasyEDA will provide it as a feature in the future.

Edit Exited Schematic Symbol



Personal Libraries

When you CTRL+S to save the Schematic Symbol, will pop up a dialog, you can choose this

library's owner:

After finish, you can find your library at the left panel: Library > Symbols > Work Space > All

Tag

When you select it , right-click it and select the menu "modify", you can add a tag for it.



Favorite

When you favorite a library, you can find it at Library > Symbols > Work Spacel > Favorite ,
If this library has a tag, the tag will show up too, but you can't edit that.
But you can via "Clone" or "Edit and save" to create a new library to personal libraries.

Edit Symbol in the Library

When you feel the Schematic Libs can not be satisfied for you, you can edit it.

Via "Library" > "Search Part/Work Space/LCSC/System" > Select Symbol > Edit

or you can click the preview image



when you finish and save, it will be saved to your personal librariesWork Space and become
your personal libraries.

Edit Symbol in the Schematic

If you want to edit a symbol in the schematic, you can use the Ungroup/Group function.

On theWiring Tools palette there is the Group/Ungroup Symbol… button.

This tool is for you to quickly create or edit schematic library symbols.

1. Select a symbol
2. Click the Group/Ungroup Symbol… button
Up to this point you have a collection of separate pins, a drawn rectangle and some text
that are all separate items with no particular association with each other.

3. Edit the shape or pin what you want to change
4. Select all of the items and click the Group/Ungroup Symbol… button.
A dialog will be opened:



After you click OK, all those separate elements will be grouped together to form your new
symbol directly in the schematic.

Using the group function, you can create/edit any symbol in the schematic, easily and quickly.

PCB Layout

Canvas Setting

After the initial conversion of a schematic to PCB, it is time to learn how to manage EasyEDA's
PCB Design Editor.

Canvas Attributes

Lots of PCB canvas attributes are the same as Schematic canvas attributes. The key is that you
can set units in PCB canvas attributes.


