
Libraries

EELib

That contains ready made symbols for a wide range of components and which can be
simulated.

Many of these components have optional US and EU style symbols, we split them, so you can
select those you like. Click on the drop down list or right click to popup the context menu, it
contains many footprints or parameters. EasyEDA will remember your choices for the next
time.

Don't forget to use Filter to locate a component fastly. For example, you just need to type
0603 to find all of resistors:

Library



EasyEDA provide a lot of libraries, you can find them at "Left-hand Panel - Library", hotkey
"SHIFT+F", at here you can search library from LCSC, system, user contributed etc.

Type

Symbol: Schematic symbols
Spice Symbol: Symbols for spice simlation
Footprint: PCB footprints, PCB pattern.
SCH Modules: Schematic modules, a part of the circuit design. It can not assign the PCB
module, doesn't like the schematic Symbol can assign the footprint . when it be placed
on the schematic, it will be separated.
PCB Modules: As like as Schematic modules.
3D Model: It is bind with footprint via "3D Model Manager".

Classes

Work Space: It include your personal parts and your teams' parts.
LCSC: EasyEDA online part store LCSC.com parts(Officail Parts). It will add new libraries
everyday
LCSC Assembled: JLCPCB Assembled parts. All JLCPCB assembly parts will contain a SMT
icon, that means this part can be JLCPCB assemble.
System: EasyEDA system parts, it comes from open source libraries, such as Kicad
libraries, company public libraries, user contributions.
Follow: If you follow a user at EasyEDA(You can follow a user at him/her user page), you
can view and use his/her libraries.
User Contributed: When you searching a part, maybe you can find it at this class. At
EasyEDA, all libraries are public. the detail you can refer at: Contribute

We add an "JLCPCB Assembled" Components option of the Parts, It's easy to choose which
component can be assembled by JLCPCB. Yes, JLCPCB will provide the assembly service. the
more information please refer at: How to order a SMT order

Search Engine - EasyEDA

Simply type your part number or symbol's name to Search. before searching, you must choose
the "Type" first.



and then click the "Table of contents" to open the categories list to choose your components.

From there you can scroll up and down to browse parts from each category.

If you know the component's name
Suppose you want to find theMAX232 (which converts signals from an RS-232 serial
port to signals suitable for use in TTL compatible digital logic circuits). Simply type
Max232 into the Search box and press Enter:

If you don't know the component's name
For example, you want to find a resistor which value is 1kohm, footprint is 0603, at
Libraries you can follow below steps:

1.Choose the library type
2.Typing the keyword such as 1k 0603

3.Click the search button
4.Select the class you which is wanted of the result
5.If you don't need the search you need to remove all the search keywords

Search Engine - LCSC Electronics

When you want to find some parts by clearly parameter, you should try "Search Engine - LCSC
Electronics", it all most same as LCSC.com.



When you find out part, and you can place into the schematic:

Notice:



Max and Min mode

If you want to place without close the "Library" dialog, you can change dialog mode to Min
mode, just click the Min button at the top-right corner.

Operations

When you hover the mouse over the picture of the Schematic symbol or PCB footprint, you
will find a toolbar with "Edit", "Place", "More" buttons.

Place:

For parts you use infrequently, you don't need to Favorite them; just Place it into your canvas
directly. Or you can double click the library to place.

Note:



Edit:

If you want to create your own version of a symbol or footprint then you can open an existing
part from the library to use as a template, edit it and then save it to your localWork Space
library in Library of the Navigation Panel.

More:

We can't promise that every component in the library is free of errors so please check all
symbols and footprints carefully before you commit to a PCB order.

If you do find a mistake in a component, please use the Report Error , so that we can fix it.

Components with sub parts (multi-device footprints).

When you find a component with sub-parts, you can't Place or Edit it, but you can Favorite
and Clone it as your own part, which you can then edit.

Right-Click

When you right-click the part list, you can edit its tags, add favorite etc.

Preview Image

Every library when you click, you can check its preview image, such as symbol, footprint,
production picture. Click the the image you can open it quickly.



Placing Components

Find the component which you plan to place to your schematic at "Libraries", then move your
mouse to the canvas and left click. If you want to add more, just left click again. To end the
current sequence of placements, right click once or press ESC .

Don't try to Drag and Drop a component to the canvas EasyEDA team thinks that Click-Click
to place components will be easier to use than a Click-Drag mode.

Multi-part Components

The number of pins on some components can be quite large. That's why it's easier to divide
such a component into several parts or functional blocks, it calls multi-parts or subparts.



As a simple example, there are six gates in the 74HC04 Hex Inverter component. To avoid
clutter in the schematic, GND and VCC pins of such components are usually served by a
separate part of the component. This is really convenient as it doesn't interfere the working
process with logical parts. The NetLabel names of VCC and GND Pin are usually hidden.

When placing the 74HC04 on a schematic, it will look like the screenshot below.

Note:

If you click the father-part and place on the schematic, the remaining subparts will be placing
one by one, if you click the one of the subpart, you will placing U1.1, U2.1, U3.1 etc.

How to create multi-part(subpart) please refer Create Symbol

Schematic Symbol Wizard

How many times have you hit a schematic capture roadblock because you couldn't find a
component symbol?

Well, in EasyEDA that would be never because the Schematic Symbol Wizard provides a quick
and easy way to create a general schematic library symbol.

Via: Top Menu > Tools > Symbol Wizard in a new schematic symbol or sheet document.

The professional function please refer at Schematic Symbol Wizard



Component Attributes

Component Attributes

After selecting a component, you can find the component's attributes in the right hand
Properties panel.

1.Component Attributes:



You can change the Prefix and Name here，And make them visible or invisible.
If you want edit this component, you can click Edit Symbol.

If the component's property "Convert to PCB" is set as "No", it will not appear at footprint
manager.

2.Custom Attributes:

You can change , , and .

Define BOM Parameters

After selected a schematic symbol, you can add a parameter, and you can mark it as In BOM ,

when you export a BOM file, you can find this parameter in CSV file.

Modify Symbol Pinmap Information

When you select a component, for opening the Modify symbol information dialog, you can
do:



Or press the I hotkey;

Or click the Edit Symbol on the Parts Attributes on the left panel.
Or click the Symbol and right-click, choose the "Edit Symbol" menu.

Using this dialog you can edit the pin names and numbers, for example, to suit a different
footprint or device variant. You can also enter a Spice Prefix and swap the spice Pin order to
make your symbol usable in simulation.

More detailed description of PCB and Spice Prefixes and pin numbers at next section.

Prefixes and Pin Numbers

Device and subcircuit (or hierarchical block) symbols created for use in schematics that are
intended to be run as spice simulations, in addition to having a PCB Prefix that is used for the
reference designator in the schematic, also have a Spice Prefix. They also have two sets of pin
numbers: PCB pins and Spice pins.

PCB Prefix and Spice Prefix

For more information please refer at Simulation: Schematic symbols: prefixes and pin numbers

Component Adjust

Adjusting Components

About adjusting components you can:

1. Move components with your mouse
2. Move components with the arrow keys.
3. Find components with the Design Manager via the CTRL+D hotkey: select the component

in the Design Manager to pan it to the centre of the canvas and then move it with your
mouse.



4. Align the components:

Rotating the Prefix and Value (Name) of components

The default Prefix and Value (or name) of EasyEDA components are horizontal. To change
them to vertical, Left click the prefix or value and when it is highlighted in red color, then
press the rotation hotkey Space and you're done.

Components Prefixes

Prefix Start

In EasyEDA, at the first new schematic the prefix will start as U1/R1..etc, and EasyEDA support
global unique prefix at multi-sheet now.

Prefix Conflict Error

Sometimes, if you save a sheet to another project, when you convert a project to PCB, open
the Design manager or run a simulation, you will get a Prefix Conflict error message.



In this schematic, you will find two components with the R4 reference designator, so you just
need to change one to Rx where x is a unique number in that schematic.

It may be tempting to backup a schematic into the same project as the original, however, if an
attempt is then made to do Convert Project to PCB, you will get the Prefix Conflict error for
every component.

In the above image, you can find the two identical copies of the same schematic, which when
you Convert Project to PCB, EasyEDA will try to merge into a single schematic, so every item
will have 2 copies.
To fix this, you just have to create a backup project and remove or better still save backup
copies of your schematics to that project.

Annotate



After creating a schematic, it is quite likely that you have component Prefixes (reference
designators) that are in no particular order on the canvas. You may also have duplicates. You
can automatically renumber/reset all the components' prefix by using the Annotate function.

Via: Top Menu > Edit > Annotate

Various Annotate possibilities are available:

Re-annotate all: resets all existing annotation and then annotates all components again
from scratch;
Keep existing annotation: annotates new components only (i.e. those whose reference
designator finishes with ? like R? or U?).
Direction: Rows annotates across the schematic in a raster pattern from top left to
bottom right;
Cols annotates down the schematic in a raster pattern from top left to bottom right.
Annotate: applies the selected annotation actions.
Reset: if you want to reset all the reference designators to end with '?', just click
the Reset button. After that, R1 will be R?, U1 will be U? etc.

Note:

Multi-Sheet

EasyEDA does not support true hierarchical designs but it does support multi-sheet designs.

You can put several schematics in one project with connections between made
by NetLabels/netPorts. All nets in EasyEDA are global so if you create a netlabel DATA0 in

sheet A and then create a netlabel DATA0 in sheet B, when sheet A and sheet B are in the

same project, they will be connected.



Multi-sheet designs(equivalent to a circuit spread over several pieces of paper), all
schematics under the same project will be merged into one when be converted to PCB
connecting in Netlabel, Netflag, Netport.



You can click the Sheet tabs on the left-down corner to switch the Sheets, and right-click the
sheet tab you can "Save as", check "Histories record", "Move Forward/Backward","Rename"
and "Delete" the sheet.

If you want to arrangement the sheets order, you click the menu of the sheet icon: Move
Forward/Move Backward.

Note:

Design Manager

With large schematics it can be hard to find the components quickly. Sometimes, you may
make a mistake such as wiring to a wrong component pin. So you need a tool to help you out.
Design Manager is just the tool.

Just press the CTRL+D hotkey to open the Design Manager.

or click it via on the left navigation panel:



You can click the jump icon to goto the folder quickly.

Filter: You can find your components or net name easily: for example, if you want to find
all capacitances, you just need to type C ;

Components: Lists all the components in this schematic. Clicking on a Component item
highlights that component and pans it to the center of the window.



Nets: Lists all the nets in this schematic. A net must connect at least two Pins, or the net
name will be marked as a red error. When click the net name, the canvas wire will
highlight and being large, when you click the empty space to unhighlight:

When you click the net name, you will see the tip at the bottom-left corner.

Net warning: It will show a prompt exclamation point icon.

When multiple netlabels on one wire, please check whether if it is correct or just
connected by mistake. You need to click this net and find it out. If your netflag
or netlabel only connect one pin, it will show warning.

The part's pin doesn't place the netlabel, or doesn't connect other pins, or
doesn't place No Connect Flag. A completed net must connects two and more
pins, so that, you need to modify your net connection. If you don't need to use
this pin, please place a No Connect Flag on the pin.

Net error: Prompts a red error icon.



When Netlabel haven't connected any pins.

Net good: Prompt text small icon. The completed net should connect two pins and
more.

When the net is completed.

Net Pins/Parts Pins: Lists all the pins of the selected net name or components.



Footprint Manager

Introduction

Want to batch modify components? Can't identify the corresponding relationship between
component pins and footprint pins? Don't worry, EasyEDA can do this.

There are two ways to open the footprint manager:

Click top menu, via: Top Menu - Tools - Footprint Manager

Click the footprint input box of custom attributes when you've selected a component:

1. Footprint manager will check your parts footprint correct or not automatically when open it.

If the part without the footprint or this footprint doesn't exist in EasyEDA Libraries, or if the
part's Pins doesn't correspond the footprint's Pads correctly, the footprint manager will show
the red background alert.

For example, If your part D1 has 2 pins,

pin numbers are 1 and 2 ,

pin names are A and C ,



but you assigned a footprint has 2 pads,

pad number are A and C ,

but the part's pin number doesn't match the pad number, so the the footprint manager will
alert red background:

In order to solve this:

method 1: change part's pin number from 1 and 2 to A and C.
method 2: change footprint's pad number as 1 and 2. That needs the footprint is created
by you. And you can't change the Pad number in footprint manager, you need to find out
the footprint at "Library > Footprints > Work Space", and then edit it.
method 3: find an other footprint and update.

2. In the preview area, you can zoom in, zoom out and pan with mouse scroll button.



Component PIN Information: And you can modify component's pin map information in
here.

PCB PAD Information:

Pad Number: You can check the footprint's pad number, but you can't modify it.
when you select the component on the left side, it shows component's footprint pad
number, if you selected a footprint which is searched or selected from the classes, it
will show the selected footprint's pad number.
Pad Size: You can check the footprint's pads size and distance, it same as "Check
Dimension" tool of footprint editor. Click the preview area unit text to change size
unit.

Update footprint

If you want to change the footprint, for example, select a component such as Q1, from TO-
92 TO TO-220, you just need to click in the footprint input box. EasyEDA will popup the
footprint manager dialog. You can follow the instructions.

Type TO-220 into the search box and search, Or change to Select tab,
Select the classes you want and select TO-220 footprint,
Verify it in the preview box,
then press the Update button.

After that you will find you have changed the footprint to TO-220.

Note:



Update in Batch

If you want to batch modify components' footprints,

In the footprint manager dialog, you can press CTRL + click or SHIFT + select to

select the components, and then select the footprint to update.
In schematic canvas, you can frame select the commponents as you want, and then click
the "footprint" attribute input box at the right-hand property panel.

To use your own footprints, you can selectWork Space under the Select tab.

Find Similar Objects

Find Components in the Schematic

Finding individual components in a dense schematic can be very time consuming. EasyEDA
has an easy way to find and jump to components:

Top Menu> Edit > Find…

(or Ctrl+F )

Note:



This feature will find, highlight and center in the window, parts by their Prefix (or reference
designator). However, it cannot be used to find net names or other text in a schematic.

This is where the Design Manager comes in. the more information please refer Design
Manager chapter.

Find Similar Objects

EasyEDA provide a powerful find similar tool, you can find what you want very easily.
Via Top Menu > Edit > Find Similar Objects…

Kind: Select the object what you want to find.
Range: This option only for the schematic, you can find the object for current sheet or all
sheets.
Find Parameters: Any: Find any objects; Same: Only find the object which attribute same as
this attribute. Different: Find the object which attribute is different than this attribute.



The input box support the Js Regular Expression, you can type /keyword/ to find what you

want, such as find all prefix which are including "R":

After click the "Find" button, all the siutable objects will be seleted, and the right-hand panel
will show all the attributes, the different attributes will show as the <...> , you can change the

attributes directly, and they will apply to all selected objects.

The find similar objects only support to find a part of custom attributes. Such as footprint,
suppiler etc.

Convert Schematics to PCB

Convert to PCB

Most of the time, schematics are created with the aim of producing a PCB. So how do
you convert your schematic to a PCB in EasyEDA? You just need to to click the PCB icon on the
toolbar with the title Convert to PCB.

Note:



Footprints Verification

After clicking the Convert to PCB button, if the project has errors the following dialog will
open:

The row in red indicates that EasyEDA can't find a PCB footprint matching the footprint that
the schematic symbol is calling for.

This could be because you have made an error entering the footprint attribute in the symbol's
Properties or maybe you haven't yet created a PCB footprint for the footprint that your
symbol is calling for.

In this case the footprint should have been AXIAL-0.3 but instead it is empty. To correct it you
can click on the row and update the footprint AXIAL-0.3 for it at the footprint manager.

After making any necessary corrections, click the Convert to PCB button and EasyEDA will
automatically load all the PCB footprints into the PCB editor as shown in the image below.



This shows the footprints placed in arbitrary positions with the connections between them
shown as blue Rat lines.

Invalid footprint

The footprint's PAD number is different from the symbol's PIN number, e.g. the diode
footprint's PAD numbers are A,C but the symbol's PIN numbers are 1,2. You just need to
change one to fit the other. It is case sensitive!

the changing method please refer the Schematic - Footprint Manager section.

Update PCB

Converting a schematic to PCB can be done using the Convert to PCB... , but if you do

modifications to the schematic, by using the Update PCB button you can immediately be

passed forward to update the selected PCB without having the PCB editor window already
open or without creating a new PCB file.

or you can use "Top Menu - Design - Import Changes" at PCB editor.



Cross Probe

This tool is used to cross probe from chosen objects on the current schematic to its
corresponding counterparts in the PCB, or from PCB Footprints to corresponding counterparts
in the schematic.

Since v6.4.0, EasyEDA supports multiple windows design to cross probe.

How do it works?

1. Open schematic and PCB
2. Right-click the schematic or PCB tab, click "Open in New Window"

3. It will open this document in new window, then you can do the cross probe: Click the
component, click the Design Manager list, the "Cross Probe and Place" works too.

Note:

Cross Probe And Place

If your schematic have a lot of components, it will be difficult to layout the PCB , so EasyEDA
provides a powerful function "Cross Probe And Place".

Top Menu> Tools > Cross Probe And Place



Cross Probe And Place will make the footprints' location match the schematic's parts' location
as much as it possibly can.

How to use:

Convert the schematic to PCB first, and save at current project.
Frame select the components area by mouse in the schematic, and then click the "Cross
Probe And Place", hotkey "CTRL + SHIFT + X".
The editor will switch to the PCB, and choose the footprints as you selected for waiting
for placing.
Right click to place, and the mouse will keep the drag status, its easy for adjusting the
footprints' location.

Notice:

Update Components from Library

If you want to update the component at schematic when you update the parts at Library, can
use this feature.

Via: Top menu - Design - Update Components from Library



Click the menu you will see the update dialog, you can preview the current components and
compare with latest version.

You can setting check the component latest version when open the schematic at bottom
option.

Before update components, please check the parts shape, pin number, footprint carefully.

PCB has this feature too at Design menu, you can update footprint from Library.

Notice：
Since v6.4.20.7, while placing the component at the schematic, that will keep the symbol and
footprint corresponding at that time, no matter you update your footprint or not, it will not
impact by latest footprint as previous editor version. when you import changes, the footprint
will use at that time version, will not use the latest footprint version, if you want to use the
latest footprint, you need to update component first.

If you want to update single one compoennt, you can right-click it and update



Reset Component ID

This function resets the ID of the component.

Before V6.4.7, EasyEDA was created by using component prefix to correspond schematic
components to PCB components. This method would lead to the situation that after the
schematic component was modified with component prefix, the old method would deleted
and add new component when imported and updated into PCB, which would affect the
original layout of components.
Since V6.4.7, the component ID is used for matching associations, so old files or imported
third party EDA files can use this feature to reset the component ID so that the two IDs match.

Via: Top Menu - Design - Reset Component ID

Notice：

1. Make sure that the schematic diagram and the component prefix of the PCB match.
The reset ID is reset based on the component prefix.



2. It is necessary to reset the component ID on both schematic diagram and PCB so
that the component ID on both sides can match one by one.

3. For schematic diagram with subparts, it is necessary to change the component prefix
of the subparts of PCB pair to U1.1 or other subparts prefixes before resets the ID,
otherwise this component will still be deleted and replaced with a new one.
Subsequent releases will solve this issue.

Global Delete

If you feel your schematic or PCB is mess up, need delete objects in batch, you can:

Top Menu > Edit > Clear All，or CTRL + A select all and then press Delete key.

Delete the document and create a new one.



Using Top Menu > Edit > Global Delete, just delete what you want.

Schematic Modules

Copying codes is an easy job for coders, now copying and reusing a schematic or PCB is easy.
Take a power supply unit for example, you can save this unit as a schematic module.
Via File > Save as Module:
EasyEDA support create the PCB modules, it seems schematic module.

How to Create

Via: Save as Module and File > New > Schematic/PCB Module。

PCB module save at Library > Schematic/PCB module > Work Space > My Libraries



How to use

Since v6.4.3, after placing schematic modules and PCB modules, after Import Changes,
supports to keep the layout location.

How to use:

1. Draw schematic modules and PCB modules, and ensure that their component prefix are
one to one, and the footprint is also corresponding. The module's component prefix can
not have question marks and duplicate prefix, such as U? or two R1.

2. Open schematic and PCB at a same project.
3. Open "Library", select the module.
4. Click the "Place" button to place the previous saved schematic module and PCB module.
5. It will pop up a window to enter English letter. The letter of schematic module should
keep corresponding with PCB modules.

For example: A component at schematic module is U2, enter letter K, press OK to place
into canvas, it will be KU2, then PCB module has KU2 too.
Click "OK" and enter the placement mode. After each placement, the pop-up will
continue to enter the identification letter. Make sure that the identification letters entered
each time are unique.

6. When finish the module place, the PCB component unique ID will same as Schematic
component unique ID, then after Import Changes, the component's location will be keep.
and you can update the track's net follow the schematic netlabel too.

That implement the multipe chanel placing.



Notice:

Module composes by tracks and components, it doesn't same as symbol binding
footprint, the schematic module can not binding PCB module, after placing, the module
will be separated by many objects, only the symbol and footprint can be corresponding
via component ID, that is why you need to make the identication letter unique for placing
each time to make sure schematic module corresponding with PCB module.

Schematic Theme

EasyEDA support a powerful theme feature for the schematic design.

Via: Top Menu - View - Theme.

Original Theme：The default theme, only works for the new part placing.

White on Black：White on Black, the objects will be white, the background will be black.

Black on White：Black on White.



User Definded：When change to this theme style, the schematic will follow your theme
options "My theme".

My Theme：Custom theme, which is stored locally in the browser and it will be synchronized
to the server. When click apply, this theme will be applied to the current schematic. Next time
you open the schematic, the theme of the schematic will be a custom theme.

My theme Settings：You can apply "My theme" on: 1. Creating New Schematic, 2.Opening
Existed Schematic.

If you used any theme for the schematic, you need to UNDO to go back previous color theme.
The "Original Theme" can't help.

Your schematic theme will synchronized to the server by default.

Export BOM

You can export the Bill of Materials (BOM) for the schematic (Document) and PCB, via: "Top
Menu - File - Export BOM", or "Top Menu - Fabriaction - BOM".

After clicking the BOM export option, the dialog below will open.

In this dialog，you can click the buttom to assign LCSC part's order code for your
components.



After clicking on the assign icon，the components and footprints search dialog will pop up,
and you can choose which component you want to assign.

When you click the "Order Parts/Check Stock" button, we will help you to list all the
components of your BOM at LCSC.com(If you haven't login LCSC, you have to login first). If
you want to buy the components form LCSC, and you just need to put them to the cart and
check out.

You can open the BOM in any text editor or spreadsheet.



Export BOM supports to export LCSC part price, it is the same as LCSC website.

Notice:

Before v6.4.17, If your project has schematic and PCB, the BOM data will come from
schematic; if the project only has PCB, the BOM data will come from PCB.
Since v6.4.17, the schematic BOM and PCB BOM are separated. If you assign the LCSC
part at the PCB, it will not modify the schematic.
In order to support multiple languages, BOM and coordinate files (CSV file) are UNICODE
encoded and tab-based. If the CSV file cannot be read by your components vendor or
PCB manufacturer, please convert the encoding and change the delimiter.
Recommended solution: Save as a new CSV file in Excel or WPS. For example, open a CSV
file in Excel, click or select: Save As - Other Formats - CSV (Comma Separated) (*. csv).
You can also open the CSV file with any text editor (such as Windows Notepad) and save
as ANSI or UTF-8 encoding. If necessary, replace all tabs with commas.

Export NetList

EasyEDA can export the netlist for the whole active project:

File > Export NetList > Spice...


