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xiForeword

Foreword

Welcome to the second edition of SketchUp for Interior Design! Modeling software has 
largely replaced traditional two-dimensional drafting as the means for designers to 

create and communicate. SketchUp remains the modeling program of choice in many diverse 
fields due to its low price and short learning curve. Like the first edition, this one is for the 
beginner who wants to get up and running fast.

Why Read This Book?
You may be wondering why you should read a SketchUp book when there is so much content 
online. My answer is that online content, while very good, is not organized. If you don’t know 
what the software’s capabilities are, you don’t know what to ask or search for. This book leads 
you through SketchUp in an orderly manner. Its intent is to acquaint you with SketchUp’s 
many capabilities. Toward that goal, tools and functions are described under their own head-
ings and then used in tutorial examples.

SketchUp’s most popular functions are introduced early, to enable you to quickly do what 
you want with it. Some tools are revisited later to show more complex options. By the time you 
finish, you’ll have been exposed to most of the tools, one or two options for each, and differ-
ent approaches for solving modeling problems. You’ll be given links to forums where you can 
ask your increasingly complex questions. End-of-chapter resources will also help guide you 
through the ocean of Web information.

What’s Covered?
Coverage is specific to the interests of interior designers and interior architects: How to model 
interior spaces; study scale and proportion; test design ideas; plan spaces; present solutions; 
generate architectural floor plans, elevations, and sections. Also discussed is using SketchUp 
in conjunction with other industry-popular programs.

Any Pre-Reqs?
Prior knowledge of drafting software is not needed. However, it is assumed that the reader has 
basic architectural drafting knowledge, such as what floor plans, interior elevations, perspec-
tive, isometric, and section views are. This book shows how to use SketchUp to create those 
drawings; it doesn’t discuss what they are. If you could benefit from a drafting refresher, check 
out the resources at the end of this Foreword.

Computer and Version of SketchUp Discussed in this Book
Only SketchUp Pro is discussed because the free Web version does not yet have all Pro’s capabil-
ities. Most screenshots are from a PC, but where Mac operations are different, Mac screenshots 



xii Foreword

are included. This book also assumes the reader uses a laptop or tower computer. SketchUp can 
be used on some tablets, but a desktop or laptop with a three-button mouse (two buttons plus 
scroll wheel) exploits its full capabilities.

Extra Goodies
On the Wiley site there is a Homework folder with files for completing the end-of-chapter 
exercises. Download and save the whole folder at once to your desktop so everything will be 
available when needed. Instructors have an additional folder with answers to the end-of-
chapter questions.

So, let’s get started!

Further Resources
Cline, Lydia Sloan Architectural Drafting for Interior Designers, 3rd edition, New York: 

Bloomsbury, 2021

Lydia’s YouTube channel has architectural drafting and SketchUp tutorials.  
https://www.youtube.com/user/ProfDrafting

Download past versions of SketchUp here. https://www.sketchup.com/download/all

https://www.youtube.com/user/ProfDrafting
https://www.sketchup.com/download/all
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About the Companion Website

This book is accompanied by a companion website:

www.wiley.com/go/Cline/SketchUpforInteriorDesign

From the website you can find the following online materials:
▶▶ Quiz Questions and Answers
▶▶ End-of-Chapter Exercises
▶▶ Wallpaper and Draperies
▶▶ Homework

http://www.wiley.com/go/Cline/SketchUpforInteriorDesign




1Chapter 1: What Is SketchUp and How Do Interior Designers Use It?

What Is SketchUp?
SketchUp is a polygonal surface modeling program. Polygonal 
meaning that everything SketchUp creates is made from 
polygons. Those are planes—flat shapes bordered by straight 
lines (Figure 1‑1). Surface meaning that everything SketchUp 
makes is hollow. Modeling meaning that the result is a three-
dimensional (3D) digital drawing composed of lines and faces 
(planes). Collectively, those lines and faces are called geometry.

SketchUp is also a vector program, meaning it creates vector 
files. A vector file is a collection of lines and curves that scale up 
or down without loss of quality. Examples of vector files are PDFs 
(Adobe documents) and DWGs (AutoCAD documents). This is as 
opposed to a raster file, which is a collection of individual pixels 
and loses resolution quality when enlarged. Examples of raster 
files are JPGs and GIFs. SketchUp creates SKP and SKB files. SKP 
is the SketchUp file; SKB is an automatically created backup file. 
It preserves the next-to-last save. To change an SKB file into an 
SKP file, just over-type the SKB extension with SKP.

What Is SketchUp 
and How Do Interior 
Designers Use It?

Objective: This chapter discusses 
what modeling is and how the 
SketchUp modeling program is 
used by designers.

Concepts and Functions: SketchUp 
Pro, SketchUp Free, SketchUp 
Shop, SketchUp Make 2017, model, 
solid/surface/t-spline/mesh model, 
BIM, geometry, plane, polygon, 
vector, raster

CHAPTER  

1

Figure 1-1:  All SketchUp models, including circular ones, are made of 
polygons and are hollow.
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What Is SketchUp Used For?
SketchUp is used to electronically sketch ideas three-dimensionally—to “get your doodle on.” 
It’s an alternative to pencil and tracing paper for thinking out ideas. Many use it for quick 
iterations, design studies, and presentations. Since you can sketch loosely (meaning without 
imputing numbers), SketchUp helps you think spatially. Height/width relationships are easy 
to see; for example, a hallway that seems wide in a floor plan may present dark and narrow 
when the vertical dimension is added. As with a physical foam core model, a digital model can 
be studied from any direction. However, SketchUp one-ups the foam core model with camera 
tools that let you stroll through at eye level.

Who Uses SketchUp?
SketchUp was written as a user-friendly alternative to complex modeling software in the 
architectural field, its original user base. However, it has since been widely adopted by 
diverse fields such as interior design, game development, filmmakers, woodworkers, catalog 
illustrators, packaging designers, landscapers, real estate agents and stagers.

SketchUp Pro
SketchUp Pro is a subscription product; compare prices at https://sketchup.com/plans-and-

pricing. Educational pricing is available for students and faculty; academic proof must be 
submitted. One license permits two sign-ins.

SketchUp Pro works on both the PC and the Mac. Files made on one platform transfer 
easily to the other. It can be operated in limited fashion on some Wacom and Surface tablets, 
and on the iPad. A free viewer app can be downloaded at https://www.sketchup.com/products/

sketchup-viewer/downloads or from the App store. This lets you open and look at SketchUp 
files without having the software.

SketchUp Free and SketchUp Shop
SketchUp Free is a web app (https://app.sketchup.com/app?hl=en). It targets K-12 students 
and is for noncommercial use. Access it from any WebGL-enabled browser. It’s version-less 
and always sports the latest release. You can save your work as an STL file, which is useful 
for 3D printing simple models. However, Free lacks important features such as the ability to 
install extensions or to save models as SKP. There is a subscription product called SketchUp 
Shop that is SketchUp Free with some added functionality. Free has a different interface than 
Pro (Figure 1‑2).

SketchUp Make 2017
SketchUp Make 2017 is a legacy version that has most of Pro’s features but lacks some features 
that designers may need, such as the ability to import DWG files and geolocation data. 

https://sketchup.com/plans-and-pricing
https://sketchup.com/plans-and-pricing
https://www.sketchup.com/products/sketchup-viewer/downloads
https://www.sketchup.com/products/sketchup-viewer/downloads
https://app.sketchup.com/app?hl=en
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Download 2017 free at https://help.sketchup.com/en/downloading-older-versions. Pro and 
Make cannot both be installed on the same computer.

Is SketchUp Easy to Learn?
It’s probably easier than other commercial industry-standard modeling programs, as it has 
fewer features and is somewhat intuitive. But “easy” is relative. Like everything else, SketchUp 
still takes practice—you probably didn’t make great pencil sketches right away, either.

Know that there are many ways to do the same thing in SketchUp, and no one right way. 
Some ways may take a few more steps, but if you make learning SketchUp the priority, 
efficiency will follow.

Do I Need to Know AutoCAD?
AutoCAD or any other two-dimensional (2D) drafting program is not a prerequisite to 
learning SketchUp. This is because drafting and modeling programs operate differently. If 
your computer drafting experience has only been with traditional 2D software, you will find 
that modeling requires a different approach. You may also find that you never want to go back 
to 2D software once you see the power of 3D.

Difference between Traditional CAD Drawings and Models
With traditional 2D computer-aided drafting (CAD) software such as AutoCAD, the mouse is 
an electronic pencil with which you replicate the hand-drafting process. 3D drawings made 
with 2D software are really just a collection of 2D pieces assembled to give the illusion of three 
dimensions.

A model, however, is a true 3D object that you can orbit around to view from any direction 
(Figure 1‑3). By default, SketchUp displays the model as a 3-point perspective. That is, all 
parallel lines converge to left, right, and top or bottom vanishing points. However, SketchUp 

Figure 1-2:  The Free interface.

https://help.sketchup.com/en/downloading-older-versions
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can be set to display as a 2-point perspective, as an isometric (3D view in which parallel lines 
remain parallel), and orthographically (plan, elevation, and section views). Orthographic (2D) 
views are generated from the model. A model makes the jump to scaled construction docu‑
ments in the LayOut program that installs with SketchUp.

There are five model types: solid, surface, t-spline (Figure 1‑4), mesh, and building information 
model (BIM). It’s helpful to know a bit about them all, as this may affect time spent trying to 
achieve a specific result in SketchUp. No model type is best, as all have different abilities. For 
example, designs that require a constant wall thickness are better drawn with a solid mod‑
eler. Designs that require organic forms are better drawn with a sculpting modeler. A common 
workflow is to start a model in one program and export it to another for further development. 
This exploits the capabilities of both.

Figure 1-3:  Orbit around a model to view it from any position.

Solid

Surface

Mesh T-spline

Figure 1-4:  Solid, surface, mesh, and t-spline models.



5Chapter 1: What Is SketchUp and How Do Interior Designers Use It?

Solid Models
These are filled solid inside; think rock. They contain data like interior volume, mass, and 
weight. This enables you to perform tasks like specifying a constant wall thickness or 
connecting and curving adjacent edges. Create solid models by adding and subtracting 
primitive geometric forms, such as cubes and cylinders, to and from each other, or by 
sketching shapes and extruding them into solid forms. Solid models are used to create product 
models that have many parts and details. SolidWorks and Fusion 360 are popular solid 
modeler programs.

Surface Models
These are hollow with a skin composed of lines and faces. You can create complex curves and 
forms, but they have hard, not smooth, edges. Only surface data, such as area, is stored. A 
surface model doesn’t recognize geometry as specific features; for example, where a solid 
model would recognize a staircase and perform relevant calculations, a surface model just 
sees the staircase as lines and faces. Surface models are used when the designer is primarily 
concerned with form and appearance. SketchUp is a popular surface modeler for building 
design; Fusion 360 and Catia are popular surface modelers for product design.

T-spline Models
This is a type of surface model that is free-flowing and curvy, and composed of four-sided 
polygons. It’s used to create organic forms. You sculpt a t-spline model by pushing and 
pulling the polygons and dragging control (editing) points. Blender and ZBrush are popular 
t-spline programs.

Mesh Models
A mesh is a type of surface model that is created when a raw model is exported as an STL file 
from whatever software it was designed in. STL is a 3D printing format. Mesh models often 
have very high polygon counts. Ones with low polygon counts can be imported into SketchUp 
for further development.

Building Information Management (BIM)
A BIM model contains all building systems: architectural, electrical, plumbing, and heating, 
ventilation, and air conditioning (HVAC). The model lives on a server and can be accessed by 
anyone authorized to do so. BIM models also contain nongraphical data, such as material, fire 
resistance class, color, and cost of the objects in it. Revit and Chief Architect are popular BIM 
programs with architects and interior designers. SketchUp is not BIM, but with downloaded 
extensions it can have BIM properties.
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What SketchUp Pro Can Do
With this program you can:

▶▶ Model complete interiors and exteriors of buildings (Figure 1‑5).

▶▶ Import real-life terrain contours and geolocation information (Figure 1‑6).

Figure 1-5:  This house is completely modeled inside and out.

Figure 1-6:  Access land contours and geolocation data anywhere in the world through SketchUp.
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▶▶ Apply artsy styles with one click (Figure 1‑7). Export as high-resolution JPGs or anima‑
tions for marketing and presentations.

▶▶ Access high-quality, ready-made models from the 3D Warehouse, including products from 
manufacturer catalogs (Figure 1‑8).

Figure 1-7:  Four of the many line types and styles in SketchUp.

Figure 1-8:  Catalogs of product models in the 3D Warehouse.
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▶▶ Access extensions (add-on tools) from the 
Extension Warehouse.

▶▶ Import JPG files of floor plans to trace and model.
▶▶ Import DWG (AutoCAD) files of floor plans 

to trace and model (Figure 1‑9). DWG files 
become SketchUp geometry.

▶▶ Export SketchUp models as a DWG file for 
import into AutoCAD, Revit, or 20/20 for 
further development.

▶▶ Create presentation boards and scaled drawings 
from the model with LayOut, a program that 
installs with SketchUp (Figure 1‑10).

▶▶ Use, create, and edit dynamic components. These are models programmed to store 
information and perform specific actions. For instance, staircases can add steps 
when height is adjusted; cabinets can open doors with a mouse click; price and parts 
information can be stored.

▶▶ Perform additive and subtractive modeling tasks called Boolean operations. This saves mod‑
eling steps, making for a faster workflow (Figure 1‑11).

Figure 1-9:  This model was made from 
an imported AutoCAD plan.

Perspective

NTS
1
1

South Elevation

1/4” = 1’-0”
2
1

Floor Plan

1/4” = 1’-0”
3
1

West Elevation

1/4” = 1’-0”
4
1

Figure 1-10:  Create scaled drawings from the model in LayOut.
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▶▶ Generate reports, which are tables of information of the objects in the model. These tables can 
be lists and quantities of materials that are helpful for cost estimating, such as deciding 
how much paint to buy based on the area of walls in the model. Reports are generated 
with one click and downloaded as a CSV (Excel) file (Figure 1‑12).

Figure 1-11:  With solid modeling tools, a tenon is pushed into a block of wood, then pulled away, 
revealing a clean mortise joint created.

Figure 1-12:  A materials list of objects in the model.
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▶▶ Receive one year of free technical support via phone and e-mail with a Pro subscription. After 
that, a Maintenance and Support subscription is needed to receive support.

▶▶ Import hand sketches into SketchUp, trace and model.
▶▶ Do shadow studies.
▶▶ Export the model as a JPG and import it into a digital imaging program to add color 

(Figure 1‑13).

▶▶ Incorporate artwork and photos into the design. The tabs at the top of Figure 1‑14 are preset 
scenes for a slideshow presentation.

Figure 1-13:  Hand sketches imported, modeled, shadow-studied, and then colored in Photoshop. 
Courtesy of mkerrdesign.com.

Figure 1-14:  Incorporate artwork and photos into the design.

http://mkerrdesign.com
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▶▶ Import images of the textiles to be used in the design (Figure 1‑15).
▶▶ Save models locally on your own computer or on the Trimble Cloud for remote collaboration 

(Figure 1‑16). You have unlimited online storage.

Want to learn more? Join me in Chapter 2, where we’ll discuss what’s needed to run 
SketchUp, put it on your computer, and explore its interface.

Summary
SketchUp is a surface modeling program used by interior designers for space planning, 
conceptual design, client presentations, and document drawings. Users can think through an 
idea, study design options, and present them creatively.

Further Resources
The Official SketchUp Blog: http://sketchupdate.blogspot.com/

Buy SketchUp here: https://store.sketchup.com/

Learn about SketchUp on the iPad: https://www.sketchup.com/products/sketchup-for-ipad

SketchUp for Web: https://www.sketchup.com/products/sketchup-for-web

Download a free SketchUp viewer: https://www.sketchup.com/products/

sketchup-viewer/downloads

Figure 1-16:  Upload your model to the Trimble Cloud 
directly from SketchUp and collaborate with others on it.

Figure 1-15:  A textile pattern imported 
and applied to a drapery model.

http://sketchupdate.blogspot.com/
https://store.sketchup.com/
https://www.sketchup.com/products/sketchup-for-ipad
https://www.sketchup.com/products/sketchup-for-web
https://www.sketchup.com/products/sketchup-viewer/downloads
https://www.sketchup.com/products/sketchup-viewer/downloads
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Compare plans and prices: https://sketchup.com/plans-and-pricing

SketchUp Shop: https://help.sketchup.com/en/sketchup-web/whats-included-sketchup-shop

Learn about other modeling types: Fusion 360 for Makers, 2nd edtion by Lydia Sloan Cline.  
San Francisco: Maker Media.

https://sketchup.com/plans-and-pricing
https://help.sketchup.com/en/sketchup-web/whats-included-sketchup-shop
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Hardware, Operating System, and 
Browser Requirements
An internet connection is needed to authorize SketchUp 
each time you open it, and to use some of its features. A late-
model computer and operating system is recommended, as 
SketchUp is a graphics-intensive program. The more detailed 
your model, the more processing power it needs. Following 
are the recommended specifications. SketchUp’s help menu 
has a downloadable app that can check your machine for 
compatibility.

PC: Windows 11, Windows 10
▶▶ 2+ GHz processor
▶▶ 8+ GB RAM
▶▶ 700 MB of available hard-disk space
▶▶ 3D-class video card with 1 GB of memory or higher and 

support for hardware acceleration
▶▶ Video-card driver must be up-to-date and support 

OpenGL 3.1 or higher
▶▶ Microsoft .NET Framework version 4.5.2
▶▶ three-button, scroll-wheel mouse
▶▶ Microsoft Internet Explorer 9.0 or higher

Mac: OS 12+ (Monterey), 11+ (Big Sur), and 
Mac OS 10.15+ (Catalina)

▶▶ 2.1+ GHz processor
▶▶ 8 GB RAM
▶▶ 700 MB of available hard-disk space

Getting Started
Objective: This chapter discusses 
what is needed to run SketchUp 
and looks at the interface.

Concepts and Functions: three-
button mouse, video card, Space 
Mouse, workspace, menu bar, 
global axes, scale figure, origin, 
measurements box, instance, 
viewer app, template, Trimble  
Connect, coordinates, backup files

CHAPTER  

2
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▶▶ 3D-class video card with 1 GB of memory or higher and support for hardware 
acceleration. The video-card driver must support OpenGL version 3.1 or higher and be 
up-to-date.

▶▶ Three-button, scroll-wheel mouse
▶▶ QuickTime 5.0 and Safari

A keyboard and three-button scroll-wheel mouse are needed. A one-button mouse or track-
pad is doable but difficult. 3D modeling requires much more on-screen movement than 2D 
drafting. A scroll wheel and right-click button let you make that movement faster than click-
ing icons and keyboard shortcuts, tapping, and sliding.

Tablets
SketchUp can also be used on an iPad Pro, Surface Pro, and Wacom graphics tablet. Use it with 
an Apple Pencil, mouse, and keyboard; a stylus pen; and/or gesture software.

Viewer App
SketchUp has a free viewer app that can be 
used on an Apple or Android phone or tablet 
(Figure 2‑1). This is useful for showing a 
model on the job site. The viewer app can 
also be downloaded on a desktop, useful for 
someone who wants to see the model but 
doesn’t have SketchUp. The viewer’s interface 
resembles SketchUp’s Web version. A model 
must be downloaded to the device to be 
viewed; the viewer app cannot access the 
model from the cloud.

Video Card
The video card, also called a graphics card, is an electronic board inside the computer that sends 
information to the monitor. Standard computers come with a built-in card that may display 
SketchUp models with a low-resolution, jagged appearance. A dedicated card, such as the 
kind used for graphic design, HD-video editing, animation, and gaming will give a smoother 

Figure 2-1:  The SketchUp viewer on an iPad Pro.

▶▶ SketchUp can adjust icon and drawing element sizes appropriate for high DPI (dots per inch) screens. 
Icons are sized when SketchUp starts up. If you adjust your DPI or scale (Microsoft Windows, up to 150%) 
you will need to restart SketchUp to see correctly sized icons and drawing elements.
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appearance (Figure 2‑2) and better handle the high demands of modeling software. If you plan 
to print SketchUp models for construction documents and marketing purposes, a high-level 
video card is especially important.

Space Mouse
A mouse option for both the PC and Mac is 
3DConnexion’s Space Mouse (Figure 2‑3), designed 
for modeling software. You push, pull, twist, or 
tilt the mouse to pan, zoom, and orbit around 
the model. The Space Mouse has programmable 
buttons for your most-used tools. It’s not a 
replacement for the traditional mouse; you still use 
that to select, create, and edit.

Download SketchUp Pro
It’s time to point your browser to www.sketchup 

.com and download Pro (Figure 2‑4). Note the 
offerings under the Products tab. Pro, Studio, 
Higher Education, and Universities are the same 
product with different subscription prices. Shop 
is the same as Free with the ability to import 
and export more file types and access to Trimble 
Connect for storage and collaboration.

Three programs will download: SketchUp Pro, LayOut, and Style Builder (Figure 2‑5). All 
can be used independently or linked to each other. Linking lets you sync updates.

Figure 2-2:  Standard video-card output (left), dedicated graphics card (right).

Figure 2-3:  The 3D mouse is used with a  
traditional mouse.

http://www.sketchup.com/ 
http://www.sketchup.com/ 
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Figure 2-5:  SketchUp Pro, LayOut, and Style Builder icons.

Launch SketchUp Pro
Click on the SketchUp Pro icon to launch. You’ll be asked to sign in (Figure 2‑6). Use your 
Google, Apple, or Trimble account. If SketchUp is already open on more computers than your 
license allows, a splash screen will tell you so.

Click on the Manage activations button. It sends you to your Trimble account. Managing  
the activation is the one time you will need a Trimble account. You can make one here or on 
any SketchUp site, such as the 3D Warehouse. Click on My Products>View Included  
Applications. Then click on Manage Devices for SketchUp Pro, LayOut, and Style Builder. Once 
deactivated, sign out of Trimble, re-sign in, and restart SketchUp.

Figure 2-4:  Download SketchUp Pro.
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Choose a Template
Once signed in, a Welcome screen with six template choices appear (Figure 2‑7). These are 
files with different default measurement settings to accommodate different uses, such as 
woodworking and 3D printing. Click More templates for another 12 choices. SketchUp will open 
after you choose a template. The template you last chose will appear as the first thumbnail 
on the template choice page. You can skip this screen by clicking on Preferences>General 
and unchecking Show Welcome Window. If you do this, your default template will open. 
Making your own custom template is discussed in Chapter 3. For our practice file, choose 
Architectural Inches.

Figure 2-6:  The sign-in screen.

Figure 2-7:  Choose a template.
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Getting Started Toolbar Menu

Scale
Figure

Axes

origin

Model Info Measurements Box

Panel
Trays

Geolocation

User Info

Figure 2-9:  The PC’s workspace.

With this template, all dimensions appear in 
a feet and inch format (Figure 2‑8). When you 
type a number, the default is inches, so no need 
to add the inch unit (″). But to enter feet, you 
must add the foot symbol (′) after a dimension 
number. Know that you can also type dimension 
units in metric (mm, cm, m) in the architectural 
inches template; just include the unit after the 
dimension number.

The Workspace
The workspace operates a bit differently in PC 
and Mac, and we’ll note those differences as we 
get to them.

Figure 2‑9 shows the PC screen. The Mac screen is almost identical; Figure 2‑10 shows dif-
ferences. Mac users, your menu starts with a SketchUp entry, and that entry contains the 
Preferences and Licensing/Update options that are under the PC’s Window and Help menus. 
Mac users also don’t have the panel trays on the right side of the screen that PC users have. 
Instead, Mac users click open individual submenus, double-click on them to minimize, and 
then stack and move them together around the screen.

Following are the elements of the workspace.

Figure 2-8:  Dimensions in the architectural 
inches template appear in feet and inches.
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Menu Bar
This is a horizontal bar at the top of the screen that houses tools and functions. It has nine 
categories: file, edit, view, camera, draw, tools, window, extensions, and help.

▶▶ File. Contains functions that let you open, save, print, import/export files, send files to 
LayOut, geolocate a file, and access Trimble Connect, which is online storage and collab-
oration space. There’s also a Predesign option, which assists with research.

▶▶ Edit. Contains standard undo/redo, cut, copy, and paste functions plus SketchUp-
specific ones like making selections, groups and components, hide/unhide, and 
deleting guides.

Window PC

Sketch Up Mac

Stacked
Submenus

Panel
Trays

Figure 2-10:  The PC and Mac menu bars.
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▶▶ View. Contains options that alter how the model looks, such as opaque or transparent, how 
section cuts are filled, show hidden geometry, shadows, fog, and animation settings.

▶▶ Camera. Contains tools that affect how you view the model, such as in perspective, 
isometric, or 2D; orbit/pan/zoom; walk and look around at eye level; and match the 
model’s perspective with that of an imported photo.

▶▶ Draw. Contains line, arc, and shape tools for creating the model.
▶▶ Tools. Contains what’s needed to edit and modify. Here you’ll find the eraser, paint 

bucket, move, rotate, scale, push/pull, follow me, offset, tape measure, and protractor. 
Also contains dimension and text tools, the section plane, solid tools (these mimic a 
solid modeling experience) and the outer shell tool (this removes interior overlapping 
geometry).

▶▶ Window. Here is where you turn the panel trays on and off. Also, access model 
information, preferences, components options/attributes, and the 3D Warehouse 
(models that others made) here.

▶▶ Extensions. Access the Extension Warehouse (more tools) and Extension Manager 
(install and update).

▶▶ Help. Here you can return to the template choices, access online support, check what 
version you’re using and if there’s an update, manage your license, and download an app 
that checks your computer for the ability to run SketchUp.

Getting Started Toolbar
The horizontal bar under the Menu bar contains icons that activate the most common drawing 
and editing tools. It opens by default when you open SketchUp.

The Global Axes
These are the height, length, and depth lines along 
which you draw. Their intersection is called the 
origin. The height (z) line is blue, and the ground 
lines (x and y) are red and green. The axes lines are 
solid in the positive directions and dotted in the 
negative. Every point has a coordinate (group of 
numbers) that describes its location. For example, 
(3,4,5) means 3 units along the x/red axis, 4 units 
along the y/green axis, and 5 units along the  
z/blue axis. You can find each point’s coordinates 
by clicking the Text tool onto it and then dragging. 
The coordinates will appear in the text box 
(Figure 2‑11).

Figure 2-11:  Every point has a coordinate 
that describes its location along the axes.
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Global axes apply to the whole model. Individual components have their own, local 
axes. Those local axes can be rotated so they don’t match the global axes if the design war-
rants it. If a downloaded component’s local axes don’t match the global axes, they can be 
rotated to match.

Scale Figure
This human shape helps you visualize sizes, which is useful when you’re loosely sketching 
instead of imputing dimensions. The scale figure is a component, meaning a collection of loose 
lines and planes that are manipulated together. It is a 2D shape, but 3D figures are available in 
the Warehouse.

▶▶ Fun fact: In each major annual release the scale figure is a different SketchUp team member. You can 
download them all from the Warehouse. Earlier scale figures are dynamic, meaning when you click the 
dynamic components tool on them, some characteristics change.

Bottom-left Screen Icons
Pin activates the geolocation tool (this defines the 
precise location on Earth where the model exists).

Figure opens the model information window. Here 
you can access and modify settings on functions 
such as animations, dimensions, components, text, 
and units.

Instructor. This icon is on the Mac and opens a brief 
tutorial for the currently activated tool (Figure 2‑12). On 
the PC, access the Instructor at Window>Default Tray 
and click Instructor to make it appear in the panel trays. 
Links inside the Instructor take you to the SketchUp 
Knowledge Center. Clicking on a different tool changes 
the information in the Instructor. If the Instructor dis-
tracts you, go to Windows> Instructor and uncheck 
it. When you want it back, recheck. You can also make 
the Instructor appear and disappear by clicking the cir-
cled question mark in the lower-left corner of the mod-
eling window.

Measurements Box
The rectangular field in the lower-right corner displays 
all dimensions. If you don’t see it, it may be hidden 
behind your taskbar/dock. Maximize the SketchUp screen or drag it higher on the desktop.

Typing numbers is how to make SketchUp models accurate. You don’t have to type num-
bers specifically in the Measurements Box—that’s just where they’ll show up. Such numbers 

Figure 2-12:  Icons and Instructor 
window on the Mac.
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include line lengths; circle diameters; rectangle sizes; number of polygon sides; number of 
copies; distance to move, offset or push/pull something; and rotation angles. Some tools cause 
default numbers to appear, and you’ll overtype them when needed. For example, when you 
click on the Polygon tool, the number 6 appears in the box, meaning you’ll draw a polygon with 
six sides. Before clicking the polygon in place, click in the Measurements box and type in the 
desired number. Then draw the polygon.

The nature of the number that appears in the Measurements box depends on which tool is 
activated. The number could mean inches, degrees, or number of sides. As we cover different 
tools, how they’re entered in the measurement box will be discussed.

Panel Trays
These are where files and functions are stored. 
Earlier we clicked open the Instructor tray. Click 
on the Materials tray now. You’ll find a drop-down 
menu with nested options for stone, tile, carpet, 
and other items (Figure 2‑13). View the trays on a 
PC at Window>Default tray (Figure 2‑14). That’s 
where you click individual trays on and off. If you 
inadvertently turn off a tray, just go there to turn 
it back on. Tray order can be changed by dragging 
them. Mac users, you need to turn the trays on 
under the Window menu.

Run Multiple SketchUp Files at 
the Same Time
On a PC, clicking File>New prompts you to save 
the current file. Upon saving, the file closes, and 
a new instance (open copy) of SketchUp opens. If 
you want to close the file without saving but keep 
SketchUp open, click No when asked to save the 
file. Clicking File>Open prompts you to save the 
current file and then navigates to another one. You 
can run multiple instances (copies of SketchUp 
software) on a PC by right-clicking on the SketchUp 
desktop icon and selecting open or clicking on the 
desktop icon of the file you want to open. While 
you can run multiple instances, you can’t run 
multiple files under one instance.

On a Mac you can have multiple files open in 
one instance. Clicking File>Open or File>New 
opens a new file without closing the current one.

Figure 2-13:  The Materials tray/
carpet options.

Figure 2-14:  View all trays at 
Windows>Default tray.
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Save Options
Under File there are four save options. Save does 
just that—it saves the open file. Save As replaces 
the open file with a new one. Save A Copy As leaves 
the current file open and makes a closed copy at 
a location you choose. Save As Template makes 
a template out of your file. The file is saved with 
an SKP extension and it will appear with all the 
other template choices when you open SketchUp. 
Files made in earlier versions of SketchUp can 
be opened in later ones. Files made with later 
versions may not work correctly in earlier versions 
if they can be opened at all. You can save a file as 
an earlier version by scrolling through the Save 
As Type field at the bottom of the Save dialog box 
(Figure 2‑15) and choosing the earlier version of 
SketchUp you want.

SketchUp automatically creates an autosave file 
at a time increment of your choice after the last 
save. Set that increment at Window>Preferences 
>General and check Autosave (PC), and at 
SketchUp>General (Mac). The autosave file deletes once you save again or exit. If SketchUp 
crashes, the autosave file remains, giving you almost up-to-date work. Set a frequent autosave 
to protect against crashes.

Backup Files
Backup files are automatically made in the same location as the SKP file (ensure that the 
Create Backup box is checked at Preferences>General). They have an SKB extension. Don’t 
delete backups until done with a project, as they’re useful if (oh, the horror) the SKP file gets 
corrupted or accidentally overwritten. SketchUp’s backup files are unique in that they’re the 
previously saved version of the model, not the last saved version. This is handy if you mess 
up a model after a save and need to backtrack a bit. Convert an SKB file into an SKP file by 
overtyping the b into a p.

Save and Exit the Software
PC users, click File>Exit or the X in the upper-right corner. Mac users, go to SketchUp>Quit 
SketchUp to exit the software; clicking the red button in the upper-left corner just closes the 
active file, not the software, because you can have multiple files open in one instance.

Figure 2-15:  Save SketchUp files in their 
current version or as an older one in the 
Save As dialog box.
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Now’s a good time to save the file—call it Practice and choose where on your computer to 
save it. Perhaps make a folder called SketchUp Files and put all work from this book in it. Next 
up is navigating around the workspace! Join me in Chapter 3 where we’ll start learning tools.

Summary
SketchUp runs on both the Windows and Mac platforms. It requires an internet connection 
and is optimally used on a tower or laptop computer with a strong graphics card, three-button 
mouse, and keyboard. It can be run on some tablets. A viewer app is available that enables 
you to see a model without installing the SketchUp software. SketchUp can run multiple 
simultaneous files; on the PC they are separate instances and on the Mac the files can run 
under one instance. The automatically created SKB backup file preserves the next-to-last 
saved version.

Further Resources
Hardware needed to run SketchUp: https://help.sketchup.com/en/sketchup/

system-requirements

SpaceMouse models: https://3dconnexion.com/us/spacemouse/

Download SketchUp viewer app: https://www.sketchup.com/products/

sketchup-viewer/downloads

SketchUp Free vs. SketchUp Shop: https://help.sketchup.com/en/sketchup-web/

whats-included-sketchup-shop

Tips on using Trimble Connect: https://blog.sketchup.com/

article/7-tips-for-remote-collaboration

Overview of the Predesign feature: https://help.sketchup.com/en/predesign-sketchup/

getting-started

https://help.sketchup.com/en/sketchup/system-requirements
https://help.sketchup.com/en/sketchup/system-requirements
https://3dconnexion.com/us/spacemouse/
https://www.sketchup.com/products/sketchup-viewer/downloads
https://www.sketchup.com/products/sketchup-viewer/downloads
https://help.sketchup.com/en/sketchup-web/whats-included-sketchup-shop
https://help.sketchup.com/en/sketchup-web/whats-included-sketchup-shop
https://blog.sketchup.com/article/7-tips-for-remote-collaboration
https://blog.sketchup.com/article/7-tips-for-remote-collaboration
https://help.sketchup.com/en/predesign-sketchup/getting-started
https://help.sketchup.com/en/predesign-sketchup/getting-started
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In Chapter 2 you installed and launched the SketchUp soft‑
ware and saved a file called Practice. Open it, as we’re going to 

maneuver around the workspace now.

Add the Large Tool Set
The Getting Started toolbar doesn’t contain every tool. There 
are a lot more. On the PC, click View>Toolbars. This opens the 
toolbar window, which shows them all (Figure 3‑1). Check the 
box in front of Large Tool Set to make that toolbar open, and 
then double-click on the toolbar’s top bar to dock it (Figure 3‑2). 
On the Mac, click View>Tool Palettes>Large Tool Set 
(Figure 3‑3). A floating toolbar will appear. Mac toolbars don’t 
dock or minimize with the workspace. On both the PC and Mac 
you can move toolbars off SketchUp and onto the desktop for 
more workspace room.

Exploring 
the Interface

Objective: This chapter discusses 
the SketchUp desktop and how to 
maneuver around it.

Tools: screen tip, select, rectangle, 
push/pull, pan, orbit, zoom, move, 
transparent tool

Concepts and Functions: menu 
bar, getting started toolbar, views 
toolbar, standard toolbar, large 
tool set, auto-select, inference 
engine, inference lines, windows, 
preferences, model info, trans-
parent tool, modifier key, plan, 
elevation, perspective, paraline, 
isometric, selection window, 
crossing window, template, select, 
erase, undo, rectangle, rotated 
rectangle, lasso, push/pull, impute 
numbers, orbit, pan, zoom, move, 
copy

CHAPTER  

3

Figure 3-1:  On the PC, click View>Toolbars to see all the tools 
available.
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Large Tool Set duplicates many of the 
tools in Getting Started and has additional 
tools. Throughout this book we’ll mostly 
access tools through toolbars. But you can 
access them through the Camera, Draw, 
and the Tools menus at the top of the screen 
if you want.

Explore! Hover the mouse over each icon to 
read its screen tip, a pop-up menu that describes 
what each tool is and what it does (Figure 3‑4) to get familiar with the icons. Click on the 
Menu items and read the submenus. Shortcut fans can find a list of keys that activate tools at 
Window>Preferences>Shortcuts (PC) or SketchUp>Preferences>Shortcut (Mac). Now 
let’s play with some of those tools.

Figure 3-2:  Click open the Large Tool Set.

Figure 3-3:  On the Mac, click View>Tool 
Palettes>Large Tool Set to add it to the 
workspace.

Figure 3-4:  Hover the mouse over a tool icon 
to see its screen tip.
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The Search Tool
Click on the magnifying glass and a search box appears (Figure 3‑5). The shortcut is Shift + S.  
You can quickly find and activate both built-in commands and installed extensions. Just 
type the tool’s name or a word related to its workflow, such as “elevation” or “Boolean.” This 
search box is especially helpful with tool menus that have a lot of icons. Instead of keeping 
that toolbar open all the time, you can just type in its name when you want it and the toolbar 
will appear.

The Select Tool, 
Erase and Undo
The Select tool icon (Figure 3‑6) 
is an arrow. It highlights objects 
for editing and for context 
menu-clicking. Click to activate.

With the Select tool activated, 
click on the scale figure component. A blue box 
appears around it, indicating that it is highlighted. 
This means you’ll get a specific context menu 
when you right-click on it. Right-click inside the 
blue box and choose Erase from the context menu 
(Figure 3‑7). He’s gone! No worries, go to Edit 
>Undo Erase to bring him back. Undo reverses 
the last action, and you can undo all actions one 
at a time until the last save. Or just reimport 
him by clicking on the Components tray from 
the Panels tray on the right (Mac Users, find it 
under the Window menu) and then on the house 
icon (Figure 3‑8). All components in the model, 
including erased ones, appear under the house 
icon, and you can drag them into the workspace. 
Return to the Select tool by clicking the space bar.

Figure 3-5:  The Search window.

Figure 3-6:  The Select tool.

Figure 3-7:  Right-clicking on a selected 
item brings up a context menu.
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The Select tool has a drop-down arrow 
in which a lasso is nested. This lets you 
select irregular boundaries. Its shortcut 
is Shift + Spacebar

The Rectangle Tool
The Rectangle tool looks like a square and 
its dropdown arrow accesses a rotated 
rectangle (Figure 3‑9). Click it.

Now click the cursor anywhere on 
the modeling window, drag and click 
again. You’ve just drawn a rectangle 
(Figure 3‑10).

The Inference Engine
While dragging the rectangle, you may have 
noticed a diagonal dotted line appear and 
disappear (Figure 3‑11). That’s SketchUp’s 
inference engine at work. This diagonal 
line appeared when the rectangle’s shape 
was dragged into a proportion called the 
Golden Section. If the rectangle is dragged 
into a perfect square, a screen tip that says 
square will appear.

The inference engine is a geometric 
analysis feature that enables you to 
draw accurately. It helps you make accu‑
rate models without constantly typing 
dimensions. Based on how and where 

Figure 3-8:  The house icon shows all components 
in the model.

Figure 3-9:  The Rectangle tool.

Figure 3-10:  A rectangle drawn with the Rectangle tool.
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you move the cursor, it assumes, or infers, the specific points, planes, and directions you want, 
like AutoCAD’s osnaps, if you’re familiar with those. For example, if you hover over the approx‑
imate location of the midpoint, endpoint, or edge with the Pencil tool, the actual midpoint, 
endpoint, edge, etc., will appear as a colored dot or line.

▶▶ Tip: Sometimes the inference you want won’t pop up immediately. In that case, encourage it by moving 
the cursor a few seconds over that area.

There are three kinds of inferences: point (e.g., to an endpoint or midpoint), linear (along the 
three axes), and planar (on the model’s faces). To clarify planar inferencing, SketchUp snaps to 
a plane when it cannot snap to a specific piece of geometry.

Instead of abstractly discussing inferencing, we’ll discuss it as we use it. For now, just go to 
Edit>Undo Rectangle (Figure 3‑12) and then redraw the rectangle as a square by watching 
for the diagonal inference line and clicking when the “square” screen tip appears.

Figure 3-11:  This dotted inference line indicates the rectangle has Golden Section proportions.

Figure 3-12:  Every action is immediately reversed with the Undo function.
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The Rotated Rectangle Tool
This is nested in the Rectangle tool and lets you use three points to create a rectangle. This is helpful 
for items that need two endpoints for length and another for height, such as doors (Figure 3‑13).

The Circle Tool
This is also nested in the Rectangle tool. Click on the tool and move the cursor to the 
workspace, but don’t click it on the workspace yet. Notice the 24 that appears in the 
Measurements box (Figure 3‑14). This circle is really a polygon with a default of 24 sides. 
Before clicking the circle into place, hit the Backspace key and the 24 will disappear, enabling 
you to type a new number. Do not hit any key in between the Backspace key and new number; 
if you do, the new number won’t take.

Why would you want to change the polygon number? Well, a bigger number creates a 
smoother shape that more closely resembles a circle. The downside is that also creates a larger 
file size, so is inadvisable if the circle is a minor feature. If you won’t be zooming in on this 

1. 2.

3.

Figure 3-13:  Use the Rotated Rectangle to draw a door.
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circle because it is a minor feature, 
type a smaller number. Let’s accept 
the default of 24 and click the circle 
tool twice to create it.

What makes the circle-polygon 
different from the polygon made with 
the Polygon tool that is also nested 
with the Rectangle tool? Click the 
Polygon tool, backspace the default 
of 6, type 24 and hit Enter. Your 
polygon will have 24 sides just like 
the circle. But when you extrude it up 
with the Push/Pull tool, all the sides 
will show. When the circle is extruded, it is smooth (Figure 3‑15).

The Push/Pull Tool
Push/pull (Figure 3‑16) adds volume to a face 
by extruding (stretching) it. It’s an auto-select 
tool, meaning when you move it onto a face, 
the face highlights. Not all tools auto-select; 
generally, you must highlight a face in a 
separate action with the Select tool. Click the 
push/pull icon and then move the mouse 
onto the square you just drew. See how 
the face becomes dotted? That means it’s 
selected and ready to edit. Click, hold, and 
drag the cursor up, let the cursor go, type 
5′ and hit Enter. The square is now a 5′ tall 
cube (Figure 3‑17).

Figure 3-14:  The default for the circle is 24 sides.

Figure 3-15:  An extruded polygon and circle.

Figure 3-16:  The Push/Pull tool.

Figure 3-17:  A cube made with Push/Pull.
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Note that while 5′ appears in the measure‑
ments box, I didn’t have to type inside that box. 
I can type the number anywhere on the screen. 
Since we’re using the inches template you don’t 
need to type the inch symbol (″) after each 
number, but you do need to type the foot symbol 
(′) if you want feet. Type metric units (mm, cm, 
m) if you want those.

When the face being extruded is adjacent 
to another face, it will pull that face along 
(Figure 3‑18). To keep the adjacent face intact, 
press and release the Ctrl key (Command on 
the Mac) right before performing the push/
pull action. If you push/pull a face on an 
angled surface up, the resultant volume will be 
rectangular. Press and release the Ctrl key to 
preserve the original shape.

Impute Numbers
To make the cube a specific size, type its dimensions as you model it. For example, after 
clicking the first point of a rectangle, type 5',5' and hit Enter. The rectangle will snap to 5 feet 
on each side. The first dimension goes along the red axis, the second dimension goes along the 
green. To change the size, type new numbers immediately after hitting Enter. If you perform 
any intermediate action after hitting Enter, such as clicking on a different tool, you won’t be 
able to enter new numbers. SketchUp draws at a 1:1 scale, so the 5′ is true size, meaning an 
actual 5′. Working with true size numbers makes calculations for scaling the model easier.

To impute fractions, add a space between the inch and fraction. For example: 7′-6 1/2, 7′-6 
1/2. Don’t forget the comma between the set of numbers (Figure 3‑19). Change the precision 
of fractions at Window>Model Info>Units (Figure 3‑20).

Figure 3-18:  Press the Ctrl key (Command 
on the Mac) to preserve faces and forms 
when using Push/Pull.

Figure 3-19:  Imputing whole numbers and fractions.
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▶▶ Tip: You don’t have to type two numbers to draw a rectangle. You can type one number and click on a 
piece of geometry for the second number. Either type the first number and click the second or click the 
first number and type the second.

The Pan, Orbit, and Zoom Tools
Pan looks like a hand; click on it. (Figure 3‑21). 
Then click on the cube, hold, and drag it around the 
screen. You’re panning, that is, moving the view 
around the desktop. You can also pan by holding the 
left mouse button and the scroll wheel down together. Pan is useful for moving geometry away 
from anything overlapping it, such as other geometry or dialog boxes (pop-up windows).

Now click on the Orbit tool, the circular arrows left of Pan. This whirls you, the viewer, 
around the cube; the cube itself doesn’t move. Orbit lets you spin around the model to view it 
from all angles. The most efficient way to orbit is to hold the mouse scroll wheel down and drag 
it around.

Orbit on top, below, and behind the cube (Figure 3‑22). Hold the Shift key down while 
orbiting to temporarily pan.

The Zoom icon is a magnifying glass to the right of Pan. Zooming in brings you close to an 
object, which lets you examine small details. Zooming out takes you farther away, which lets 
you see the big picture.

Figure 3-20:  To change the model’s units, go to Window>Model Info>Units.

Figure 3-21:  The Pan and Orbit tools
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Click the Zoom tool onto the model, hold the left 
mouse key down and drag it up and down to zoom 
in and out (Figure 3‑23). Even better, just rotate 
the scroll wheel on the mouse. The icon to Zoom’s 
right—the magnifying glass with three arrows—is 
Zoom Extents. Clicking it makes the whole model 
fill up the window.

If you click Zoom Extents and your model 
hides off in a corner, it’s because there are little 
pieces of geometry you drew earlier still lurking 
around. Find and erase them, and your model 
will come back. Clicking Zoom Extents is a good 
way to locate those lost, small pieces.

Pan, Orbit, and Zoom are transparent tools, 
meaning you can activate them while using 
another tool and then pick up the other tool 
where you left off. For example, if you’re drawing 
something with the Pencil and click on Orbit, the 

Figure 3-22:  Orbiting around the cube.

Figure 3-23:  Zooming out and in.
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Pencil icon will deselect. When you click the Pencil to reactivate, it will resume drawing in 
the location it was before you clicked Orbit.

Modifier Keys
Modifier keys are keys pressed while using a tool to make it do something else. Examples are 
the Shift key while orbiting to temporarily pan, or the Ctrl key while push/pulling to keep a 
face intact. Here are PC and Mac modifier key equivalents:

PC MAC
Alt Command

Ctrl Option

Enter Return

Shift Shift

The Escape Key
The Esc key quits an operation. It cancels dialog boxes, closes menus, and quits functions. If 
you’re in the middle of something and need to get 
out, just hit Esc.

The Camera and 
the Views Toolbar
You’ve probably noticed by now that the cube 
you modeled appears in perspective. That is, 
it looks the way the eye sees it: parallel lines 
converge to vanishing points and its size changes 
with proximity to viewer location. Three-point 
perspective is SketchUp’s default mode. However, 
you can make the model appear as a paraline view, 
which is where parallel lines remain parallel; 
they don’t converge. Click on Camera>Parallel 
Projection (Figure 3‑24). Now the cube appears as 
an isometric view, a type of paraline drawing where 
the horizontal lines slope at a 30° angle.

With parallel projection on, let’s do something 
that makes modeling software really shine. We’ll 
generate orthographic views from this cube, spe‑
cifically top, front, and side views. Or in architec‑
tural drafting terms, the plan and elevations.

Figure 3-24:  Click on Camera>Parallel 
Projection to see the model in a 
paraline view.
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On the PC, click on View>Toolbars 
and check the Views box. A toolbar with 
icons that look like 2D views of a house will 
appear (Figure 3‑25). On the Mac, go to 
View>Customize Toolbar. A tools page appears on which tools are stored (Figure 3‑26). Drag 
the Views toolbar from this window into the Getting Started toolbar (Figure 3‑27). Drag the 
Undo/Redo arrows there also, while you’re at it.

Figure 3-25:  The Views toolbar.

Figure 3-26:  On the Mac, Views>Customize Toolbar brings up a tools dialog box.

Figure 3-27:  On the Mac, drag the Views toolbar into the Getting Started toolbar.
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Clicking on View’s icons generates top, front, right, back, and left views (Figure 3‑28). To 
return to the isometric view, click the View toolbar’s first icon, the one whose screen tip says 
iso. Finally, click Camera>Perspective to return the model to a perspective view.

Selection Techniques
Geometry must be selected before anything can be 
done with it. A highlighted cube has blue dots on 
its faces and is ready for editing. Activate the Select 
tool by clicking on it. Your selection options are:

Selection Window (Figure 3‑29). Hold the mouse 
down and drag it from the upper-left corner to the 
lower-right corner. Let go. All geometry entirely 
within that window will get selected for edit‑
ing. Anything partly outside the window will not 
be selected.

Crossing Window. Holding the mouse button, 
drag it from the lower-right corner to the upper-left 
corner. This creates a crossing window. All geometry 
touched by that window, whether entirely inside it 
or not, will get selected.

Right Click on selected geometry. You’ll get a slightly different context menu depending 
on whether you select a line or plane, but options include selecting by connected faces; all 
connected geometry; all with the same tag; and inverting the selection (Figure 3‑30).

Figure 3-28:  Isometric and top views of the cube.

Figure 3-29:  Drag a selection 
window from the upper-left to lower-
right corners.

Cline897743_c03.indd   37 2/1/2023   9:00:24 PM
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▶▶ Tip: A performance issue with a weak video card is an inability to make selection windows. A quick fix 
is to go to Preferences>OpenGL and uncheck Use Fast Feedback. Know this will also slow the 
program down when working on large models.

Single, Double, and Triple Clicks. Click the Select tool once on a face to select it. Double-click 
to select a face and all its bordering edges. Triple-click an edge or a face to select all attached 
geometry (Figure 3‑31).

Figure 3-30:  A selection window and the highlighted cube.

Figure 3-31:  Single-click to select a face. Double-click a face to select it and all its edges. Triple-click an 
edge or face to select everything attached to it.
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Shift and Control Keys. Hold the Shift key down to bring up a plus/minus sign. This indi‑
cates you can add or remove individual pieces from the selection. Hold the Ctrl key down to 
bring up a plus sign, indicating you can add individual pieces to the selection.

The Move Tool
Move (Figure 3‑32) relocates selected 
geometry. Click on its icon, click on the cube, 
and move it around. When you move parallel 
to the axes, lines that color-coordinate with 
those axes appear. They’re inference lines, 
telling you that you are indeed parallel to the 
axis. Figure 3‑33 shows the cube moving along 
the red axis.

You can edit a line’s length with the Move tool 
if the line doesn’t bound a face. Hover Move over 
one of the line’s endpoints and then click and 
drag the endpoint to change the line’s length. 
The Move tool also copies. Press and release 
the Ctrl key. A plus sign appears, indicating 
you can make a single copy of what is selected 
(Figure 3‑34). Press and release the Ctrl key 
twice to “stamp,” or make multiple copies. Press 
and release the Ctrl key to return to Move mode. 
Alternatively, you can select geometry, click 
File>Copy and then File>Paste. Then click the copy that appears into place.

Figure 3-32:  The Move tool.

Figure 3-33:  A red inference line 
appears when the cube moves parallel to 
the red axis.

Figure 3-34:  The Move tool moves and copies.



40 SketchUp for Interior Design

Resize a Circle with the Move Tool
If a circle’s perimeter is highlighted, click the Move tool anywhere onto the circle to relocate it. 
If a circle’s perimeter isn’t highlighted, click the Move tool anywhere onto the circle to resize it 
by dragging.

Customize the Workspace
What if you don’t like where the toolbars are? Or you want a custom toolbar with the icons you 
use most? Personalize the workspace by customizing the toolbars and changing their locations.

Customize Toolbars on the PC
On the PC, undock and move toolbars by grasping 
their handles, those dotted lines at the left end or 
top. Remove a toolbar from the modeling window 
by unchecking it in the View>Toolbars window. 
Incidentally, you can right-click on a blank spot up 
on the top menu bar area to access the toolbar list 
and click them on and off (Figure 3‑35). Toolbars 
can also be moved off the workspace and onto the 
desktop to free up more modeling room

To make a custom toolbar go to 
View>Toolbars. Click New, and a pop-up menu 
box will appear. Name it and hit OK (Figure 3‑36). 
Drag and drop tools from other toolbars into the 
new toolbar. The toolbars window must remain 
open while doing this. Note that the new toolbar is 
listed with all the others (Figure 3‑37). While that 
window is open you can also move the position of 
individual tools on the Getting Started and other 
menus by sliding the icons around with the cursor.

When you drag a tool from one toolbar into 
another, the tool disappears from the one it was 
dragged from. To return it, you’ll have to drag it 
back; open the toolbars window to do that. It’s 
possible to lose or inadvertently delete a tool. With 
the toolbar window still open, right-click on a toolbar to see its context menu and click Reset 
All to restore it to defaults (Figure 3‑38). You can also restore an individual toolbar by clicking 
it in the Toolbars window and then clicking the Reset button. Reset all toolbars at once with 
the Reset All button. Your custom toolbar stocked with its tools will remain. Delete a custom 
toolbar by highlighting it and clicking the Delete button. Once you close SketchUp with the 
toolbars in their new docked positions and shapes, it will remember them each time it opens.

Figure 3-35:  Right-click at the top to 
quickly access toolbars.
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Figure 3-36:  Make a custom toolbar at View>Toolbars>New.

Figure 3-37:  Drag tools from other toolbars into the 
newly created one.

Figure 3-38:  Right-click on a toolbar for 
a context menu.
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A useful toolbar to activate is the Standard toolbar, which contains operating system com‑
mands such as Save, Copy, Undo, and Redo (Figure 3‑39). We’ll be activating other toolbars as 
needed throughout the book.

Customize the Getting Started Toolbar on the Mac
Customization on the Mac consists of adding, deleting, and relocating tools to the Getting 
Started toolbar. Right-click on a blank space on the Getting Started menu and choose Customize 
Toolbar (Figure 3-40). The tools window we saw earlier appears; drag what you want from it 
into the Getting Started bar. Delete icons from Getting Started by dragging them back into the 
tools window. Drag tools left and right on the Getting Started bar to reposition them (the tools 
dialog box must be open while doing this) and click Done to set.

To restore Getting Started to its original state, drag all its tools into the tools window and 
then drag the default set toolbar at the bottom of the tools window up to the top of the screen. 
SketchUp will remember any other modeling window changes made, such as the screen size 
and the location of other toolbars.

Make a Custom Template
A template is a file of default settings. You may want to customize one after you start 
“sketchupping” in earnest. Click on File>New to open a new SketchUp file. Here are features to 
consider for a custom template:

▶▶ Custom toolbars and specific locations for them on the workplace.
▶▶ Units, Dimensions, and Text. Go to Window>Model Info. Adjust settings such as those 

shown in Figure 3‑41.

Figure 3-39:  The Standard toolbar.

Figure 3.40:  Click on Customize Toolbar to create one with your preferences.
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▶▶ Styles, Components, Materials. Go to Window>Style and adjust whatever settings 
there you want, such as workplace color and model style (Figure 3‑42). Click open the 
components and materials windows to add anything there. You might want to add a dif‑
ferent scale figure component or delete the one that’s there.

▶▶ Perspective. Go to the Camera menu and change the default to 2-point perspective 
or paraline.

Figure 3-41:  Dimensions (PC) and text settings (Mac).

Figure 3-42:  The Styles, Components, and Materials windows.
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When you’ve finished choosing all the settings, save and name the file at File>Save As 
Template (Figure 3‑43). Then click on File >New from Template to see the custom thumb‑
nail appear with the built-in ones (Figure 3‑44). To delete the custom template, go to 
Window>Preferences>Files on the PC and SketchUp>Preferences>Files on the Mac. Click 
on the folder next to Templates. A browser window will open in which you can delete the tem‑
plate (Figure 3‑45).

Figure 3-43:  Save and name the custom template file.

My templates

Figure 3-44:  Find the custom template under My Templates.
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The Help Function
Stuck? Click on Help>Help Center (Figure 3‑46). 
This will take you to a page with tutorials, and 
if you scroll to the bottom, there’s a link to the 
official SketchUp community forums at https://

forums.sketchup.com/. The community forums 
at https://sketchucation.com/ are another nice 
resource. However, just typing your question into 
Google may be fastest, as it has probably been 
asked and answered already on one of the many 
places where SketchUp is discussed.

Now that you can maneuver around the work‑
space, it’s time to model something. Join me in 
Chapter 4 and we’ll make some furniture.

Summary
Personalize the workspace with modified toolbars and custom templates. Impute numbers and 
watch for inference prompts to model accurately. The Select tool highlights geometry, which 
enables editing. The Pan, Zoom, and Orbit tools maneuver around the modeling window; 
Rectangle makes faces; Push/Pull adds volume; Move relocates and copies; and Esc gets you out. 
Find tools quickly with the Search box. Generate 2D views with the Views toolbar and take 
questions directly to Google for the quickest answers.

Figure 3-45:  Delete a custom template at Preferences/Files.

Figure 3-46:  Accessing online help.

https://forums.sketchup.com/
https://forums.sketchup.com/
https://sketchucation.com/
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Further Resources
SketchUp channel on YouTube: http://www.youtube.com/user/SketchUpVideo

SketchUp Blog: https://blog.sketchup.com/

Lydia’s YouTube channel. Lots of SketchUp tutorials: https://www.youtube.com/user/

ProfDrafting

Exercises
This exercise will get you comfortable with the SketchUp interface. Download the Eames Chair 
file from the Wiley site.

▶▶ Use Orbit to move around it and Pan to move it around the modeling window.
▶▶ Zoom in and out of it.
▶▶ Change its view in the Camera menu from perspective to paraline, and then activate 

the Views toolbar.
▶▶ Click on the Views toolbar’s icons to see the chair’s different orthographic views.
▶▶ Click on the iso icon to return it to a 3D view, then click Camera>Perspective to return 

to a perspective view.
▶▶ Click the Select tool on the chair and notice the blue bounding box that appears. That 

will be discussed in Chapter 4.
▶▶ Open a new SketchUp file. Customize the toolbars and then save it as a template file. 

Close it, and then find and re-open.

http://www.youtube.com/user/SketchUpVideo 
https://blog.sketchup.com/
https://www.youtube.com/user/ProfDrafting
https://www.youtube.com/user/ProfDrafting
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In Chapter 3 we maneuvered around the modeling workspace. 
Here we’ll use SketchUp’s built-in tools to create a table, a 

bookcase, and a clock.

Faces and Edges
Open the Cube file from Chapter 3. The cube, like all surface 
models, consists of edges (lines) and faces (planes). Collectively 
those edges and faces are called geometry.

Edges are lines. They’re always straight and have no thick-
ness. You can apply styles that make them appear thick, but 
that’s just a display trick. The geometry itself isn’t thicker. Faces 
are coplanar surfaces, meaning flat like a piece of paper. They’re 
bounded by at least three edges and lack thickness. The front, 
called the normal, is white; the back is blue.

You can’t have a face without edges, as the Eraser tool will 
now demonstrate.

The Eraser Tool and Erasing
The Eraser (Figure 4‑1) deletes edges. Click it onto an edge to 
delete it. Continuously erase multiple edges by holding down 
the left mouse button and dragging. But the fastest way to erase 
multiple items at once is to select them and hit the Delete key.

Highlight a face with the Select tool, right-click and choose 
Erase from the context menu. Figure 4‑2 shows an edge and 
face being erased. When right-clicking, ensure that a tool is 
active, not Orbit, Pan, or Zoom, because those have different con-
text menus.

Modeling Furniture
Objective: This chapter uses 
SketchUp’s native modeling and 
editing tools to create three 
furniture and accessory models.

Tools: rectangle, pencil, freehand, 
eraser, tape measure, scale, offset, 
arc, rotate, circle

Concepts and Functions: edge, 
face, normal, geometry, rubber 
banding, fill, stickiness, group, 
nested group, bounding box, com-
ponent, component/local axis, 
definition, instance, redo, grips, 
guidelines, guide points, shadows, 
hide, editing box, Materials tray, 
flip along axis, line, setting axis 
colors, cursor cross hairs, entity 
info box, escape key, taper a leg, 
linear and radial array

CHAPTER  

4

Figure 4-1:  The Eraser tool.
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At Edit>Undo, click to restore the cube. Note there’s a redo option also in case you undo too 
much. You can also just drag a crossing window around the cube, hit Delete, and redraw it.

The Pencil and Freehand Tools
The Pencil, also called Line, draws 
straight lines (a model’s edges). 
After clicking two endpoints, 
hit ESC to finish a line. Freehand 
(Figure 4‑3) draws irregular lines 
in any direction and can draw on 
adjacent faces in all three planes 
(Figure 4‑4). Freehand lines are multiple straight segments that behave as a single line.

Activate the Pencil and draw a line on the top of the cube from midpoint-to-midpoint 
(Figure 4‑5). Find those midpoints by hovering over them until the cyan midpoint inference 
appears. Click, draw to the opposite side, and click on the midpoint inference again. Always 
draw parallel to the global axes unless the item you’re modeling is skewed to the axes for a 
design reason. When drawing parallel to an axis, holding the Shift key down locks the Pencil 
along that axis.

Figure 4-2:  Erasing edges and faces.

Figure 4-3:  The Pencil and Freehand tools.
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The Pencil “rubber bands,” meaning the endpoint of one line is the start point of another. 
Clicking the Esc key exits the Pencil, as it does all other tools. If rubber banding annoys you, go 
to Preferences>Drawing and unclick Continue line drawing (Figure 4‑6) to turn it off.

Figure 4-4:  Freehand lines.

Figure 4-5:  Hover over the midpoint 
until an inference appears.

Figure 4-6:  Adjust Pencil settings in Preferences.
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Note that in Figure 4‑5 the line between the two midpoints is green. That’s the inference 
engine telling you the line is parallel to the green axis. Once you click on the second midpoint, 
the line turns black. While you are drawing, a line not parallel to any axis will appear black.

▶▶ Tip: Modifiers are keys that, when pressed and released, make tools do different things. When a tool is 
activated, you can see what modifiers are available in the status bar at the bottom of the screen. Confirm 
the current modified state of the tool by examining the cursor (there will typically be a plus or arrow sign 
near it) or the tool’s on-screen modeling behavior. To exit a modified tool state either hit the modifier key 
again or change tools.

Make a Roof Ridge with the Move tool
Activate the Move tool 
(Figure 4‑7) and click it anywhere 
on the line you just drew. Move 
is auto-selecting, meaning it 
highlights geometry just by 
touching it. Now move the 
mouse straight up. When a blue 
inference line appears, you’re moving parallel to 
the blue axis. Hold the Shift key down while using 
Move to lock the movement along an axis. Click 
the line at a random height to make a roof ridge 
(Figure 4‑8) on this little house.

Stickiness
When you moved that roof line, it took the planes 
on both sides with it. That’s called stickiness, the 
fusion of objects that touch. Stickiness lets you do 
great things like create a roof peak by moving a line up. It can also be frustrating if you don’t 
know how to work with it, because it will deform objects you didn’t mean to deform. As an 
example, activate the Rotated Rectangle tool. Click it on the front and back corners of the house 
as shown in Figure 4‑9—note the green endpoint inferences and tooltips—and then move it 
any distance to the right to make a rectangle. Note that the rectangle is filled in. That means 
a face was created. Next, push/pull the rectangle up until the blue midpoint inference point 
appears. Click on that point. Then click on the Select key.

Sometimes the normals (front faces) orient inwards. Correct them to orient outwards so 
that SketchUp knows which is the inside and outside of the cube. That’s important for tasks 
such as 3D printing, sending the model to another program for rendering and using the 

Figure 4-7:  The Move tool.

Figure 4-8:  Drag the line up with the 
Move tool to create a roof ridge.
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Solid tools and calculating volume on models made 
with the Solid tools. Select, right-click, and choose 
Reverse Faces.

Drag a selection window around both blocks 
(Figure 4‑10) to highlight them. Now hold the Shift 
key down. A plus and minus sign appears, meaning 
you can add or subtract individual pieces from the 
selection (Figure 4‑11). Double-click the Select tool 
onto all planes of the second box. This will dese-
lect them and their edges, leaving just the house 
highlighted.

Now click Move onto the house and do just that, 
move it around. See what happens? The house sticks to 
the block, causing the block to deform (Figure 4‑12). 
Not good! Click Edit>Undo to restore the block and 
house to as they were before moving the house.

1. 2.

3.

Figure 4-9:  Use the Rotated Rectangle to make a rectangle adjacent to the house and push/pull it up.

Figure 4-10:  Drag a selection 
window around the blocks, press 
and hold Shift, and deselect the 
second box.
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What Is a Group?
Here’s how to manage SketchUp’s stickiness. Make a group, which is a collection of loose 
geometry inside an invisible shell. Any geometry can go in a group: edges, faces, text, 
dimensions, cutting planes, as well as photos and textures. Groups can even contain other 
groups, which collectively are called a nested group.

A group is isolated from the rest of the model’s geometry, hence it doesn’t stick to 
anything. Along with solving the stickiness issue, groups let you manipulate—move, rotate, 
scale, paint, etc.— all the pieces inside them together. Copies of groups behave independent 
of each other.

Make a Group
Undo the model until just the house remains. Then draw a selection window around 
it, right-click on it, and choose Make Group (Figure 4‑13). A blue bounding box appears. 

Figure 4-11:  The plus and minus sign that lets you add 
or subtract individual pieces from the selection.

Figure 4-12:  Moving the house causes 
the block fused to it to deform.
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This is the invisible shell that encloses the 
loose geometry and signifies that it is indeed 
now a group.

Redraw the block next to the house, from 
corner to corner like you did the first time. Then 
click Move onto the house again and move it 
around. It easily moves without taking the block 
along (Figure 4‑14).

The bounding box should be the same size as 
the geometry inside it. If it’s bigger, you inad-
vertently included something else. Right-click 
and choose Explode from the Context menu 
to return the group to its individual edges 
and faces. Then carefully select and group the 
house again.

Edit a Group
Editing must be done inside a group’s bounding box (also called the editing box). Double-click 
on the bounding box to access the loose geometry. Everything outside the bounding box 
will gray out. Draw a line on the house. Then click on the workspace to close the editing box. 
Move the house. You’ll see that the line moves with it.

Figure 4-13:  Select the house, right-click and choose Make Group. A blue bounding box appears around it.

Figure 4-14:  Groups don’t stick 
to anything.
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Before we continue, click open the bounding 
box again and then click on both sides of the 
line you just drew. The faces highlight sepa-
rately (Figure 4‑15). This is because lines break 
up faces. So, erase any unnecessary geometry 
as you work. Now erase this line, click the Select 
tool, and click on the workspace to close the 
bounding box.

If you draw a line on a group outside its 
bounding box, that line won’t be part of the 
group and will get left behind when you move 
the group. It’s easy to think you’re adding lines 
to a group when you’re really drawing outside 
the group, since loose geometry and groups can 
occupy the same space.

Causes of a Non-Filling Face
Before we start our project, let’s discuss a common modeling problem: tracing a perimeter that 
won’t fill. No fill means no face. If you’re not sure if a face has formed, click the Select tool on it. 
A face will become covered with blue highlighting dots. No dots mean no face.

The following may cause a non-filling face:

The model is very large or very small. SketchUp doesn’t deal well with either. Other problems 
may also arise with extreme sizes. If this describes your model, make it smaller or larger 
and see if that helps. You can always scale it back to size when you’re finished. We’ll discuss 
how to do that later in this chapter.

There are gaps between lines. See if there’s an unconnected line by clicking Window> 
Styles>Edit and checking the Profiles box to turn profiles on. You may also need to 
increase the profiles number. This makes any line not connected to others on both sides 
appear thinner than lines that are connected to others on both sides.

There is overlapping geometry. Make the model transparent at View>Face Style>Xray and 
then zoom in closely to look for small, overlapping pieces.

The face is not coplanar. This is because:

1.	 The endpoints aren’t aligned. They may be misaligned just enough to form a subdi-
vided plane, one where a face forms if a diagonal line is drawn across it. See if SketchUp 
supplied a hidden diagonal line by clicking View>Hidden Geometry. Alternatively, 
click the Text tool on each point, hold the mouse down and drag. This creates a leader 
line and text field in which the point’s coordinates appear (Figure 4‑16). All points 

Figure 4-15:  Edit a group inside its 
bounding box. Draw a line to see how it 
breaks up a face.



55Chapter 4: Modeling Furniture

must have the same last coordinate (the 
z/blue axis) to be coplanar.

Or

2.	 One line isn’t parallel to the rest of 
the lines. Assuming you’re modeling 
parallel to the global axes (the best way 
to model), set all lines so they match the 
color of their parallel axes (discussed 
shortly). Any line not parallel with the 
axes will be black.

Best Practices for Modeling
Start your model on or near the origin. Some 
tools simply operate better there, plus 
SketchUp can get glitchy when the model is 
far from the origin.

Model in the upper-right quadrant. Number coordinates are positive there, making imputed 
numbers and calculations easier.

Align the front of your model (the longest side) with the red axis. This makes it work well with 
the Views toolbar.

Model all lines parallel to the axes. This facilitates accuracy, coplanar faces, and works best 
with the Views toolbar. Modeling parallel to the axes is so important that we’re going to 
color-coordinate the lines of our first project with the axes to help develop your feel for 
when you’re modeling along the axes and when you’re not.

Color-coordinate Axes and Model Lines by Changing  
the Edge Style Setting
Styles are display settings that change the model’s appearance. Line color, thickness, and 
endpoint size are examples of those settings.

Figure 4‑17 shows how to change line color to coordinate with their parallel axes. Click on 
the Styles panel (PC) or Window>Styles (Mac) to open the Styles dialog box. Click the Edit tab 
to bring up the edit panel. Then click the first icon, Edge Settings. At the bottom of the panel is 
a Color field. Scroll to By axis. This will color-coordinate the edges with the axes they’re parallel 
to and take effect immediately. Note that the roof’s sloped lines remain black. This is because 
they’re not parallel to any axis.

Another aid in modeling accurately is activating the cursor’s crosshairs. You can color-
match them to the axes, too, for instant visual feedback. Go to Preferences>Drawing and 
check Display crosshairs (Figure 4‑18).

Figure 4-16:  Click the Text tool on the 
plane’s corners to reveal its coordinates. 
All corners must have the same last 
coordinate to be coplanar.
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Model a Table
So! It’s time to implement these tools 
and techniques. Let’s model the table in 
Figure 4‑19. Go to File>Save and choose 
Save As. Type Table in the pop-up screen. 
This will save and close the Practice file and 
make a new file active called Table. It will 
have the same settings as Practice, including 
the color-by-axis setting. Drag a selection 
window around the house and block, right-
click and choose Erase to delete them.

Edge
Settings

Edit

By axis

Figure 4-17:  Click Windows>Styles to open the Styles dialog box; then the Edit tab; then the Edge Settings 
icon; then scroll to By Axis in the Color field to color-coordinate lines with the axes they’re parallel to.

Figure 4-18:  Color-coordinate the cursor’s crosshairs with the axes.

Figure 4-19:  Table.
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Model the Tabletop
Model the tabletop (Figure 4‑20). Activate the Rectangle tool, click it on-screen, and type 6′,3′. 
The first number goes along the red axis, the second along the green. Add the foot symbol since 
the default is inches. Remember that you don’t have to type inside the Measurements box. 
Next, push/pull the rectangle up a little bit and let go. Immediately type 2. The top will adjust to 
a 2″ thickness.

Make the tabletop a group. Drag a selection window around the tabletop, right-click and 
choose Make Group (Figure 4‑21). Now we need some guidelines for leg placement.

Figure 4-20:  Make a rectangle 6’ × 3’ and push/pull it up 2”.

Figure 4-21:  Select the tabletop, right-click and choose Make Group.
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Guidelines and Guide Points
Guidelines are dashed, infinite-length construction lines. Guide points are marks at specific 
locations. Neither are part of the 
model; they’re strictly for construction 
purposes. Both can be made anywhere 
on the screen, hidden, erased, moved, 
and rotated. Use the Tape Measure 
(Figure 4‑22) to make them.

The Tape Measure’s Two Modes
The Tape Measure (Figure 4‑22) has two operating modes:

Mode 1: This measures lines and creates guidelines 
and guide points. By default, the Tape Measure is 
in guideline mode. The - - + signs next to its icon 
(Figure 4‑23) tell you that it’s in guideline mode. 
Measure a line by clicking the Tape Measure on the 
endpoints. Create guidelines by clicking the Tape 
Measure onto a line on the model and dragging it to 
the desired guideline location. Create guide points by 
clicking the Tape Measure on an endpoint or midpoint 
and then clicking on the desired guide point location. 
Click the Tape Measure onto opposite corners of a rectangle to create diagonal guidelines. 
Where the guidelines intersect is the center of that rectangle.

Too many guidelines and points can interfere with inference engine accuracy, so erase when 
no longer needed. They can be erased individually or all at once at Edit>Delete Guides. If you 
think you might use them again, select them, right-click, and choose Hide.

Mode 2: This scales a model bigger or smaller. Click the Tape Measure on two endpoints, 
type the desired size, and hit Enter. The whole model will resize, not just the item you 
clicked on. To only size one part of the model, group it, open its editing box, and rescale 
inside the editing box. The Tape Measure can also scale a model based on one known 
dimension, which we’ll do in Chapter 5.

Click the Tape Measure on two of the tabletop’s endpoints. To confirm your dimensions, 
you should see 6′ or 3′ appear in the Measurements box. The measuring tape functions like an 
inference line, changing colors to match parallel axes. The Measurements box dynamically dis-
plays the length of the measuring tape as the mouse moves.

Place Guidelines for the Table Legs
Orbit under the table, click the Tape Measure on an edge, move the Tape Measure in the direction 
the guideline is needed, let go and immediately type 2. A guideline 2″ from the edge appears 
(Figure 4‑24). Place guidelines on the other three edges. Note that you can type another number 
immediately after placing a guideline and the guideline will adjust to that number.

Figure 4-22:  The Tape Measure.

Figure 4-23:  The - - + signs mean 
the Tape Measure is in measure and 
guideline mode.
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Model the Table Leg
Let’s draw one leg. Outside the tabletop’s group shell, click the 
Rectangle tool on the intersection shown in Figure 4‑25, and 
then click a second point. Immediately type 4,4. The rectangle 
will adjust to a 4″ × 4″ square. Remember that you must type 
those dimensions immediately after clicking the second 
point or the dimensions won’t take. To change the rectangle’s 
size later, the Scale tool, discussed later in this chapter, is 
needed. You might notice some flashing in the square; that’s 
just SketchUp telling you that two faces are adjacent. Once 
you push/pull the square, the flashing will disappear. But 
before going further, let’s turn this square into a component.

What Is a Component?
Like a group, a component is a collection of loose geometry that moves together and doesn’t 
stick to anything. Unlike a group, a change to the definition (original) component applies to 
all instances (copies) of it, which makes components a powerful modeling tool. Components 
also take up less file space than groups. When multiple copies are needed, make those copies 
components.

Figure 4-24:  Click the Tape Measure onto a line, move it inward, let go, and type 2 to create a guideline 
2” from the edge.

Figure 4-25:  Draw a 4” × 4”  
square to serve as the top 
of the leg.



60 SketchUp for Interior Design

Most components are 3D, but there are also 2D ones, such as the scale figure. 2D com-
ponents take up less space than 3D ones, so are good for entourage items such as trees 
and people.

Edit a Component and Make It Unique
A component is created by right-clicking on selected geometry and choosing Make Component. 
As with groups, make changes inside its bounding box. And, as with groups, loose geometry 
and components can occupy the same space, so it’s easy to think you’re editing the component 
when you’re really drawing outside its bounding box. If you want to change just one instance, 
select it, right-click and choose Make Unique from the context menu. You can also hold the 
Shift key down to select multiple components to make unique. Subsequent edits to the other 
instances won’t affect the unique component(s). Change a unique component’s name so you 
can distinguish it from the rest when viewing a list in the Outliner panel tray.

▶▶ Double-click on the scale figure to open its editing box. You can then apply different colors and 
materials to it.

Turn the Leg Square into a Component
Let’s make the square a component, copy it once, and model it into a leg.

Select the square, right-click, and choose Make Component from the context menu. A dialog 
box appears (Figure 4‑26). In the Name screen, over-type “Component 1″ with “Table Leg.”

Figure 4-26:  Select the square, right-click and choose Make Component.
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Component Options
We’ll keep the defaults for the other options, but here’s what they mean:

▶▶ Glue to. This attaches components to faces. The alignment option determines which face 
the component “glues” or snaps to. If your component is a window, door, or piece of wall 
art, choose vertical to make it snap to walls. A vertical orientation will also make the com-
ponent automatically rotate when moved to a perpendicular wall.

▶▶ Set Component Axes. This lets you give the local axes a different orientation than the 
global axes. Every component has its own axis, which sets orientation upon insert 
and is the “handle” when moved. By default, the component axes are aligned with 
the global axes, and the origin is in the corner of the bounding box closest to the 
global origin.

▶▶ Always face camera. This applies to 2D components. Have you noticed that no matter 
which way you orbit, the scale figure always faces you? Check this box or you’ll see the 
component’s unfinished backside when orbiting.

▶▶ Replace selection with component. Make sure this box is checked. If it isn’t, what you’ve 
selected will not be made a component.

Copy the Leg Component
Select the component, activate the Move tool, and then press and release the Ctrl key (Option 
key on the Mac). Ctrl is a modifier that makes the Move tool copy. Grab a corner, slide the 
copy to the other side, and align to a guideline (Figure 4‑27). Then repeat to the table’s 
remaining corners.

Figure 4-27:  Use Move plus Ctrl key to copy the component square.



62 SketchUp for Interior Design

Add Volume to the Leg Component
Activate the Select tool and double-click the 
component to open its editing box. Click the Push/
Pull tool onto the square, extrude it down a random 
distance, and type 6. The leg will adjust to a 6″ 
length (Figure 4‑28). Note this affects the copied 
components, too.

Add the Leg’s Lower Part
Place guidelines 1″ from each of the block’s edges 
and sketch a 2″ × 2″ square inside the larger square, 
using either the Pencil or Rectangle. Then push/pull 
that square down 26″ (Figure 4‑29).

How to Edit the Leg’s Length
If you want to add more length later, open the bounding box, select the bottom of the leg, and 
stretch it out a random length with push/pull. Then type a specific number and hit Enter. 
That number will get added to the existing length. To make the leg shorter, push/pull the leg 
closer to the tabletop, type a number, and hit Enter. That number will be subtracted from the 
existing length. When finished, right-click the Select tool anywhere on the screen to close the 
editing box.

Figure 4-29:  Sketch a square and push/pull it down 26”.

Figure 4-28:  Open the component 
editing box and push/pull the 
square down 6”.
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Taper the Leg with the Scale Tool
The Scale tool (Figure 4‑30) can resize 
the whole model or just part of it. 
Figure 4‑31 shows the process for 
tapering the rectangular leg.

Select its bottom surface by clicking 
twice to active both the face and its four edges. Then activate Scale. The selected part auto-
matically highlights with green cubes called grips. Hover the mouse over a grip to activate it. 
Corner grips scale around points and distort geometry. Grab an edge grip and hold the Ctrl 
key down, which will force scaling around the center of the selection. Then move the grip 
inward to taper the leg. Click the Select tool outside the editing box to close. Note how the leg 
edges are now black, as they’re not parallel to any axis.

Figure 4-31:  Tapering the leg with the Scale tool.

Figure 4-30:  The Scale tool.
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Adjust Size with the Scale Tool
You can scale an item by eyeballing its proportions or by typing numbers for precision. For 
example, to adjust the table leg to 24″ long, triple-click on it with the selection tool to highlight 
it all. Then activate Scale. The grips will appear on all sides. Grab one grip, drag it a random 
length in any direction, then immediately type 24,24,24. The leg will adjust to that size. Type 
0.5 to scale it down to half its size.

Scale can be clicked on the whole model or just one face. You can even click on one face and a 
line to scale those two items proportionately to each other. To change the tabletop’s size, select 
it (include its thickness) and activate Scale. Grab a grip, randomly move it, and type two num-
bers separated by a comma. Remember that the first number scales along the red axis and the 
second number scales along the green.

Draw the Apron
Draw a 1″ × 4″ rectangle at the top of one of the table legs, and then push/pull that rectangle 
forward (Figure 4‑32). Click on an Edge inference at the opposite end. Triple-click the apron to 
select and make it a group. Then copy it with Move and Ctrl and move the copy to the opposite 
side of the table. Make an apron for the short side of the table (Figure 4‑33), and then group, 
copy, and move it in place.

Figure 4-33:  Make an apron for the short side of the table.

Figure 4-32:  Draw a 1” × 4” rectangle and push/pull it to the opposite leg.
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Add a Shadow
Delete all guidelines by erasing them individually with 
the Eraser tool. If the guidelines were created inside a 
group or component, they must be erased within the 
bounding box. Alternatively, erase them all at once via 
Edit>Delete Guides, which will remove ones inside groups 
and components. Return all edges to black by going to 
Window>Styles>Edit, click on the Edge Settings icon, and 
scroll to all same in the Color box. As a final touch, click 
View>Shadows to apply a shadow (Figure 4‑34). Voila! The 
finished table.

Model a Bookcase
Let’s model the bookcase in Figure 4‑35. Open a new file, 
choose the Architectural Inches template and delete the scale figure.

Make a Shell with the Offset Tool
Draw a rectangle 48″ × 24″ on or near the origin, and push/pull it 72″ high (Figure 4‑36).

To turn the block into a shell click on Offset (Figure 4‑37). It creates copies of faces and 
edges at a specified distance from the originals. It also works on two or more connected, 

Figure 4-34:  The finished table.

Figure 4-35:  Bookcase.
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coplanar lines. Offset is auto-selecting, 
so hover it over a face to select. Grab one 
of the face’s edges, move it in or out, type 
a specific distance to offset, or just click 
somewhere. Offsetting a face creates a 
new face. Click Offset onto one of the block’s edges. Drag it toward the center of the block and 
release. Immediately type 4; the edge will adjust to a 4″ offset.

Next, click Move onto the bottom edge. The edge will self-select; move it straight up 
along the blue axis, release, and type 12. Push/pull the face inward, release, and type 22. 
(Figure 4‑38).

Group the Shell
Select the entire shell with a selection window or by clicking three times anywhere on it 
(Figure 4‑39). Remember, a triple-click selects all connected faces and edges. Right-click and 
choose Make Group. Now we can place shelves inside the shell that won’t stick to it.

Make and Array a Shelf Component
Click the Rectangle onto the lower-left and upper-right corners of the shell’s bottom. Double-
click to select the rectangle face and edges, then right-click and choose Make Component 
(Figure 4‑40). Now we’ll array (make multiple copies of) that shelf.

What Is Array?
Array is a function that copies and arranges. There are linear and radial arrays. A linear array 
is equally spaced copies along a straight line. You can array between two endpoints (think 
shelves on a bookcase) or array copies with a specific distance between them (think of a row of 
trees in a park).

Figure 4-37:  The Offset tool.

Figure 4-36:  Model a 48” × 24” × 72” block.
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To array equally spaced copies between two  
endpoints, make the original, select it, copy it with 
Move plus Ctrl, and place the copy the desired  
distance from the original. The original and that 
copy define the endpoints. Next, type / and the 
number of total copies wanted; for example, /5. 
This creates four copies equally spaced between the 
original and first copy, so five copies total. You must 
type /5 immediately after placing the first copy for 
this to work; don’t perform any other action  
between making the first copy and typing /5.

To array copies with a specified distance bet-
ween them, make the original, select it, make one Figure 4-39:  Group the shell.

1. 2.

3. 4.

Figure 4-38:  Making a bookcase shell.
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copy with Move plus Ctrl, and then place the copy the distance you want from the original. 
Type x followed by the number of copies wanted; for example, x5. This creates four more copies 
(so five copies total), each separated by the same distance as that which is between the original 
and the first copy.

Linear Array the Shelf Component
Copy the shelf and move the copy to the top of the bookcase shell. Type /4. This creates 
three shelves between the shelf and the first copy. Remember not to do anything between 
placing the first copy and typing /4. If you inadvertently do an intermediate function, go to 
Edit>Undo, recopy the shelf, and type /4 again (Figure 4‑41).

Figure 4-41:  Copy/move the shelf to the top and type /4 to create three intermediate shelves.

Figure 4-40:  Draw a shelf, select, and turn it into a component.
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Erase both the original shelf and the first copy 
because we only needed them to define the end-
points (the array distance). Select them, right-
click, and choose Erase.

Change the Shelves’ 
Height and Depth
Click on one shelf to open its bounding box. Push/
pull it 2″ up and 2″ back (Figure 4‑42). Activate the 
Select tool and click it anywhere on the screen to 
close the bounding box.

Add a Curved Apron with the 
2-Point Arc Tool
Double-click on the bookcase to open the group bounding box. We want to draw a line 12″ 
above the bottom. Make a guide point by clicking the Tape Measure onto the bottom-right 
corner, moving it up, and typing 12. The guide point will appear 12″ from the bottom. Starting 
at the guide point, draw a line with the Pencil across the bookcase, parallel to the red axis. 
Make sure the On Face inference appears, confirming that you are indeed drawing on the 
bookcase’s face (Figure 4‑43). Pay attention to inference pop-ups because they tell you if you’re 
placing your geometry where you think you are. If you don’t see On Face, you may be tilting the 
arc instead of pulling it straight up.

Figure 4-42:  Edit one component shelf’s 
height and depth.

Figure 4-43:  Draw a line at the bottom of the bookcase.
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The 2-Pont Arc (Figure 4‑44) makes circular 
arcs. Which, in SketchUp, are 12 straight, 
connected lines edited as a single arc; you’ll see 
the number 12 in the Measurements box right 
after activating the tool. If you want more than 
12 segments to make the arc look smoother, 
type that number immediately after activating 
Arc, and hit Enter.

Click Arc onto the bookcase’s endpoints, lift 
the bulge, and click it onto the line (Figure 4‑45). 
For more precision, type numbers for the distance between the arc’s endpoints and the height 
of the bulge.

All the native SketchUp arcs are based on a 360° circle. While an arc’s shape can be some-
what manipulated by clicking the Scale tool on it and pulling the grips, if you want Bezier 
curves, you’ll need to download an extension for making them. Extensions are discussed 
in Chapter 9. But you can modify an arc’s radius, length, and number of segments in its 
entity info box.

What Is the Entity Info Box?
Entity Info is a dialog box that shows a piece of geometry’s attributes—its properties 
and characteristics. Select the geometry and open the Entity Info panel (Figure 4‑46). 
Different options appear based on what is selected. The Entity Info boxes for circles, 
polygons, arcs, and lines have text fields to change size, length, and add line segments 
(Figure 4‑46).

Figure 4-44:  The Arc tool.

Figure 4-45:  Draw an arc.
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Push/pull the arc through the bookcase shell 
and click on the shell’s back edge. That prevents the 
push/pulled volume from going past that back edge 
(Figure 4‑47).

Make a Component Door
We’ll place these outside the group, so don’t open 
the bounding box. Draw a rectangle on the group’s 
shell, using corner and midpoint inferences. Make the 
rectangle a component called Door. Then double-click 
to open the bounding box, and push/pull it 1″ thick 
(Figure 4‑48).

Add 4″ wide rails and stiles to the component door 
(Figure 4‑49). Click the Tape Measure on the top and 
bottom door edges and then click it 4″ away to make 
guide points. Draw vertical lines from those guide 

Figure 4-47:  Push/pull and click on the bookcase’s back edge.

Figure 4-46:  Change geometry via the Entity Info box.

Figure 4-48:  Make a component  
door.
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points down to make stiles. Do the same thing at the top and bottom to make rails. For the 
center stile, draw a line down the middle of the door, copy it 1″ on both sides by selecting it, 
click Move on it, press/release the Ctrl key, drag the center line left, let go, type 1" and hit 
Enter. Repeat on the right and then erase the middle line (Figure 4‑50).

Make a Second Component Door and Mirror It
Highlight the door component, copy, and slide it off to the side along the red axis. Select it, 
right-click, and choose Flip Along Component’s Red. Now that it’s a mirror of the first door, 
editing applied to one will appear in reverse on the other. Grab it by a corner and move it into 
place (Figure 4‑51).

Figure 4-49:  Draw the rails and stiles.

Figure 4-50:  Draw the center stile.
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Model a Crown Molding
Orbit to the top of the bookcase, open its bounding box, and select the bookcase’s edges (click 
Select on each edge while holding down the Shift key). Selecting the edges instead of the face 
means the bookcase’s height won’t be affected. Offset the edges 2″ and then push/pull it up 2″. 
(Figure 4‑52). This creates a crown molding trim.

If you want to change the top to a solid slab later, just draw a line between two corners. This 
creates a new face. Then erase the remaining lines (Figure 4‑53).

Put Glass in the Doors
The doors would look nice with some glass in them. For that we need the Materials tray (on 
the Mac, Windows>Materials). Click it open to see folders of color and texture swatches and 

1. 2.

3.

Figure 4-51:  Copy the component door and flip it along the red axis.
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scroll to Glass and Mirrors (Figure 4‑54). We’ll discuss painting 
more in Chapter 7, but here’s a taste of it.

Open one component door’s bounding box. Click on translu-
cent glass blue. The paint bucket cursor appears; click it onto the 
doors. Both will turn blue (Figure 4‑55).

A Translucent Workaround with the 
Rotate Tool and Hide
So, the glass is blue, but not translucent. Why? Because 
SketchUp is designed for single-face modeling. When we 
made the component door, we push/pulled it 1″ thick. That 
made it double-faced. Double-faces present problems that 
require workarounds. A workaround for making the glass in 
this door appear translucent is to either hide the back face or 
paint it translucent blue. To access that back face, rotate the 
doors open.

Figure 4-52:  Offset and push/pull the edges.

Figure 4-53:  You can turn 
the crown molding into a 
solid slab by drawing a line 
between two corners.



75Chapter 4: Modeling Furniture

The Rotate tool (Figure 4‑56) 
spins geometry around an axis. It 
aligns itself with whatever plane 
it’s parallel to. For instance, if the 
cursor is above the model, Rotate 
aligns with the blue axis; if the cursor is in front of the model, Rotate aligns with the green 
axis; if the cursor is on the side of the model, Rotate aligns with the red axis (Figure 4‑57). The 
cursor itself color-coordinates with the axis it is spinning an object around. A black rotator 
means the object isn’t aligned with any axis. Press and release the arrow keys on the keyboard 
to lock Rotate into different axes. Press and release to unlock. Hold the Shift key down to lock 
an axis in place. All orientations are most likely to appear if you model near the origin. You can 
also click on the Rotate tool and drag it to change its orientation.

Open one door’s editing box and select the whole door by triple-clicking. Move Rotate on 
top of the bookcase. Once the blue appears, hold the Shift key down to lock it in place, and 
click the rotator onto the door’s top hinge. Then click it at the opposite endpoint. Swing the 
door open with the mouse. Both doors will open (Figure 4‑58). Note that you must select the 
entire door. If the door warps when rotated (Figure 4‑59), you didn’t select it all.

Figure 4-55:  Paint the doors translucent  
blue.Figure 4-54:  The Glass and Mirrors 

folder in the Materials tray.

Figure 4-56:  The Rotate tool.
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Figure 4-57:  The Rotate tool aligns itself with the plane it’s parallel to. You can also click and drag it.

Click here

1. 2.

3.

Click here

Figure 4-58:  Rotating the doors open.
Figure 4-59:  The door will warp when 
rotated if not fully selected.

Select the back face of the door and click on Edit>Hide. It disappears, making the front 
face’s translucency settings apparent (Figure 4‑60).
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You can unhide the face anytime at Edit>Unhide (Figure 4‑61). Note that one of the Unhide 
options is Selected. To view and select hidden items, click on View>Hidden Geometry. Hidden 
geometry appears with a light grid (Figure 4‑62).

Figure 4-60:  Hide the double-faced door’s back face to show translucency.

Figure 4-61:  Unhide hidden geometry.
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Figure 4-62:  Hidden geometry appears with a light grid.

Click here Click here

1. 2.

3.

Figure 4-63:  Rotate the doors shut.

Finally, click the Rotate tool onto the hinge, then onto the opposite corner, and move the 
mouse to swing the doors shut (Figure 4‑63).
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Add Knobs with the Circle Tool
The Circle tool (Figure 4‑64) is 
nested within the Rectangle tool. 
When activated, the number 
24 appears in the Measurements 
box because the circle is really a 
polygon with 24 segments. You can change that default number by overtyping the 24 with a 
new number. More sides will make the circle smoother, less sides will take up less file space. 
Like Rotate, the Circle tool aligns with whatever side it is parallel to. Click keyboard arrows to 
change its orientation and press and hold Shift to lock it in place.

With the door component editing box open, click Circle onto one of the lock stiles. Click 
again to define the radius. To change the radius after clicking, immediately type a new 
number. The circle’s radius and segments can be changed later by right-clicking on it, choos-
ing Entity Info, and typing a new radius (Figure 4‑65). Then push/pull out. Our bookcase 
knobs have a 1″ radius and are 1″ long (Figure 4‑66). Click on View>Shadows and we’re done 
(Figure 4‑67).

Figure 4-64:  The Circle tool.

Figure 4-65:  Change a circle’s properties through its Entity Info box.
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Model a Clock with Radial Array
Let’s model the clock shown in Figure 4‑68. In the process we’ll do a radial array, which is 
multiple copies arranged in a circle. Access the Views toolbar (Figure 4‑69), at View>Toolbars 
(PC) and View>Tool Palettes (Mac) and then click the front view icon.

Figure 4-66:  Making knobs with the 
Circle tool.

Figure 4-68:  Clock.

Figure 4-67:  The finished bookcase.
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Figure 4-70:  Draw a circle and place 
guidelines at its center.

Figure 4-69:  The front view icon on the 
Views toolbar.

Draw a 3′ diameter circle with the Circle tool. Group it. 
Hover the Tape Measure over the circle’s center until the Tape 
Measure snaps to it and draw horizontal and vertical guide-
lines through that center (Figure 4‑70).

Draw a rectangular hour mark at the 12:00 position with 
the Pencil. Use the inference engine to match the rectangle’s 
lengths by hovering the cursor over the first length until a 
pop-up circle guides you for the other length (Figure 4‑71). 
Then select the rectangle and make it a component 
(Figure 4‑72).

Array 12 hour marks around the clock face  
(Figures 4‑73 and 4‑74). Here’s how:

a.	 Select the hour mark component and click Rotate onto 
the circle’s center.

b.	 Click Rotate on the top of the hour mark.

c.	 Press and release the Ctrl key. A + sign appears over the Rotate cursor, indicating mul-
tiple copies will be made. Move the cursor a bit to the right (but don’t click).

d.	 Type 360 and Enter.

e.	 Type /12 and Enter.

Figure 4-71:  Make an 
hour mark.
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Figure 4-72:  Turn the hour mark into a component.

1. 2.

3.

Figure 4-73:  Set up the array with the Rotate tool.
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Add thickness to the clock face by opening its 
bounding box and push/pulling it straight back Offset 
the clock face and give the offset thickness with push/
pull (Figure 4‑75).

Draw Clock Hands 
with Inference Matching
Use the Rectangle tool to draw clock hands off the clock 
face. Group, and then rotate them (Figure 4‑76).

Open the editing box and push/pull one hand for-
ward. Click Push/Pull on the face of the second hand 
and hover it over the face of the first. The second item 
will snap to that thickness (Figure 4‑77). Release the 
cursor and close the editing box.

If needed, adjust the size and proportion of the hour 
marks and hands with the Scale tool (Figure 4‑78). 
Scale works inside or out of the bounding box. However, since the hour marks are components, 
a change made inside one bounding box will affect them all.

Done! (Figure 4‑79)
This is the extent of furniture and accessories modeling we’ll do. Why? Because there are 

sources from which you can download just about any ready-made, editable component you 

Figure 4-75:  Offset and push/pull 
the clock face.

4. 5.

Figure 4-74:  Type 360 and /12.
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Figure 4-77:  Inference-match the clock hand’s 
thickness.

Figure 4-76:  Draw clock hands.

Figure 4-78:  Scale the hands and hour marks.

Figure 4-79:  The finished clock.
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need (Figure 4‑80). Editing a component is generally more time-efficient than making one 
from scratch. Head to Chapter 5 now, where we’ll model a floor plan and download compo-
nents from the Trimble 3D Warehouse.

Summary
In this chapter we used SketchUp’s native drawing and editing tools to model a table, 
bookcase, and clock. In the process we learned what stickiness is and how to manage it with 
groups, examined non-filling faces, made and edited components, mirrored geometry, applied 
translucent paint, scaled and arrayed, changed a style setting, and inference-matched. We also 
discussed modeling best practices.

Exercises
1.	 Make a 5′ × 5′ × 5′ cube

▶▶ Group it.

▶▶ Apply the Rotate and Scale tools to it.

▶▶ Flip it along an axis

Figure 4-80:  Accessories were downloaded from the Trimble 3D Warehouse and scaled to size. Note 
the translucent paint on the door. Courtesy Matthew Kerr, mkerrdesign.com.

http://mkerrdesign.com
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▶▶ Change the color of its axes.

▶▶ Hide and unhide its surfaces.

▶▶ Click shadows on and off it.

▶▶ Turn it into a component.

2.	 Model a piece of furniture from a photo.

3.	 Model a clock like the one in this chapter.
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In this chapter we’ll model spaces from plans. We’ll do this 
three ways: 1. By tracing over a raster file; 2. By drawing from 

a paper sketch; and 3. By importing an AutoCAD file. So, open a 
new SketchUp file and we’ll start with importing a raster file.

Prepare a Raster File for Import
Figure 5‑1 shows the files that can be imported on a Mac. The PC 
imports the same ones except for PDF. SketchUp will resample 
(downsize) files larger than 1024 × 1024 pixels. However, that 
size is still much larger than what is usually needed. Large files 
slow down the software, so crop and resample them yourself 
before importing.

To further keep file size down, use compressed file types. 
JPGs and PNGs are compressed, plus they’re smaller than other 
file types, hence the best choice. PNGs preserve transparency 
layers, important when importing a file adjusted with digital 
imaging software. Convert GIF files (which are not importable) 
and BMP files (which are not compressed) on the Mac by right-
clicking on the image and choosing Quick Actions>Convert 
Image (Figure 5-2).

Once imported, a raster file is permanently part of the 
model. SketchUp doesn’t externally reference files, meaning it 
won’t search for them on your computer each time the model is 
opened and display a red X when it can’t find them.

Draft a Plan by Tracing a Raster Image
Import a raster image floor plan. Click on File>Import. Choose All 
Supported Types, navigate to the floor plan JPG, click the Image 
radio button and then click the Import button (Figure 5‑3).

Place the file. Click once to place the JPG’s lower-left corner, 
and then click anywhere a second time to place the upper-right 
corner (Figure 5‑4). It’s best to model on or near the origin and 

Drafting, Modeling, 
and Furnishing 
a Floor Plan

CHAPTER  

5
Objective: This chapter shows  
different ways to draft and model 
a plan, and how to import  
ready-made components.

Tools: section, text, protractor, 
views, tape measure

Concepts and Functions: import 
raster and AutoCAD files, change 
face and line styles, change line 
color, inference-match, tracing 
techniques, scale a model, 
explode, stretch a line, 3D Ware-
house, components browser, link 
a local collection, paste in place, 
purge, move geometry with coor-
dinates, clipping, flashing, make a 
sloped ceiling, measure an angle, 
geo-locate, tags, make SketchUp 
run faster, polygon count.
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Figure 5-1:  Importable files. Figure 5-2:  Converting a file on the Mac.

Figure 5-3:  Import the JPG.

Figure 5-4:  Click twice to place the JPG.
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in the upper-right quadrant. Then select and explode the JPG and make it a group (Figure 5‑5). 
A JPG imports with some group-like qualities, but is not a true group.

The Explode Function
Explode reduces a group or component to its individual geometry. Nested groups and 
components—that is, groups or components that are inside other groups or components—
may need to be exploded multiple times to edit what you’re trying to edit. However, know 
that adjacent nested geometry fuses upon explosion. Exploded geometry gets automatically 
selected, so you can quickly re-group if necessary. Exploding circles and arcs reduces them to 
individual line segments that don’t behave as a whole anymore. Fix by selecting, right-clicking, 
and choosing Weld (Figure 5‑6).

How to Resize Geometry
If you’re wondering why we didn’t address scale when importing the file, it’s because we 
can scale anything at any time. All geometry and imported files can be resized based on a 
known dimension. Say you want to make a wall 10′ long. Click the Tape Measure on the wall’s 
endpoints, and then immediately type 10'. The wall resizes, but so does everything else in the 
file. To preserve the scale of everything else, put the geometry that you want to resize inside a 
group or component and resize inside its bounding box.

Scale the Imported Floor Plan with the Tape Measure
Scale the floor plan (Figure 5‑7). We’ll adjust the plan’s size by scaling a doorway. Interior doors 
are typically 2′-8″ wide. Click the Tape Measure on one side of a door jamb and then on the 
other. A pop-up box displays the distance as 1′-5/8″. Type 2′8. A dialogue box appears asking if 
we want to resize the model. Click Yes. The whole model will resize to a proportion in keeping 
with the new doorway opening size of 2′-8″.

Figure 5-5:  Explode and group.
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It’s easier to trace in a plan view. So, add the Views toolbar to your workspace 
(View>Toolbars). It has icons that display top and side views of the model. Click the top view 
icon to see the image as a plan (Figure 5‑8).

Figure 5-6:  Exploding and welding a curve.

1. Click 2.

3.

Click

Figure 5-7:  Resize a doorway to scale the floor plan.
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Trace the plan’s perimeter (see Figures 5‑9 a–g). Outside the group’s bounding box, trace the 
walls with the Pencil. Ensure you’re drawing parallel to the axes and that the On Face in Group 
pop-up appears when you click at each corner. if you don’t see the pop-ups, your points won’t 
be coplanar. Use inference-matching to draw the line in f; when the two black dots appear, the 
bottom horizontal line is the same length as the top horizontal line. If black dots don’t appear, 
hover the cursor over the top corner and then slowly drag it down to the bottom corner. When 
finished, a face is created, as seen by the opaque fill. If the fill doesn’t appear, a face hasn’t been 
created. The corner points are probably not coplanar; erase and redo is the easiest fix.

Figure 5-8:  Display the plan as a top view.

a. b.
Figure 5-9:  a–g Trace the raster plan.
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c. d.

e.

f.

g.
Figure 5-9:  (continued)
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Make the face transparent. We can’t trace the interior walls through an opaque face, so go to 
View>Face Style and click X-ray to make the face transparent (Figure 5‑10).

Offset the perimeter walls. Use the Offset tool and type 6, which is the wall thickness 
(Figure 5‑11).

Figure 5-10:  Make the face transparent.

Figure 5-11:  Offset the perimeter walls.
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Change Line Color
Black lines over a black-and-white drawing are hard to see, so make them red. To do this on the 
PC, click on the Styles tray, and then the Edit tab. In the Color box, scroll to All Same. There’s a 
box next to it that’s filled black, which is the line’s current color. Click on it to make a picker 
wheel appear, click on red, move the slider up until the preview box is filled red, and then click 
OK (Figure 5‑12). On the Mac, click on Window>Styles and then click on the Edit tab. In the 
Color box, scroll to All Same. A color wheel will appear; click on red and then move the slider 
over to red (Figure 5‑13).

Slider

Figure 5-12:  Changing the line color on a PC.

Figure 5-13:  Changing the line color on a Mac.
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Trace Interior Walls
There are multiple approaches to tracing the interior walls, so rather than go step by step, here 
are some techniques for you to apply.

▶▶ Trace one line on each interior wall and then copy it 6″ to the left or right (Figure 5‑14).
▶▶ Obtain line lengths by inference-matching. Click the new line’s first endpoint. Hover the 

cursor over the point shown in Figure 5‑15′s top graphic, and then move the cursor up 
(bottom graphic) until it locks in place.

▶▶ Use the Move tool to stretch lines and faces longer or shorter (Figure 5‑16). Select the 
line and move its endpoint forward or backward. Stretch a face by selecting an edge, 
grabbing it somewhere along its length, and moving it forward or backward. This won’t 
work if the line and face are connected to other geometry that stretches with it.

Figure 5-14:  Draw one line, copy it, and 
move it 6” away. Figure 5-15:  Inference-match line lengths.

Figure 5-16:  Stretch a line by moving its endpoint; stretch a face by moving its edge.
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▶▶ Use the Pencil to add to lines whose endpoints can’t be moved because they’re attached 
to other geometry. This results in two lines: the original and the added (Figure 5‑17).

After you finish drawing the interior lines, return to View>Face Style and unclick X-ray. 
The face becomes opaque again, allowing you to see any missing lines or areas to clean up, such 
as crossed lines at intersections. If you inadvertently erase a line, just redraw it with the Pencil.

Edge Styles Again
Eventually your plan should look like the one shown in Figure 5‑18.

Figure 5-17:  Add line length with the Pencil.

Figure 5-18:  The completed plan.
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Note that all intersections are “clean,” meaning there are no crossed lines in them. This 
makes the walls contiguous, which is necessary to pull them up together. Also note the thick‑
ened endpoints; those are a default style. You can remove them at Window>Styles. Style 
options include changing endpoints and profiles (the appearance of line thickness). Unclick 
the Endpoints box, and the endpoints will disappear (Figure 5‑19). Experiment with different 
numbers in the checkbox to see how the endpoints are affected. Increase the number in the 
Profiles checkbox to see how the lines display thicker (Figure 5‑20). Know that technically the 
lines are still thin; the thickness is just a display trick.

Figure 5-19:  Uncheck the Endpoints box so the endpoints don’t display.

Figure 5-20:  Increase the Profiles number to make the lines look thicker.
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The enabled Profiles feature is what causes Interior lines on a plan to look thinner than the 
perimeter lines (Figure 5‑21). Thick lines indicate that those lines do not enclose a coplanar 
face. In the isometric and perspective views, a thicker appearance is the default, mimicking how 
designers outline forms with thicker line weights to visually define them. You cannot assign 
different thicknesses to different lines in SketchUp. If you don’t like the different thickness at 
all, turn them off by unchecking the Profiles box. However, leaving Profiles on helps to see which 
lines aren’t connected, which is useful when troubleshooting problems like a non-filling face.

Return the edge style to black and click the iso icon in the Views toolbar. Your plan should 
now look like Figure 5‑22.

From Plan to Model
Hover Push/Pull over a wall. Ideally, all walls will highlight. Extrude up 10′ (Figure 5‑23). Erase 
any extraneous vertical lines that appear on the walls.

Figure 5-21:  Interior lines are  
thinner than exterior ones.

Figure 5-22:  The finished plan. X-ray is turned off, the edge 
color is black, and the iso icon in the Views toolbar is checked.

Figure 5-23:  Push/pull the floor plan up.
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I say ideally because if your walls didn’t extrude this smoothly, something went wrong. Did 
a floor area extrude up with the walls? Push/pull the walls back down and trace the perimeter 
of that floor area with the Pencil. Sometimes that solves the problem. Erase some faces or walls 
and redraw them. SketchUp takes playing and practice to get things exactly as you want.

Add a Porch, Door, and Window
Put the faces in X-ray mode again (View>Face style>X-ray) and we’ll add the porch, a door, 
and window.

Draw the porch (Figure 5‑24). Use inferencing to draw the length of the porch, and then 
push/pull it up 12″.

Add the porch steps (Figure 5‑25). Trace them with the Pencil. Push/pull the second step 
level with the porch. Push/pull the first step to the midpoint of the second—an inference dot 
and screen tip will appear as the cursor approaches the midpoint. When you’re finished, if the 
faces are reversed (the white side should face out), select and right-click the stairs and choose 
Reverse Faces.

Add the door (Figure 5‑26). Click the Rectangle at the bottom of the wall (level with the step) 
for the door opening’s lower-left corner, type 2′8,7 and hit Enter to make the rectangle 2′-8″ 

1. 2.

3.

Figure 5-24:  Draw the porch and push/pull it up.
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1. 2.

3.

Figure 5-25:  Trace the steps and push/pull them up.

Figure 5-26:  Add a door opening.
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wide and 7′ tall. Remember, there is no space between the comma and the 7. You could also 
click anywhere the second time and immediately type the dimension. The opening will adjust.

Add a window (Figure 5‑27). Place the window head (top) level with the door head. Hover the 
Rectangle at the top of the door, move it to the right along the axis (watch for the dotted infer‑
ence line), and click to place the window’s upper-left corner. Click again to place the lower-
right corner or type a dimension. Alternatively, place guidelines at the window locations in the 
plan view and then click the Rectangle on those guidelines (Figure 5‑28).

Cut the door and window openings. Push/pull the faces back a bit, type 6 (the width of the wall 
in inches), and hit Enter (Figure 5‑29).

Raise the interior floor. Orbit inside the model. The doorway is above the floor. Push/pull 
the floor up and click it on the door sill (Figure 5‑30). Raise the floors in the other rooms by 
inference-matching them to that floor (Figure 5‑31).

Figure 5-27:  Use inferencing to align the door and window heads.

Figure 5-28:  Guidelines drawn in plan can be 
used to place the window opening.

Figure 5-29:  Cut openings by push/pulling the 
faces back 6”.
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Flashing Planes
Before you raised the floor, you may have noticed flashing when orbiting around the cottage 
(Figure 5‑32). This is called “z-fighting” and happens when two planes are adjacent. Flashing 
tells you that the planes are occupying the same space and SketchUp doesn’t know which to 
display. Here it was happening because the floor plane was on top of the imported JPG, which 
is a plane, too. Raising the floor hides the flashing under the new face plane.

Draft a Plan from a Paper Sketch
Designers typically have a sketch of a space’s layout and dimensions. In this project we’ll trace 
and model a dorm room from an imported JPG of the plan (Figure 5‑33).

Figure 5-30:  Raise the interior floor to the door sill.

Figure 5-31:  Inference-match the other rooms’ floors 
to the new floor height.

Figure 5-32:  When two planes are adja-
cent to each other, they flash.
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Import the sketch and size it. Click the plan icon in the Views toolbar and follow the same 
instructions as with the floor plan we imported earlier.

Place guidelines on the sketch. Use the Tape Measure to create guidelines defining a 14″ × 10″ 
rectangle. After you draw one horizontal and one vertical guideline, you can click and drag 
those guidelines to create the rest. Type distances after dragging but before clicking in place. 
Then trace over the guidelines on the sketch (Figure 5‑34).

If the default black guidelines are hard to see, change their color. Do this at Styles>Edit 
and click the fifth icon that’s directly below the Edit tab. Click on Guides, click on a color from 
the picker wheel, and move the slider up (Figure 5‑35).

Return the plan to a perspective view. Click iso on the Views toolbar and delete all guidelines 
at Edit>Delete Guides. Right-click on the imported sketch to select it and choose Hide.

Model the plan. Push/pull the face up 9′. Right-click on the face that is created and choose 
Erase (Figure 5‑36). Or just hide if you think you’ll use that face as a ceiling later. Make a 
guideline 3″ from the corner for the door. Let’s put a door in now.

Figure 5-33:  A floor plan sketch.
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1. 2. 3.

4. 5. 6.

7. 8. 9.

Figure 5-34:  Place and trace guidelines.

Figure 5-35:  Change the guidelines’ color to make them easier to see.
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The 3D Warehouse
In Chapter 4 you modeled some furniture. The ability to do that is nice but saving time 
by using other people’s models is even better. You can import doors, windows, furniture, 
flowerpots, food, whatever you want from the many online libraries that exist. The largest 
source of free SketchUp components is the 3D Warehouse, a library where millions of people 
upload and download models.

People use the Warehouse for different things, such as selling products and advertising 
their modeled or design services. Beginners and pros upload their creations; companies upload 
their products. Anyone can contribute. You can find whole buildings and cities, and rooms 
filled with furniture, fixtures, and equipment. Excluding branding and logos, all content is 
free, reusable, editable, and republishable. A link to the Warehouse’s terms of use is at the end 
of this chapter. In that spirit of sharing, this book liberally uses Warehouse models.

There are multiple ways to access the Warehouse, all requiring an internet connection. One 
way is directly at https://3dwarehouse.sketchup.com. Contents are easiest to browse there. 
However, it is more convenient to access the Warehouse through the SketchUp software. Click‑
ing on the Warehouse icon (Figure 5‑37) takes you directly to it. However, we’re going to access 
the Warehouse through the Components tray, which has category folders.

Figure 5-36:  Model the plan.

Figure 5-37:  The Warehouse icon.

https://3dwarehouse.sketchup.com
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Import a Door through the Components Tray
Import a door component (Figure 5‑38). Click open the Components tray, click the dropdown 
arrow, and then click on the Construction folder. This accesses multiple subfolders; click on 
Doors Low Poly.

This spirits us to the Warehouse, where many door types are presented (Figure 5‑39). I 
chose Door with left jamb reverse (Figure 5‑40). Click Download. You’ll be asked if you want to 
load the model directly into your SketchUp model. Click Yes.

To Download into the Model or Not?
A Warehouse component, as well as any component you make, is a full-fledged, self-contained 
model. When you download a component, you’re embedding that model into your own model. 
You’re also bringing in all that model’s imported images, tags, scenes, and styles. That can 
be dangerous! All that stuff can bloat your file, there may be corrupted elements in it, and it 
might take a long time to remove unwanted items. If you’ve spent hours developing your own 
model, don’t download a Warehouse component directly into your file; rather, click No, and a 
navigation browser will appear enabling you to download the component separately. Check it 
out, delete what you don’t want, and then import into your file. You can import the Warehouse 

Figure 5-38:  Access the Warehouse via Components>Construction>Doors Low Poly.
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Figure 5-39:  Many door types are at the Warehouse.

Figure 5-40:  Let’s download this door.
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model at File>Import. Alternatively, select the component, press Ctrl (or Command) C, then 
click on your file and press Ctrl (or Command) V. Since we haven’t spent much time on our 
practice model, download the Warehouse model directly into your open file.

Place the door. The Move tool is active and is attached to the door’s local axis. Note how the 
door attaches or “glues” itself to whatever plane it’s on. Gluing is an option when a component 
is created (Figure 5‑41), so if a component doesn’t glue as expected, inspect that option by 
clicking on the house icon to access all components in the model. Then find the component’s 
thumbnail, right-click and choose Properties (Figure 5‑42).

Click the back of the frame onto the floor and guideline (Figure 5‑43). Four crosses will 
appear when you hover the Move tool over the door. Those allow you to rotate the door. While 
you obviously don’t want to rotate a door, those crosses appear on all downloaded components 
to enable rotation right away instead of as a separate task.

Figure 5-41:  The component’s Glue option.
Figure 5-42:  If a component doesn’t attach to 
a wall, inspect its gluing option.

Figure 5-43:  Click the door’s frame onto the wall.
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Component Door in Single- versus Double-sided Walls
Note that the component door cut a hole in the 
wall. This is an option when creating a component 
(Figure 5‑44). If you delete the door, the hole 
will also delete; if you move the door, the hole 
will move with it. This is a huge benefit of using 
component doors instead of manually cutting 
holes in walls. However, this only works on single-
face walls, not double-face walls like we modeled 
in the cottage. Since designers typically draw walls 
with thicknesses, a workaround for a double-
face wall is needed. Sometimes you can draw a 
rectangle around the door or window component, 
push the face back, and that cuts a hole through 
the second face. Other times you might have to 
push the face back and then select/delete it.

Import and place the window. First, draw a guide‑
line 2′-2″ from the ceiling to mark the window 
head (Figure 5‑45). Then go to Window>Components>Construction>Windows Low Poly, 
which takes you to the Warehouse and presents windows to browse (Figure 5‑46). Choose one, 
bring it into the model, and click to place (Figure 5‑47).

Import Warehouse Furniture Through the Components 
Browser Search Field
Let’s import a desk, dresser, and bed now. In the Components browser’s search field, do separate 
searches for small dresser, dorm bed, and desk (Figure 5‑48). Thumbnails will appear in the 
browser; double-click ones that interest you and download into the model. Alternatively, 

Figure 5-44:  Select Cut opening when  
creating a door component.

Figure 5-45:  Make a guideline for the window head.
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click the Details arrow and choose View in 3D Warehouse (Figure 5‑49). You’ll be taken directly 
to a Warehouse page with the same search results, which makes browsing the individual 
components easier.

Figure 5-46:  Browse the Windows Low Poly folder.

Figure 5-47:  Click a window into place.
Figure 5-48:  Use the search field to find 
Warehouse components.
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I imported storage cabinets for under the bed and a poster (Figure 5‑50). The poster is an 
image, and flashed when put against the wall. I opened its editing box and push/pulled it out a 
bit to give it thickness and stop the flashing (5-51).

Copy and Paste Between SketchUp Files
You can copy and paste components from one SketchUp file to another. Open both files. You 
must click the second file open from the SketchUp icon to open two instances of the software. 
Merely clicking File>Open will close the active file.

Select the item to copy in the first file and press Ctrl C (copy). Click on the second file, acti‑
vate the Select key, and press Ctrl V (paste). On a Mac, press Command C and Command V. 
Alternatively, go to the File menu and click Edit>Copy in the first file and Edit>Paste in the 
second. Cutting and pasting works on geometry within a file, too.

Figure 5-49:  Click the Details arrow for a fly-out menu.

Figure 5-50:  The dorm room with imported 
furniture.

Figure 5-51:  Thickening an 
imported image.



112 SketchUp for Interior Design

Paste In Place
Simple pasting puts the content anywhere in 
the active SketchUp file. The Edit menu has a 
cool feature called Paste In Place (Figure 5‑52) 
that puts an item in the same location it was 
cut or copied from. This is great for moving 
items that are outside a group/component 
into it while preserving the location. Because 
groups/components and loose geometry can 
occupy the same spot, a common error is to 
inadvertently make edits outside a group/
component’s shell instead of opening the bounding box and editing inside it. Relocate geometry 
to the same place inside the group/component by selecting the geometry, clicking File>Cut, 
opening the group’s bounding box, and clicking File>Paste in Place.

Here are a couple more tips. Go to File>Import, set the Files of Type field to SKP and nav‑
igate to the file you want to import. This brings the whole file into the open one. You can also 
drag that file’s desktop icon into the open file. Large files will take a while to import.

See All Components Loaded in the Model with the In 
Model Icon
Once downloaded, a component remains in 
the file even if you delete it from the model. 
At Window>Components we clicked the 
dropdown arrow to see the Construction and 
other component collection folders. To only 
see components that have been loaded into the 
model, click the In Model icon; it’s the house 
(Figure 5‑53). Every component added to the 
model through any method—downloading, 
importing, making it yourself, cutting and 
pasting—shows up here. You’ll probably 
return to this window often to purge or 
retrieve components.

Purge and Delete Unused 
Components
Unused components increase the file size, so 
get rid of them. Click the Details arrow on the 
Components browser and choose Purge Unused from the fly-out menu (Figure 5‑54). Purging 
removes all unused components from the file.

Figure 5-52:  The Paste In Place function.

Figure 5-53:  Click the house icon to see all  
components in the model.
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You can also right-click on a component and choose Delete. That removes the component 
from the file and from the SketchUp software. Deleting components is a useful way to get rid 
of unneeded blocks that were part of an AutoCAD import. If you think you might reuse purged 
or deleted components for a different project, make a local collection for them.

Make a Local Collection and Link It to the 
Components Browser
A local collection is a folder on your computer in which components are kept. You can link 
this folder to the Components browser for easy access to its contents each time you open any 
SketchUp file. Here’s how.

1.	 Click the arrow in the upper-right 
corner of the Components browser to 
open the secondary (bottom) pane 
(Figure 5‑55). It looks just like the top 
pane. However, you can create your own 
collection folders in this pane and drag 
components from the top pane down 
into them.

2.	 Make a new folder on your desktop and 
call it My Components. Then click the 
Details arrow and choose Open or Create 
a local collection; on the Mac choose Cre-
ate a new collection (Figure 5‑56).

Navigate to the My Components folder that 
you just made. Select it and click the Select 
Folder button (Figure 5‑57). That collection 
is now open in the lower pane. Populate the 

Figure 5-54:  Purge unused components.

Arrow

Figure 5-55:  Click the arrow to open the 
bottom panel.
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Figure 5-56:  Click the arrow and choose Open or Create a local collection.

Figure 5-57:  Navigate to the My Components folder and click Select Folder.
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folder by dragging components into it (Figure 5‑58). 
Open the folder on the desktop to verify that the 
components are, indeed, in there now.

Right-click on the Details arrow in the lower pane 
and choose Add collection to favorites; on the Mac 
choose Save as a local collection. When you click the 
dropdown arrow, the My Components folder will 
appear, too (Figure 5‑59).

Eventually you’ll want to make local collections 
for different categories, such as rugs, tables, and 
lighting fixtures. You can even save searches as a col‑
lection. Type search terms in the components search 
field, hit Enter, and after results are returned, click 
the Details arrow and choose Add to favorites. Your 
search will appear with all the other collections. To 
remove a collection, select it, click the Details arrow 
again, and choose Remove from favorites.

▶▶ Tip: If you can’t drag components from the top to bottom 
pane or make local collection folders, your permission 
settings may be locked. Figure 5-58:  Drag components from 

the upper pane into the lower pane.

Figure 5-59:  Add your local folder to Favorites.
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Create Plan and Elevation Views
If you prefer to study the model in 
orthographic views, you can. When we 
imported the JPG plan of the cottage, we 
clicked on the Views toolbar’s plan icon for 
a plan view. However, what we’re getting is 
an aerial perspective (Figure 5‑60).

Make an orthographic top view of 
the model by clicking Camera>Parallel 
Projection (Figure 5‑61) and using it in 
tandem with the Views toolbar.

Figure 5-60:  A model in Plan appears as an 
aerial perspective.

Figure 5-61:  Camera>Parallel Projection and the Plan icon creates an orthographic view.

The other Views icons yield exterior elevation views, so a workaround is needed to obtain 
an interior elevation view. One way is to hide the wall opposite the one you want an interior 
elevation of (Figure 5‑62). To finesse the location where the elevation view is made, use the 
Section tool.
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The Section Tool
Activate the Section toolbar (Figure 5‑63) at 
View>Toolbars>Section. It creates cut-through views 
of the model. It doesn’t cut the model; it just displays 
a view of the cut. There are four icons: one draws the 
plane; one toggles the plane on and off; one toggles the 
cut on and off; and one toggles section fill on and off.

Click on the first icon and place the cursor on the wall you want to remove from the cut 
(Figure 5‑64). Name the cut in the dialog box. Move the plane to the desired location and click 
in place. You can lock its orientation in place with the arrow keys. Toggle both the cutting 
plane and the cut part on and off with the other icons. To change the cut’s location, select it 
and use Move. To change the plane’s direction, select it and use the Rotate tool (Figure 5‑65). 
To remove a section plane, select and delete it.

Make a Section Cut with Create Group from Slice
You can make multiple section cuts in a model (Figure 5‑66), but only one will be active at a 
time. A workaround for making simultaneously active planes is to group the model with a 
section plane and then create another section plane outside the group. Grouping the model 
and applying the Section tool inside the group’s bounding box is useful if you have other 
models in the file, because otherwise the section plane cuts through everything.

Actual cuts in the model can be generated from section plane views. Select a plane, right-
click on it, and choose Create group from slice. This makes a cut at the insertion location 
(Figure 5‑67). If you made the plane cut inside a group, you’ll need to open the group’s bound‑
ing box for the Create group from slice option to appear.

Figure 5-62:  Hide a wall to obtain an interior elevation.

Figure 5-63:  The Section toolbar.
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1. 2.

3.

Figure 5-64:  Creating a cut with the Section tool.

Figure 5-65:  Use Rotate to change the plane’s 
direction.

Figure 5-66:  Multiple section cuts 
in a model.
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The cut is a group that can be removed or exploded in place. Removing enables further 
development. Exploding severs the model in two, enabling separate editing of each part 
(Figure 5‑68).

Model a Building from an AutoCAD (DWG) Plan
So far, we’ve drafted floor plans from imported raster files. You can also import a DWG or 
DXF file, which becomes SketchUp geometry upon import. This is a common design workflow 
(Figure 5‑69).

You don’t need AutoCAD software installed on your computer to import a DWG file into 
SketchUp. However, a DWG file needs preparation before import for best results, and opti‑
mally this is done within AutoCAD. Simpler files need less preparation than data-rich ones 
that have lots of layers and line weights, and you probably don’t need to do everything on the 
following list, but all can make a difference. As with a Warehouse model, it’s best practice to 
import a DWG or DWX file into a new SketchUp file before bringing it into your open model to 
ensure it isn’t problematic.

1. 2.

3.

Figure 5-67:  Creating a cut from a section view.
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Prepare a DWG File for Import
▶▶ Import files smaller than 15MB. Larger files either take a long time to import or fail to 

import. If the file is larger, consider breaking it into smaller files. For example, one file 
can have a site plan, and another can have a floor plan.

▶▶ Copy and paste the plan into a new AutoCAD file. This keeps stale metadata from 
importing into SketchUp.

▶▶ Run the PURGE and AUDIT commands to clean up any old data that did enter the new 
AutoCAD file.

Figure 5-68:  Exploding a slice severs the model in two.

Figure 5-69:  This office was modeled in SketchUp from an imported AutoCAD plan.  
Courtesy mkerrdesign.com.

http://mkerrdesign.com
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▶▶ Import only necessary geometry. Delete text, dimensions, hatch lines, x-references, layers, 
and any “smart” items (ADT or ARX objects). Delete anything with no 3D relevance, such as 
door and window symbols and furniture blocks, unless you want to use them as references.

▶▶ Explode all polylines, arcs, and filleted lines. Also erase any construction objects, such as 
points created where lines were divided. These often import as artifacts (bits and pieces 
of geometry).

▶▶ Remove all textures, x-referenced and imported files, colors, and dynamic blocks. These 
may cause problems upon import.

▶▶ Ensure that lines connected at endpoints are indeed connected. This is especially  
important for lines that define surfaces you plan to model.

▶▶ Run the Units command so you know what the units are. Scale the file to 1:1 if it isn’t 
scaled to that already. SketchUp 2018 and later enables you to scale the model using the 
CAD file units.

▶▶ Save the AutoCAD file as release 13 or 14, as best import results are obtained with those.
▶▶ Locate the plan at the origin.

Import a DWG File of the Cottage
Let’s import the AutoCAD file shown in 
Figure 5-70.

1.	 Click File>Import, navigate to and select 
the DWG file. Make sure that either Auto-
CAD Files or All Supported Image Types 
is visible in the Files field. Then click the 
Options button (Figure 5‑71).

2.	 In the Options dialog window, check the 
first two boxes (Figure 5‑72). They tell 
SketchUp to remove triangulated lines 
from planes and to orient faces uniformly. 
Set the Units field to the AutoCAD plan’s 
units. Meaning, if the plan’s units are feet, 
set it to feet. If the AutoCAD plan’s scale 
and this field’s scale are different, the plan 
will not enter SketchUp correctly scaled. 
If you don’t know the units, choose Model 
units, and SketchUp will turn one CAD unit 
into 1″ in SketchUp. Alternatively, use a 
large unit type, such as feet or meters, and 
then resize the plan after import.

Figure 5-70:  AutoCAD file simplified 
for import.
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Uncheck the Preserve drawing origin box. SketchUp will then place the imported plan at 
the origin. If the plan is placed elsewhere, “clipping” may occur, a glitch that causes part 
of the plan to disappear. Then click OK.

Figure 5-71:  Locate the file to import.

Figure 5-72:  Set the options.
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3.	 Click Open to import the DWG file into SketchUp. A box appears showing the specific 
data imported. Click again and ta-da! The imported DWG file is now SketchUp geometry. 
It imports as a component, so right-click and choose Explode (Figure 5‑73). If needed, 
scale the plan to its correct dimensions with the Tape Measure.

Some clean-up can be done on the AutoCAD file up after import. Delete unneeded geometry 
by selecting and erasing. Delete unused data at Window>Model Info>Statistics and click 
the Purge Unused button at the bottom (Figure 5‑74). If any AutoCAD blocks came into the file, 
find them in the Components tray and delete them there.

Model the DWG File
Erase unneeded geometry and turn walls into faces by tracing over them with the Pencil 
or the Rectangle. You’ll probably have to do this separately for the walls and interior spaces 
(Figure 5‑75). There’s an extension called S4U Make Face that can help. Extensions are 
discussed in Chapter 9.

Push/pull the walls up (Figure 5‑76). Create heads over doors and windows with the 3-Point 
Rectangle and Push/Pull tools (Figure 5‑77).

Figure 5-73:  The imported DWG file.
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Figure 5-74:  Purge unneeded data that came in with the AutoCAD file.

Figure 5-75:  Trace the plan to create faces.

Figure 5-76:  Push/pull the walls up.
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Export the File
You can also import SketchUp files into 
AutoCAD. All exported plans, elevations, and 
sections keep their true scale, and components 
and layers stay intact. Units default to inches. 
Go to Export>3D Model and export as a 
DWG or DXF file. There’s also a DAE option 
(Figure 5‑78), which enables exporting the 
SketchUp model to other 3D programs such 
Maya, 3DS Max, and Blender.

Interact with Revit, 20-20, and 
Chief Architect
You can import SketchUp models directly into 
Revit and 20-20. Import a Revit model into 
SketchUp by exporting the RVT file as a DWG 
or DXF file, and then importing that file into 
SketchUp. Import 20-20 models into SketchUp 
by exporting the KIT file to a DXF file, and 
then importing the DXF into SketchUp. Import 
SketchUp models directly into Chief Architect; import Chief Architect files into SketchUp as 
3DS Max files. A lot of cleaning up for all will probably be needed.

“Clipping” (Disappearing Geometry)
Clipping is a glitch that causes faces to partially disappear when orbiting and zooming. 
Clipping occurs when geometry is very small or very large or when it’s located far from 
the origin, common with a DWG import. Fix by clicking Zoom Extents, and then move the 
geometry to the origin.

Figure 5-77:  Make door heads with the 3-Point Rectangle and Push/Pull tools.

Figure 5-78:  Export an SKP file to import 
into other programs.
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Move Geometry with Coordinates
To move a far-away piece of geometry to the origin, select it, click Move on a ground-plane 
corner, move the geometry a bit, and type [0,0,0] (include the square brackets). Then hit Enter. 
(Figure 5‑79). The selected geometry will snap there.

This technique also moves distant pieces of geometry together. By now you’ve probably 
experienced the difficulty of moving two far-apart or non-aligned items. The next time that 
happens, click the Text tool (Figure 5‑80) on a corner of one item to see its coordinates. Select 
the other item, activate Move, grab a bottom corner, type those coordinates in square brackets, 
and hit Enter. The item will snap to, or near, the coordinate location.

Add Tags to Control Visibility
Tags are an organizational tool. You create and assign geometry to them, then turn them on and 
off to control the geometry’s visibility. This is useful when viewing or modeling something that 
is obstructed by something else. The turned-off geometry also speeds up regeneration time. Tags 
let you present different design options for one space, which we’ll discuss in Chapter 8.

Click on the Tags tray, click on the plus sign to create a tag, and name it. Select geometry to 
put on it through the Entity Info box. In the Entity Info box, click the dropdown arrow until the 
new tag appears, and click on it. The selected geometry is now on that tag, and by clicking the 
eye in the Tags tray, you can turn its visibility on and off. The pencil graphic on the far right 
of a tag indicates that tag is current, meaning everything you draw will go onto that tag. You 
can’t make the current tag invisible.

Only put groups and components on any tags you create, not edges and faces. This will 
make it harder to “lose” pieces of geometry or deform them. All loose geometry should be on 
the “Untagged” tag at the top of the list. You cannot rename this tag. You can click the Pencil 
on any tag to make it current, but experienced SketchUp users keep the default Untagged tag 
current because organizational problems occur when others are made current. When a tag is 
turned off, only visibility is affected; the geometry on that tag is still attached to geometry on 
other tags. You’ll deform your model by forgetting about geometry on invisible layers.

Delete a tag by right-clicking on it and choosing Delete. A window will appear asking if you 
want to move its items to another tag or just delete them.

Figure 5-79:  Type coordinates to move geometry. Figure 5-80:  The Text tool.
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Change Line Type with Tag
Click on the Tag icon and then click it onto a named tag to bring up line type choices 
(Figure 5‑81). Click on the line type you want. Then click on a line in the model with the Tag 
icon and that line will change to the chosen line type.

Modeling Tips
▶▶ Reconstruct a broken face by tracing the face’s perimeter. If the face won’t fill, review 

Chapter 4 for possible causes.
▶▶ Inference-match to obtain line lengths, watch for inference tooltips when connecting 

the lines, and draw along the axes. Hold the Shift key down to lock the Pencil and Move 
tools along the axes.

▶▶ If geometry is in an awkward location to modify, cut and paste it somewhere else on the 
screen, work on it there, and then move it back.

▶▶ Make a copy of the work and try different modeling techniques on it. For instance, if 
drawing multiple parallel lines is problematic, select one already drawn and copy it to 
other locations.

▶▶ If something goes wrong, undo is your friend.

Make new tag

Tags

Figure 5-81:  Change line type with the Tag tool.
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Model a Sloped Roof with the  
Protractor Tool
Want a sloped ceiling? Group the whole house so the 
roof doesn’t stick to it. Then activate the Protractor tool 
(Figure 5‑82). It measures angles and creates angled 
guidelines.

The protractor aligns with the plane it is on. Click the 
protractor onto the appropriate plane; click it again; move 
the protractor until the angle you want appears (read it in 
the Measurements box); click a third time to lock that angle 
in place (Figure 5‑83). When the cursor is close to the protractor, it snaps to 15° increments. 
When the cursor is farther away, it moves more smoothly and precisely. The protractor leaves a 
guideline at the angle specified.

After you set the angle, trace over the guideline with the pencil. Then push/pull the roof’s 
shape to give it volume (Figure 5‑84). From the inside the roof will look like a sloped ceiling.

Figure 5-82:  The Protractor  
tool.

Figure 5-83:  Setting a roof angle with the Protractor.

Figure 5-84:  Trace and push/pull the roof.



129Chapter 5: Drafting, Modeling, and Furnishing a Floor Plan

To measure an angle with the protractor, click it on an endpoint; click it under the other 
endpoint, and then click on the opposite endpoint (Figure 5‑85).

Geo-locate a Model
SketchUp can place the model in its geographical location with online digital information. 
Geo-location is helpful for shadow studies and presentations. The Geo-location function imports 
both 2D imagery and 3D contours, if available. Here’s how to access it.

1.	 Click on File>Geo-location>Add location. A map will appear (Figure 5‑86).

2.	 Zoom into the area you want or type an address. Select a region by drawing a window 
around it. Choose a digital imagery provider (I chose Digital Globe) and click the Import 
button (Figure 5‑87).

1.
Click

2.

3.

Click

Click

Figure 5-85:  Click three times to measure an angle.
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The terrain comes in as a flat raster file. Open the Tags tray and you’ll see there are two tags. 
Turn off the Location Snapshot tag and turn on the Location Terrain tag to get the result in the 
bottom graphic of Figure 5‑88.

Figure 5-87:  Select the region to import.

Figure 5-86:  The Geo-location function.
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Fun Exports and Imports
You can place your model on Google Earth. This is a 3D site of the whole globe built on satellite 
imagery, aerial photography, and Geographical Information Systems (GIS) data, and lets you 
view cities and landscapes from all angles. Export the SketchUp model as a Google Earth 
(KMZ) file at File>Export>3D Model>Google Earth File. Then open Google Earth, go to 
File>Open, navigate to the KMZ file, and bring it in. The model will appear correctly located 
and oriented in Google Earth.

Do you design video game assets? Import and export Collada (DAE) files, which are used in 
games. If you extract a character as a DAE file from a game, you can import it into SketchUp.

Tags

Figure 5-88:  The imported terrain.
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Is SketchUp Running Slow?
By now you may have experienced SketchUp slowdowns, freezes, and display abbreviations, 
where bounding boxes are shown instead of components, and details/textures lost. Assuming 
your computer’s RAM, processor speed, and graphics card meet minimum standards, 
slowdowns are caused by bloated geometry, which means an excessive number of polygons 
(the plane figures that make up a SketchUp model). This isn’t necessarily the same thing as a 
large file size. A large file size can reflect bloated geometry, and indicates complexity, but it’s 
possible to have a small file size and a large polygon count (the number of polygons in a model).

Check file size by right-clicking the model’s desktop icon and choosing Properties. The Ware‑
house doesn’t accept uploads larger than 100 MB so use that as a guide.

Make SketchUp Run Faster by Keeping the Polygon 
Count Down
SketchUp calculates each polygon when you pan, orbit, and zoom, so keep the polygon count 
down. Be cognizant of how much geometry the shapes you create have. Figure 5‑89 shows two 
cylinders with the hidden geometry option turned on. The left is made with the default 24 
sides, the right with 12 sides. While the left one looks smoother, it has more geometry. If the 
circle isn’t important, will 12 sides suffice?

SketchUp also makes hidden lines when auto-
folding, creating curves, and using Follow Me (the 
path line gets left behind). Some of this can be 
erased. Examine the model in Hidden and X-ray 
modes (View>Face style>X-ray) for extra geom‑
etry. You may find parts stuck into each other; not 
deliberately intersected, just stuck (Figure 5‑90). 
Erasing them reduces the polygon count and keeps 
the model clean.

Figure 5-90:  X-ray mode may show 
extra pieces.

Figure 5-89:  The smoother circle has more geometry.
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At Window>Model Info>Statistics the amount of geometry is displayed. More than 
100,000 edges causes slowdowns. Following are strategies to manage the polygon count and 
hence make SketchUp run faster.

Strategies to Make SketchUp Run Faster
▶▶ Purge unused files. In the Components, Materials, and Styles trays, click In Model (the 

house icon) and then click the Details arrow. Choose Purge Unused (Figure 5‑91). 
At Window>Model Info>Statistics, click the Purge Unused button at the bottom 
(Figure 5‑92). This removes unused materials, components, and styles all at once, as well 
as unused tags and stale metadata accumulated during the modeling process.

Figure 5-92:  Purge everything unused.

Figure 5-91:  Purge unused materials, components, and styles.
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▶▶ Use images instead of textures when only one instance is needed. Images take less space 
than textures. Choose JPGs or PNGs when possible, as they take the least space.

▶▶ Use appropriate sizes for imported images. Is the image a major part of the model? Must 
it display in high resolution? If not, cut its image size down in digital imaging software 
and import a smaller resolution file, such as 512k × 512k.

▶▶ Model minor items simply. A small, detailed model takes up as much file space as a 
large one. When zooming in to work on a small piece, it’s easy to lose sight of its relative 
importance. But small items should be simpler than large ones, and background items 
even simpler.

▶▶ Download components to the desktop and purge unused/unneeded items before copy‑
ing or pasting them into the model.

▶▶ Use components for multiple copies. Components take less space than groups. Use 
groups for single instances only.

▶▶ Model half of symmetrical items. Make it a component and copy/flip along axis to 
complete. This saves time and takes up less space than a fully modeled component.

▶▶ Place groups and components on their own tags and turn off the tags that aren’t needed. 
Turned-off tags don’t get calculated. Until you’re ready to print, does entourage such as 
trees and people need to be displayed?

▶▶ Use 2D components for people, cars, and trees that always face the camera (check that 
setting in their editing box). If a plan view isn’t needed, use 2D plants. Put them in 3D 
pots to look more convincing.

▶▶ Model with textures off. Textures are calculated with each pan, orbit, and zoom. Click 
View>Face Style>Monochrome after you’re done painting. Make a scene with the 
Shaded with textures face style to quickly view it as needed.

▶▶ Model with a simple default style. Don’t model with an elaborate style, as it takes longer 
to recalculate when rendering, panning, orbiting, and zooming.

▶▶ Turn off shadows while modeling. They slow the model down and are only needed when 
adjusting position and value, and when printing a hard copy.

▶▶ Turn off edge profiles, depth cue, and extensions at View>Edge Style by unchecking 
their boxes (Figure 5‑93). All these settings are on by default but add little and slow 
the model down a lot. In the Styles tray, click Edit and set the edge color to All the same 
(Figure 5‑94). Hide any watermarks—click on the fourth cube under the Edit tab to 
access watermarks (Figure 5‑95).
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